PDA

View Full Version : Problem installing 6.5 - error when build-perl-modules.pl try to download modules



binky72
2006-09-21, 08:39
I am trying to upgrade from 6.2.2 to 6.5 on my gentoo box with use of the tar.gz package.

When I try to run ./build-perl-modules.pl I get the following errors:

Please enter a perl binary to use (defaults to /usr/bin/perl)
This must be the same perl binary that you ran this program with -->
Please enter the path to your SlimServer directory (ex: /usr/local/slimserver) --> /usr/local/slimserver
Please enter a directory to download files to --> /tmp
Downloads will use lwp to fetch tarballs.

Downloading Compress-Zlib-1.41.tar.gz to: /tmp
Use of uninitialized value in hash element at /usr/local/slimserver/CPAN/LWP/Protocol.pm line 55, <STDIN> line 3.
Use of uninitialized value in pattern match (m//) at /usr/local/slimserver/CPAN/LWP/Protocol.pm line 58, <STDIN> line 3.
Use of uninitialized value in concatenation (.) or string at /usr/local/slimserver/CPAN/LWP/Protocol.pm line 38, <STDIN> line 3.
Use of uninitialized value in string eq at /usr/local/slimserver/CPAN/LWP/UserAgent.pm line 195, <STDIN> line 3.
Something looks wrong - I couldn't read /tmp/Compress-Zlib-1.41.tar.gz, which I just downloaded.
Uncompressing..
sh: Compress-Zlib-1.41.tar.gz: No such file or directory
Couldn't change to Compress-Zlib-1.41 : No such file or directory at ./build-perl-modules.pl line 222, <STDIN> line 3.


I didnt't have this problem installing 6.2.2. The internet connection is working.
Dos anyone have a clue what could be wrong?

Regards
Eirik

binky72
2006-09-21, 12:28
I managed to fix it by changing line 145 in 'build-perl-modules.pl'.

from: $downloadUsing = 'lwp';

to: $downloadUsing = 'wget';

I have no clue why 'lwp' didn't work. Hopefully some of you have a few tips.