PDA

View Full Version : 6.5 Internet Radio - Connection Timed Out



googdot
2006-09-20, 19:31
Hi All.

Since upgrading to 6.5, I can no longer receive any internet radio. This began with the 6.5 beta versions - everything was fine in 6.2 and 6.3. It does not matter how I try to connect: Silm Devices Picks, RadioTime, directly entering a URL, etc. I am on Mac OSX 10.4.8 running the latest offical release 6.5.

Here is the debugging log:

2006-09-21 14:22:37.2227 This player supports direct streaming for http://kexp-mp3-2.cac.washington.edu:8000/ as http://kexp-mp3-2.cac.washington.edu:8000/, let's do it.
2006-09-21 14:22:37.2266 setting up direct stream (2358118622:8000) autostart: 2.
2006-09-21 14:22:37.2268 request string: GET / HTTP/1.0
Accept: */*
Cache-Control: no-cache
User-Agent: iTunes/4.7.1 (Macintosh; N; Mac OS X 10.4.7 (8J135); ppc-darwin; EN; utf8) SlimServer/6.5.0/9916
Icy-MetaData: 1
Connection: close
Host: kexp-mp3-2.cac.washington.edu:8000


2006-09-21 14:22:47.2297 Oh, well failed to do a direct stream for: http://kexp-mp3-2.cac.washington.edu:8000/ [Connection timed out]
2006-09-21 14:22:47.2303 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/Users/goog/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Squeezebox2.pm line 569)
frame 1: Slim::Player::Squeezebox2::failedDirectStream (/Users/goog/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Slimproto.pm line 526)
frame 2: Slim::Networking::Slimproto::_disco_handler (/Users/goog/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Slimproto.pm line 387)
frame 3: Slim::Networking::Slimproto::client_readable (/Users/goog/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 238)
frame 4: Slim::Networking::Select::select (./slimserver.pl line 487)
frame 5: main::idle (./slimserver.pl line 440)
frame 6: main::main (./slimserver.pl line 1039)

I have tried increasing the server setting for radio timeouts to 20, but no luck. There seems to be an error coming up within the server itself.

Can anyone help? Anybody else have the same issue?

Cheers
Frank

dean
2006-09-20, 19:56
Is it possible that the new installation requires you to reconfigure
your firewall? It looks like from the log that your player can't
make an outgoing connection for internet radio.

Note that in 6.5, the player directly connects to the radio station
in most cases.

googdot
2006-09-21, 13:02
Ah-Ha! So the player now connects directly to the radio station - that was the problem. I needed to reconfigure the DNS address to make this work.

How is this different to connecting to radio in earlier versions? It seems quite a few people on the forum are having trouble with Internet Radio since the upgrade, so would be great to know what's changed.

Many thanks.

Cheers
Frank

radish
2006-09-21, 13:27
It used to be that the slimserver would act as a proxy for the stream, so the SB connected to the slimserver which in turn connected to the stream server. Now (it seems) the middleman (the slimserver) has been taken out.

This is news to me too - I haven't upgraded to 6.5 yet but when I do I'll have to do some serious tweaking as my players are on a private network. Hmmmm...

Dean - is it possible to disable this change through config?

wrorke
2006-09-23, 11:25
The community has an impressive amount of competence, but not all of us are so facile with the technical details.

I'm getting a "Connection timed out" message too. And I see I need to do something with my DNS settings, but I do not know specifically what I need to do.

My Squeezebox is connected through an ethernet switch to a laptop which is connected via 802.11g to a router (hardware firewall) and out to DSL. Not running software firewall.

What do I need to do with the DNS for which device(s)?

Thanks. (I'm really looking forward to using RadioTime!)

wrorke
2006-09-23, 15:46
One of the added bonuses of a Squeezebox is you learn lots about computers and networking.

I figured out my problem -- my Squeezebox did not have a connection to the internet. I was running hardwire to the laptop and wireless from the laptop to the DSL router.

I changed the SB to wireless direct to the DSL router and all is well. (Change SB IP address to talk to router, tell SB the wireless IP of the server, voila!)

I guess it's time to finish hooking up the ethernet between the laptop and SB to the router. Tomorrow perhaps.

Linzer
2006-11-28, 21:08
Sorry for dragging up an old thread. Is there any way of reporting on what the hardware (SB3s in my case) has for DNS entries? I've looked through the web interface and am not seeing anything.

radish
2006-11-28, 21:22
Hold down left from the main menu and you'll go back to the setup menu. One of the options is to display the current settings, which will include DNS.

Linzer
2006-11-28, 21:36
Thanks radish. That showed me that my SB3 has a valid DNS entry in it. I'm seeing the exact same kind of errors as shown below.

2006-11-28 21:35:41.0257 Backtrace:

frame 0: Slim::Player::Source::errorOpening (/usr/share/perl5/Slim/Player/Squeezebox2.pm line 569)
frame 1: Slim::Player::Squeezebox2::failedDirectStream (/usr/share/perl5/Slim/Networking/Slimproto.pm line 526)
frame 2: Slim::Networking::Slimproto::_disco_handler (/usr/share/perl5/Slim/Networking/Slimproto.pm line 387)
frame 3: Slim::Networking::Slimproto::client_readable (/usr/share/perl5/Slim/Networking/Select.pm line 238)
frame 4: Slim::Networking::Select::select (/usr/sbin/slimserver line 487)
frame 5: main::idle (/usr/sbin/slimserver line 440)
frame 6: main::main (/usr/sbin/slimserver line 1039)


Software is 6.5.0 debian package, firmware version is 64 (if I remember correctly). Anyone care to make a recommendation as to a what debugging options to turn on (directstream, mdns, remotestream, stream, stream_v, etc.) or better yet anyone know of a solution?

Linzer
2006-11-29, 20:29
OK, darndest thing but here's what I did to resolve my Internet Radio streaming problems.

1) Held down the left button on the remote until it brought me to the setup. (I was going to get its IP and try to sniff the traffic; I was that desperate.)

2) It was at this point I saw the Connect to Squeeze Network and I though "I wonder if that works?" so I tried it. A couple of seconds later...absolutely no display on my SB3.

3) Checked the Slimserver and saw the software was still running. Oh bad things were running through my head at this point.

4) Unplugged the power from my SB3, waited 10 seconds and then plugged it back in.

5) SB3 came back to life but this time logged into the Squeeze Network. I tried a couple of different stations and things seemed to work well.

6) I logged out of the Squeeze Network and verified I could see my Slimserver.

7) Tried streaming Internet Radio and low and behold I could now stream Shoutcast, Live Music Archive, etc.

So in the end a power reset of the SB3 seemed to cure my problems; at least as far as I can deduce.