PDA

View Full Version : Problem with skins?



ron 'coyote' lussier
2003-12-06, 08:22
Hi there,

I've installed SlimServer 5.0.1, and for some reason, the only skin
that seems to be working is 'Standard'. All of the others appear,
including 'Hypo 1.3', but only Standard appears to work correctly.
(The others all give me generic-looking text.)

Any ideas as to why this would be happening? (I'm on Mac OS X 10.3.1)

coyote
--- , /),
(( -.((_)) _,) Joyous Solstice!
,\`.' `-','
`.> (,-
,', `._,)
ron lussier / lenscraft (( ) (`--' fine art
photography
67 crescent avenue `'( ) _ _,-.\
sausalito / ca 94965 /,' \( ) `'
http://lenscraft.com/
(( `\
`

Kevin Deane-Freeman
2003-12-06, 11:57
Quoting ron 'coyote' lussier <rlussier (AT) lenscraft (DOT) com>:

> Hi there,
>
> I've installed SlimServer 5.0.1, and for some reason, the only skin
> that seems to be working is 'Standard'. All of the others appear,
> including 'Hypo 1.3', but only Standard appears to work correctly.
> (The others all give me generic-looking text.)
>
> Any ideas as to why this would be happening? (I'm on Mac OS X 10.3.1)


the new SlimServer has changed several things in regards to skins. Skins
designed for Slimp3 server are no longer compatible. You have to convert them
using skinjob.pl from here:

http://www.slimdevices.com/downloads/nightly/slimserver/tools/skinjob.pl

run it from your skins directory with the skin folder as the option:
../skinjob.pl Hypo_1.3

it will rewrite hypo and copy the old version to a folder named, old.

As for the none of the other skins working, I'm not sure. They certainly should
if they come with the server. These include Purple, Handheld, Fishbone,
Sensemaker, Dark, etc.

-kdf

ron 'coyote' lussier
2003-12-07, 09:37
Unfortunately this didn't work. (Well, it *ran*, but didn't fix the
problem.)

One thing I notice is that when I select the 'standard' skin and then
surf to http://localhost:9000/slimserver.css, I see a proper style
sheet. If I select 'Hypo1.3' and then surf to
http://localhost:9000/slimserver.css, I see a blank page.

When I look at the file
~/Library/SlimDevices/html/Hypo1.3/slimserver.css, there is definitely
a very complex stylesheet there.

Any ideas?

coyote

On Dec 6, 2003, at 10:57 AM, Kevin Deane-Freeman wrote:

> Quoting ron 'coyote' lussier <rlussier (AT) lenscraft (DOT) com>:
>
>> Hi there,
>>
>> I've installed SlimServer 5.0.1, and for some reason, the only skin
>> that seems to be working is 'Standard'. All of the others appear,
>> including 'Hypo 1.3', but only Standard appears to work correctly.
>> (The others all give me generic-looking text.)
>>
>> Any ideas as to why this would be happening? (I'm on Mac OS X 10.3.1)
>
>
> the new SlimServer has changed several things in regards to skins.
> Skins
> designed for Slimp3 server are no longer compatible. You have to
> convert them
> using skinjob.pl from here:
>
> http://www.slimdevices.com/downloads/nightly/slimserver/tools/
> skinjob.pl
>
> run it from your skins directory with the skin folder as the option:
> ./skinjob.pl Hypo_1.3
>
> it will rewrite hypo and copy the old version to a folder named, old.
>
> As for the none of the other skins working, I'm not sure. They
> certainly should
> if they come with the server. These include Purple, Handheld,
> Fishbone,
> Sensemaker, Dark, etc.
>
> -kdf
>
>
>

Craig Brannan
2003-12-07, 11:39
A number of months ago I posted this same problem with using the
~/Library/SlimDevices... location for skins. Didn't get much (if any)
feedback.

I was trying to install a 3rd party skin in that directory and couldn't
ever get it to work.

I just went back to using the default skin location
(/Library/PreferencePanes/SlimServer.prefpane) and everything was
fine...

It looks like the ~/Library/SlimDevices location is great for plug-ins,
Strings.txt , and preferences... but I don't think it works for skins.

Craig.

On Dec 7, 2003, at 11:37 AM, ron 'coyote' lussier wrote:

> Unfortunately this didn't work. (Well, it *ran*, but didn't fix the
> problem.)
>
> One thing I notice is that when I select the 'standard' skin and then
> surf to http://localhost:9000/slimserver.css, I see a proper style
> sheet. If I select 'Hypo1.3' and then surf to
> http://localhost:9000/slimserver.css, I see a blank page.
>
> When I look at the file
> ~/Library/SlimDevices/html/Hypo1.3/slimserver.css, there is definitely
> a very complex stylesheet there.
>
> Any ideas?
>
> coyote
>
> On Dec 6, 2003, at 10:57 AM, Kevin Deane-Freeman wrote:
>
>> Quoting ron 'coyote' lussier <rlussier (AT) lenscraft (DOT) com>:
>>
>>> Hi there,
>>>
>>> I've installed SlimServer 5.0.1, and for some reason, the only skin
>>> that seems to be working is 'Standard'. All of the others appear,
>>> including 'Hypo 1.3', but only Standard appears to work correctly.
>>> (The others all give me generic-looking text.)
>>>
>>> Any ideas as to why this would be happening? (I'm on Mac OS X
>>> 10.3.1)
>>
>>
>> the new SlimServer has changed several things in regards to skins.
>> Skins
>> designed for Slimp3 server are no longer compatible. You have to
>> convert them
>> using skinjob.pl from here:
>>
>> http://www.slimdevices.com/downloads/nightly/slimserver/tools/
>> skinjob.pl
>>
>> run it from your skins directory with the skin folder as the option:
>> ./skinjob.pl Hypo_1.3
>>
>> it will rewrite hypo and copy the old version to a folder named, old.
>>
>> As for the none of the other skins working, I'm not sure. They
>> certainly should
>> if they come with the server. These include Purple, Handheld,
>> Fishbone,
>> Sensemaker, Dark, etc.
>>
>> -kdf
>>
>>
>>

dean
2003-12-08, 14:44
Sorry we didn't resolve this issue before, but I found and fixed the
problem. Look for the html folder in your Library/SlimDevices folder
working better in the next release.


On Dec 7, 2003, at 10:39 AM, Craig Brannan wrote:

> A number of months ago I posted this same problem with using the
> ~/Library/SlimDevices... location for skins. Didn't get much (if any)
> feedback.
>
> I was trying to install a 3rd party skin in that directory and
> couldn't ever get it to work.
>
> I just went back to using the default skin location
> (/Library/PreferencePanes/SlimServer.prefpane) and everything was
> fine...
>
> It looks like the ~/Library/SlimDevices location is great for
> plug-ins, Strings.txt , and preferences... but I don't think it works
> for skins.
>
> Craig.
>
> On Dec 7, 2003, at 11:37 AM, ron 'coyote' lussier wrote:
>
>> Unfortunately this didn't work. (Well, it *ran*, but didn't fix the
>> problem.)
>>
>> One thing I notice is that when I select the 'standard' skin and then
>> surf to http://localhost:9000/slimserver.css, I see a proper style
>> sheet. If I select 'Hypo1.3' and then surf to
>> http://localhost:9000/slimserver.css, I see a blank page.
>>
>> When I look at the file
>> ~/Library/SlimDevices/html/Hypo1.3/slimserver.css, there is
>> definitely a very complex stylesheet there.
>>
>> Any ideas?
>>
>> coyote
>>
>> On Dec 6, 2003, at 10:57 AM, Kevin Deane-Freeman wrote:
>>
>>> Quoting ron 'coyote' lussier <rlussier (AT) lenscraft (DOT) com>:
>>>
>>>> Hi there,
>>>>
>>>> I've installed SlimServer 5.0.1, and for some reason, the only skin
>>>> that seems to be working is 'Standard'. All of the others appear,
>>>> including 'Hypo 1.3', but only Standard appears to work correctly.
>>>> (The others all give me generic-looking text.)
>>>>
>>>> Any ideas as to why this would be happening? (I'm on Mac OS X
>>>> 10.3.1)
>>>
>>>
>>> the new SlimServer has changed several things in regards to skins.
>>> Skins
>>> designed for Slimp3 server are no longer compatible. You have to
>>> convert them
>>> using skinjob.pl from here:
>>>
>>> http://www.slimdevices.com/downloads/nightly/slimserver/tools/
>>> skinjob.pl
>>>
>>> run it from your skins directory with the skin folder as the option:
>>> ./skinjob.pl Hypo_1.3
>>>
>>> it will rewrite hypo and copy the old version to a folder named, old.
>>>
>>> As for the none of the other skins working, I'm not sure. They
>>> certainly should
>>> if they come with the server. These include Purple, Handheld,
>>> Fishbone,
>>> Sensemaker, Dark, etc.
>>>
>>> -kdf
>>>
>>>
>>>