PDA

View Full Version : "Failed to find Softsqueeze libraries" error



andy_c
2006-09-16, 08:03
Hi all,

I'm running Windows XP and SlimServer 6.3.1. I've done evaluations of several different builds of the 6.5 beta and returned to 6.3.1 each time. Each time I returned to 6.3.1, I had no problem setting it up again, including SoftSqueeze - except the last time. The last time was with 6.5b3. Now when I try to do the install or run of SoftSqueeze, it looks like it gets almost all the way through, except at the very end it bombs with an error dialog box saying "Failed to find Softsqueeze libraries".

Here's what I did to uninstall the 6.5b3.
1) From the tray icon, choose "Stop SlimServer"
2) After SlimServer stops, choose "Exit" from the tray icon
3) Run the uninstall program from Control Panel
4) Delete the directory that SlimServer was in

Then I reinstalled SlimServer 6.3.1, allowing it to re-create the SlimServer directory that I deleted above.

Since I completely blew away the prior installation, I'm baffled as to what could be causing this SoftSqueeze error - especially since I've done this successfully about five times before with various 6.5 beta builds.

Any help would be much appreciated!

andy_c
2006-09-18, 09:39
Here's an update:

I have SoftSqueeze working now, but I had to use a workaround. The normal way of installing and running SoftSqueeze still doesn't work.

Here's what I did. I went to the SoftSqueeze sourceforge site and found that one way to launch SoftSqueeze is to just double-click on the softsqueeze.jar file. I did so and everything worked fine. But if I tried to launch SoftSqueeze from its shortcut, a download takes place, then the "Failed to find Softsqueeze libraries" error message happens every time. So I looked up the properties for .jar files in Windows Explorer. Based on this info, I just ended up changing the "target" properties of the SoftSqueeze shortcut to:

"C:\Program Files\Java\jre1.5.0_07\bin\javaw.exe" -jar "C:\Program Files\SlimServer\server\HTML\EN\html\softsqueeze\s oftsqueeze.jar"

Based on this, I'm wondering whether there's something funky with the download process invoked by the original SoftSqueeze shortcut.

rbdavis
2006-10-12, 01:17
I have exactly the same problem.

I have installed and uninstalled various versions of 6.5, which unfortunately has not worked due to a FileCache problem.

I then thoroughly uninstalled last version, deleting directory. When i reinstall 6.3 I am unable to run SoftSqueeze on my remote machines, with the same error "Failed to find softsqueeze libraries".

I did try adapting the workaround mentioned above (my paths were different), but this will make it impractical use SoftSqueeze as I need. (e.g. i quite often open up SoftSqueeze at parties, but i can't imagine hunting around forums and the user's PC to get it working - we'd just have to give up!)

rbdavis
2006-10-12, 06:35
Oh - and this doesn't seem to work at all on remote machines. Only on machines that have SlimServer 6.3 already installed! Which of course is not longer available online.

So if I want to run SoftSqueeze at a friend's I have to bring a CDROM of SlimServer 6.3, install it, install SoftSqueeze, go online to the forum, look up this thread, copy the link, check the local PC's JRE directory, check the path to SoftSqueeze, edit the shortcut.... Aaaaaargghhh!!

Mark Lanctot
2006-10-12, 06:53
Only on machines that have SlimServer 6.3 already installed! Which of course is not longer available online.

http://www.slimdevices.com/downloads/ ?

andy_c
2007-03-24, 16:11
Well, I finally found a way to fix this SoftSqueeze problem in 6.3.1 under WinXP in a way that doesn't require the workaround hack I mentioned in a post above. Here's what I did.

1) Download http://slimdevices.com/downloads/SlimServer_v6.3.1/SlimServer_v6.3.1.perlscripts.ZIP
Note: This assumes you're running 6.3.1!!! If running a different SlimServer version, find the corresponding zip file (not the exe installer, but the zip) from the downloads section.
2) Unzip it to a temporary folder
3) Navigate to the
C:\Program Files\SlimServer\server\HTML\EN\html
folder where SlimServer is installed. Use your SlimServer install path if different from above.
4) Delete the entire softsqueeze folder underneath the path in step 3 (and all its subfolders)
5) In the unzipped file from part 2 above, locate the softsqueeze subfolder in the path analogous to that of step 3 above.
6) Copy and paste this folder to your SlimServer installation so it's underneath the path in step 3 above (same path as where the original softsqueeze folder was before, but now the contents are coming from the downloaded zip file). Now the SoftSqueeze subfolder of your SlimServer has been replaced with the one from the downloaded zip file.
7) Stop and restart SlimServer
8) Run the normal SoftSqueeze install procedure from the help page.

This made the SoftSqueeze error go away for me. Hope it works for you.