PDA

View Full Version : Album Art Images in Browser Interface



msandover
2006-09-13, 08:10
Turned off the "Look for Album Art" choice in Performance in server settings at one time to make scanning quicker. Would like to see album art back in the browser interface and no matter what I restore nothing shows anymore.

All the proper .jpg files are still out in the file system and yet SlimServer doesn't seem to pick them up now.

Any ideas on what to tweak to get this functioning again?

slimpy
2006-09-13, 08:13
"Clear library and rescan" will do the trick.

-s.

mherger
2006-09-13, 09:08
> Turned off the "Look for Album Art" choice in Performance in server
> settings at one time to make scanning quicker. Would like to see album
> art back in the browser interface and no matter what I restore nothing
> shows anymore.

Did you a rescan of your collection after turning that option on?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

msandover
2006-09-13, 13:20
"Clear library and rescan" will do the trick.

-s.

Hmmm. Done this many times. The "album.jpg" files and others are definitely on the disc but the clear-rescans I've done don't do it.

Any other places I could make sure I've not turned something off?

msandover
2006-09-13, 13:22
> Turned off the "Look for Album Art" choice in Performance in server
> settings at one time to make scanning quicker. Would like to see album
> art back in the browser interface and no matter what I restore nothing
> shows anymore.

Did you a rescan of your collection after turning that option on?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)


Yes and the rescans don't do it. And I've also checked to be sure the browser cache's cleared (I use both IE and Mozilla and album art's disappeared from either interface when looking at SlimServer)

slimpy
2006-09-14, 00:20
Turn on "Look for artwork", shut down slimserver, delete the db file from the slimserver cache directory and restart slimserver.
Your library should now be rescanned. Make sure the "Look for artwork" setting is still turned on after the restart.

-s.

msandover
2006-09-14, 08:33
Will try that. Deleting the db may work since I have only done complete rescans but on whatever file exists at the time. Thank you for the suggestion.
msandover

msandover
2006-09-15, 06:39
The .db is persistent - it comes right back after being deleted after Slimserver has been stopped, the database has been deleted, and then Slimserver has been restarted! Same size, etc. The erase and rebuild scan now shows Artist names in text in the Browse Album Art function but still no pictures. The pictures are in with the MP3 files on the disk in all cases. Any further ideas?!

Kyle
2006-09-15, 09:40
This may not be the case for you since you apparently once had album art working, but I use Windows, and I worked for weeks to get album art to show up. Seems my OS was set not to display the .jpg suffix, so I had to turn that on manually. Once I did that, album art displayed fine.

msandover
2006-09-19, 08:21
I have tried all that folks have suggested and nothing's worked despite some of the solutions sounding obvious. Best I get now is the title/artist of the album prints in the "browse artwork" screen but no pictures. The capability to display the cover art seems to be hosed permanently. All these musicserver softwares (I use Twonky also sometimes) are so not ready for prime time. I'm leaving well enough alone. I don't need to see the cute thumbnails - I know who does what album! It would be nice if things worked properly just based on making choices on pulldowns, etc.

I'd rather not break the basic program functionality by playing in the linux stuff (I have it running on a NAS and don't want or need to have my PC on to stream music). The program streams ok so I'm leaving it at that. Thanks for your input.

aubuti
2006-09-19, 08:33
As you did have album art showing before I doubt this is the solution, but it's worth a shot: have you double-checked the permissions on the album.jpg or cover.jpg files?