View Full Version : permissions

Matt Shaw
2003-12-05, 11:33
Ignore this... Finally got all sorted - and on 5.01.

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Matt Shaw
Sent: 05 December 2003 18:18
To: 'SlimDevices Discussion'
Subject: [slim] permissions

Ditto... Everything was working OK under 4.x... And then 5.0. But when I
went to 5.01 and pointed it to my network drive that contains my music,
it keeps coming back with "Folder invalid".

Got fed up of that so I uninstall and went back to 5.0... And still have
the problem. So now having to run the server application on my main
machine where the music is local to it before it will play them.

Last time I had this (going from 4.x to 5.0) I had to unshared my music,
create a new folder and then share that - a bit over kill but it worked.

Maybe I'm missing something here.

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Theo M
Sent: 04 December 2003 19:38
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] permissions

I am having playlist problems. everything seems to work ine. music is
scanned and folder is valid, but when I click + to add to playlist, the
refreshes and the playlist remains empty. In desparation I have chmod
the entire slimserver folder and the entire music directory. This is
on Linux. Is there an apache permissions thing Im missing? Help!

2003-12-05, 11:46
Quoting Matt Shaw <Yahoo (AT) chercott (DOT) com>:

> Ignore this... Finally got all sorted - and on 5.01.

Maybe you'd care to share the details to avoid some other user the frustration
you obviously experienced trying to make it work.

This mail sent via webmail.pagefamily.net

2003-12-08, 07:51
I had a permissions problem, too, for a saved playlist. It was easy
to fix, but the error message was quite misleading --- slimserver 5.01
claimed that I already had a playlist by the same name. In fact, the
problem was that slimserver didn't have write permission in the
playlist directory. Seems like this should be fixed, so that file
permissions are checked and an appropriate error message is printed.
If someone's not looking at it, I could have a peek at the code

Rob Studdert
2003-12-08, 20:45
On 6 Dec 2003 at 19:05, Matt Shaw wrote:

> I only wish I knew. This time round I didn't uninstalled 5.0 when going
> over to 5.01 - whether that had an affect or not I don't know.
> My shared network drive I unshared and reshared and then every worked.
> 5.01 did take a long time to first see the file structure. Then it was
> sluggish to find a song.... It then delayed in playing the song (a good
> few minutes). Then suddenly everything went OK and now I have no
> problems browsing music or playing it. (currently looking at 7,000
> songs)

My Slimserver (NT4SVR) looks to a network drive (NT4WS) for it's audio file and
playlist directories and I too had problems with 5.0.1 and the latest 5.0.3
seeing directories that were valid under 4.2.6. I completely removed the
installation and reinstalled 5.0.3 and the server can now see the directories,