PDA

View Full Version : Official 6.5.0 Beta 2 - Please Test!



Dan Sully
2006-09-11, 00:12
All - I've just released our official beta 2 release for 6.5.

Many, many improvements have gone in over the past few months, and we feel
that this release is substansially better than 6.3.

http://www.slimdevices.com/downloads/SlimServer_v6.5.0b2/

Major changes include:

* Support for Transporter, Slim Device's newest audio player.

* Many firmware fixes, including native Ogg support.

* Better Unicode support, including Hebrew.

* Live Music Archive, RadioGuide & Improved Slim Picks.

* Nokia 770 specific skin.

* Separate scanning process for improved performance.

Please give it a try, and report any bugs you find:

http://bugs.slimdevices.com/

We're looking to release an official 6.5.0 on the 18th.

Thanks.

-D
--
<dr.pox> do they call it 'gq' because it makes your text fashionable?

=?UTF-8?B?UGV0ZXIgTsO1dQ==?=
2006-09-11, 04:08
Dan Sully wrote:
> All - I've just released our official beta 2 release for 6.5.
>
> Many, many improvements have gone in over the past few months, and we
> feel that this release is substansially better than 6.3.
>
> http://www.slimdevices.com/downloads/SlimServer_v6.5.0b2/
>
> Major changes include:
>
> * Support for Transporter, Slim Device's newest audio player.
>
> * Many firmware fixes, including native Ogg support.
>
> * Better Unicode support, including Hebrew.
>
> * Live Music Archive, RadioGuide & Improved Slim Picks.
>
> * Nokia 770 specific skin.
>
> * Separate scanning process for improved performance.
>
> Please give it a try, and report any bugs you find:

Hi,


I upgraded (uninstalled, rebooted, removed directories left), from an
earlier nightly of 6.5beta on Win2000server. I use the .exe version on
windows for this particular machine/install.

I can't get slimserver to start at all. The event viewer states:

> Event Type: Error
> Date: 2006-09-11
> Time: 11:20:35
> Description:
> The description for Event ID ( 0 ) in Source ( Application ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. The following information is part of the event: Undefined subroutine &Getopt::Long::GetOptions called at slimserver.pl line 44.
> .

On the previous build (running mostly fine for two weeks), I had a
problem with the scanning engine not recognizing my ";" as separator of
multiple artists within id3-tags

Thanks (and I didn't yet look in the bug tracking db for these)
/peter

mherger
2006-09-11, 04:23
Peter,

>> The description for Event ID ( 0 ) in Source ( Application ) cannot be
>> found. The local computer may not have the necessary registry
>> information or message DLL files to display messages from a remote
>> computer. The following information is part of the event: Undefined
>> subroutine &Getopt::Long::GetOptions called at slimserver.pl line 44.

If you're sure you did remove everything, then try to clean the temporary
folders of your system.

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

NY2006
2006-09-11, 19:26
I'm getting this error after installing 6.5b2...

When i try to open Slim device picks I get this error...

Error (1 of 2)

Failed to parse <http://www.slimdevices.com/picks/radio.ompl>

On the Server Settings for Device Pick I see this error there...

There was an error loading the remote feed for Slim Devices Picks: (Invalid XML feed - didn't find


Any idea what is happening here ?


Forgot Error message 2....

Error 2

Imvalid XML Feed-
didn't find <XML feed-didn't find <X<L>!

NY2006
2006-09-11, 20:01
"I'm getting this error after installing 6.5b2..."


Problem solved...I forgot to uninstall before installing 6.5b2...

peterbell
2006-09-12, 01:11
I presume that those of us running SlimServer on a QNAP can't just install this new version, but have to wait on Progressive to do the necessary?

funkstar
2006-09-12, 05:52
correct.

they will release a 6.5 download when it is released

Wombat
2006-09-12, 06:48
6.5b2 clean install. When selecting an album on the Squeezebox it plays one song after the other but the display always shows the name of track 1 in the display.

m1abrams
2006-09-12, 07:00
Running the latest b2. When I browse by Artist or Genre using either "touch" or "nokia770" skin I do not see artist albums after selecting a specfic artist. I remember this being a problem a few nightlys ago but I thought it was resolved. It appears to be back again.

Note I have tested this behaviour with the "fishbone" skin with no issues.

Patrick Dixon
2006-09-12, 08:37
6.5b2 clean install. When selecting an album on the Squeezebox it plays one song after the other but the display always shows the name of track 1 in the display.

Have you selected 'Now Playing' or enabled 'Now Playing' as a screensaver?

NY2006
2006-09-12, 08:38
I'm having a problem playing various radio stations saved on my favorites list from Squeezebox Network..some play but others that usually play like CNN News for example just keep buffering over and over...any idea how to fix this ?

Wombat
2006-09-12, 10:27
Have you selected 'Now Playing' or enabled 'Now Playing' as a screensaver?

I have disabled screensaver completely.

Patrick Dixon
2006-09-12, 11:39
I have disabled screensaver completely.

Therefore you need to press 'Now Playing' to have the display track your current playlist. Otherwise it will just sit there displaying the last Browse or Search you did.

Wombat
2006-09-12, 12:15
Never had this in 6.31. When i browse albums and enter one album it shows the first track. I press play on this and the rest followes. What´s wrong with this?
May this be related to "Dark" view in the server GUI?
Now back to "Standard" and it works.

Edit: Now after playing a while and switching to another album it hangs again :(

Kyle
2006-09-13, 12:38
Does the Windows executable uninstall before install?

bobharp
2006-09-14, 06:06
Updated my Ubuntu/breezy server to the latest nightly with apt-get.
No hiccups.
Synch'd music on 2 SB2s and a Softqueeze client without problems.

Based on the above setup please PM me if you want me to try anything else.
Bob

caldvd
2006-09-17, 17:13
Does the Windows executable uninstall before install?

I want to upgrade from 6.3.1, however, all of these problems make me nervous. Also, I can't find anywhere a "best practices" for upgrading. For Example, uninstall, clear directory (x, y and z) from the following locations, reboot, throw salt over your shoulder, dance on one leg, etc. If it doesn't work, can we uninstall and reinstall 6.3.1? Does a guide like this exist to make sure that we do it right the first time and that if we do run into problems, there is a way back to our music?

Thanks!

mherger
2006-09-18, 00:05
> I want to upgrade from 6.3.1, however, all of these problems make me
> nervous. Also, I can't find anywhere a "best practices" for upgrading.

6.5 has not officially been released yet (to be expected today). I hope
there will be some information about your concerns.

> locations, reboot, throw salt over your shoulder, dance on one leg, etc.

I can assure you this won't be necessary. I did update my "production"
system a few days ago and definitely can't dance.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

hughesie89
2006-09-18, 18:21
so it is now past the release date when is it coming out 6.5?

kdf
2006-09-18, 18:54
On 18-Sep-06, at 6:21 PM, hughesie89 wrote:

>
> so it is now past the release date when is it coming out 6.5?
>
as was already posted elsewhere, there are a couple of outstanding
issues that will result in the release being postponed for a day.
-k

paltomare
2006-09-20, 13:11
I have an SB1, will I see an improvement if I upgrade to 6.5? Is 6.5 compatable with an SB1?
Thanks.

Mitch Harding
2006-09-20, 13:18
6.5 is compatible with SB1, and there were some server side changes in how
it does library scanning, which should be of benefit to all users.

However, I think the safest route is that if it isn't broken, don't fix it.

On 9/20/06, paltomare <
paltomare.2eg9az1158783301 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> I have an SB1, will I see an improvement if I upgrade to 6.5? Is 6.5
> compatable with an SB1?
> Thanks.
>
>
> --
> paltomare
> ------------------------------------------------------------------------
> paltomare's Profile: http://forums.slimdevices.com/member.php?userid=2062
> View this thread: http://forums.slimdevices.com/showthread.php?t=27259
>
>

pfarrell
2006-09-20, 13:33
paltomare wrote:
> I have an SB1, will I see an improvement if I upgrade to 6.5? Is 6.5
> compatable with an SB1?

Yes, it is compatible, I've been running the beta versions for a while,
and I have two SB1s.

There are improvements to the streaming engine that really help with
dropouts on my SB1s, which have smaller buffers than the newer models.

While the "if it aint broke, don't fix it" rule is always true,
for me, the improvement was significant and worth it.

--
Pat
http://www.pfarrell.com/music/slimserver/slimsoftware.html

bishopdonmiguel
2006-09-20, 13:53
Is the Debian Apt package working with the most recent 6.5.0 Beta 2? I'd like to upgrade from 6.3.1, but not sure what the new dependencies might be and I'd rather not go through another manual setup.

Ben Sandee
2006-09-20, 16:04
On 9/20/06, bishopdonmiguel <
bishopdonmiguel.2egb5n1158785701 (AT) no-mx (DOT) forums.slimdevices.com> wrote:
>
>
> Is the Debian Apt package working with the most recent 6.5.0 Beta 2?
> I'd like to upgrade from 6.3.1, but not sure what the new dependencies
> might be and I'd rather not go through another manual setup.


The final 6.5 .deb is out there right now on debian.slimdevices.com.

I've been very happy with the APT packages -- running on Debian testing. A
few weeks ago there was a rough spot where mysql binaries were updated on
testing that did a couple things wrong (broke the ABI, etc) but these
changes were reverted on the Debian side. I would strongly recommend giving
the new packages a try -- you should be able to leave your existing install
intact in the event that it just doesn't work out.

Ben