PDA

View Full Version : Problem updating tags



wesg
2006-09-03, 15:01
I ripped a CD via EAC configured to automatically encode the files as FLAC.

After encoding I noticed a typo in the genre. I then used TAG and Rename to edit the genre tag. However after clearing and searching for new music on the slimserver the original uncorrected genre tag is still being displayed.

As a sanity check I downloaded easytag and confirmed that the FLAC tag files was properly set as expected from Tag and Rename. However slim is still seeing the unmodifed tag.

Is slim reading the flac tags or some other tag I'm missing? Any help or guidance in helping me clear my confusion would be most appreciated.

Thanks

Wesg

jdvmi
2006-09-03, 15:12
I've seen this exact thing many times with my mp3 files. The only way I could get it to fix the issue is to use the program Mp3tag to complete remove all tag information then re-tag the files in Tag&Rename. I'm not sure what is causing this, but it is definately something somewhere in the tag information that is not shown to tag programs like Mp3Tag and Tag&Rename but is being read by slimserver.

jdvmi
2006-09-03, 18:32
Just to clarify, here are some images of the wierdness:

The first image "tag1" shows how browsing by album shows this R.E.M. title as two different albums.

The second image "tag2" shows what tracks are concidered part of one of the albums.

The third image "tag3" shows what tracks are being concidered part of the second album.

The fourth image "tag4" shows how tag&rename sees these files tags.

Anyone know what slimserver is reading that is different from what Tag&Rename and other tagging programs read?

ceejay
2006-09-03, 23:55
Just some guesses but...

jdvmi - might you have both id3v1 and id3v2 tags in your mp3 files? mp3tag will tell you if you have both. If you have different information in the two sets of tags, its quite possible slimserver has got confused.

wesg - you're using FLAC so that won't be your problem. But are you sure you've done a complete clear and rescan of the slimserver database?

HTH

Ceejay

jdvmi
2006-09-04, 08:08
Just some guesses but...

jdvmi - might you have both id3v1 and id3v2 tags in your mp3 files? mp3tag will tell you if you have both. If you have different information in the two sets of tags, its quite possible slimserver has got confused.

Ceejay

Ceejay,
Thanks for the response. I do have both id3v1 and v2, but they are exactly the same. That was the first thing I checked when I noticed this problem.

wesg
2006-09-04, 14:17
I don't know if jdvmi and I have the same issue or not, but I can confrim with the flac files that I have cleared the library and rescaned everything.

When I updated title and artist tags via tag and rename, the slimserver seems to update properly on the clear and rescan, but the genre tags do not.

I am running windows XP, SP2, I observed the same behavior with the same files on 6.3.1 and now 6.5b1 - 9373.

I am going to attempt jdvmi's suggestion to find a way to clear the tag and start over and see if his approach resolves my issue as well.

Thanks

wesg

ceejay
2006-09-04, 14:35
I don't know if jdvmi and I have the same issue or not, but I can confrim with the flac files that I have cleared the library and rescaned everything.

When I updated title and artist tags via tag and rename, the slimserver seems to update properly on the clear and rescan, but the genre tags do not.

I am running windows XP, SP2, I observed the same behavior with the same files on 6.3.1 and now 6.5b1 - 9373.

I am going to attempt jdvmi's suggestion to find a way to clear the tag and start over and see if his approach resolves my issue as well.

Thanks

wesg

OK, this is a very long shot, but I had some odd behaviour with genre tags on my new 6.5 installation and cleared it by rebooting the server. Have you done this recently?

Ceejay

tommypeters
2006-09-04, 14:41
Any .cue files, or playlist files with extended info?

jdvmi
2006-09-04, 15:51
Any .cue files, or playlist files with extended info?

None of those files here.

wesg
2006-09-05, 18:20
I cleared the tags, and reset them all using Tag&Rename. Rebooted in between for unrelated reasons.

Cleared database and scaned for music... then all was good and corrected.

Not sure what exactly the fix was, rebotting or clearing the tags. If it happens again I'll try and be more scientific.

Thanks for all the suggestions.

wesg

jdvmi
2006-09-05, 18:50
I cleared the tags, and reset them all using Tag&Rename. Rebooted in between for unrelated reasons.

Cleared database and scaned for music... then all was good and corrected.

Not sure what exactly the fix was, rebotting or clearing the tags. If it happens again I'll try and be more scientific.

Thanks for all the suggestions.

wesg
Clearing the tags is what does it, but more importantly I would like to know what information/tags slimserver is using for it's album and artis information that isn't being detected by any of the tagging aplications. Anyone?

stinkingpig
2006-09-05, 20:25
> Clearing the tags is what does it, but more importantly I would like to
> know what information/tags slimserver is using for it's album and artis
> information that isn't being detected by any of the tagging
> aplications. Anyone?
>
>
Server Settings > Formatting > Guess Tags:

For files that do not have reasonable tags, you can have the server guess at
tags using the path and filename. Using the same variables as Title Format,
you can create a pattern to match your file naming conventions so that the
server can make a good guess at what the tags should be. Priority goes in
the order listed below. The first valid pattern match is used.

--
"I spent all me tin with the ladies drinking gin,
So across the Western ocean I must wander" -- traditional

jdvmi
2006-09-05, 21:06
> Clearing the tags is what does it, but more importantly I would like to
> know what information/tags slimserver is using for it's album and artis
> information that isn't being detected by any of the tagging
> aplications. Anyone?
>
>
Server Settings > Formatting > Guess Tags:

For files that do not have reasonable tags, you can have the server guess at
tags using the path and filename. Using the same variables as Title Format,
you can create a pattern to match your file naming conventions so that the
server can make a good guess at what the tags should be. Priority goes in
the order listed below. The first valid pattern match is used.

--
"I spent all me tin with the ladies drinking gin,
So across the Western ocean I must wander" -- traditional

Thanks Jack,
but there is something else causing this problem. I cleared out everything in "Server Settings > Formatting > Guess Tags" and it is still duplicating the album like the pictures attached above. There is something somewhere in the tag information that slimserver is reading that is not visible in any of the tagging applications.

stinkingpig
2006-09-05, 21:41
On 9/5/06, jdvmi <jdvmi.2dp3an1157515801 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> Thanks Jack,
> but there is something else causing this problem. I cleared out
> everything in "Server Settings > Formatting > Guess Tags" and it is
> still duplicating the album like the pictures attached above. There is
> something somewhere in the tag information that slimserver is reading
> that is not visible in any of the tagging applications.
>
>

Had to go look at the pictures...

I have had this problem before, and it was a problem with id3v1 and v2 tags
-- mp3tag didn't show a difference I could see, and doesn't show both tags
at the same time. Anyway, the problem went away after I deleted the v1 tags
entirely and did a clear-and-rescan.

--
"I spent all me tin with the ladies drinking gin,
So across the Western ocean I must wander" -- traditional

jdvmi
2006-09-05, 23:19
Had to go look at the pictures...

I have had this problem before, and it was a problem with id3v1 and v2 tags
-- mp3tag didn't show a difference I could see, and doesn't show both tags
at the same time. Anyway, the problem went away after I deleted the v1 tags
entirely and did a clear-and-rescan.



Thanks Jack,
I tried removing the ID3v1 tag information, but that didn't fix it. So far the only thing that works is to completely remove all tag information and re-tag.

Ur[s]uS
2006-10-05, 13:13
Just to clarify, here are some images of the wierdness:

The first image "tag1" shows how browsing by album shows this R.E.M. title as two different albums.

The second image "tag2" shows what tracks are concidered part of one of the albums.

The third image "tag3" shows what tracks are being concidered part of the second album.

The fourth image "tag4" shows how tag&rename sees these files tags.

Anyone know what slimserver is reading that is different from what Tag&Rename and other tagging programs read?

Lower case "t" for "the" in tracks 5-13; but, upper case "T" for "The" in tracks 1-4. I get this problem now and again.