PDA

View Full Version : I love it.......when it works



Hangtight
2006-09-02, 08:35
I have just been through the trauma of reinstalling XP, and having been delighted that my wireless router had retained all it's settings and connected to the net as soon as it was plugged in, I was less thrilled that I have so far failed to get my SB2 working.
I've been through and checked the router security settings, turned off the Windows firewall and reinstated the port exceptions in the sortware firewall (PcCillin). The wireless zero configuration service is disabled, and I have checked and rechecked the SB settings. After a reset, the SB finds the network SSID fine but then fails to connect. I've tried with WPA, WEP and with no encryption. One thing that seems a little strange is that XP does not seem to acknowledge the wireless network under the Network tab in Control Panel. Am I missing something obvious?

Router is an Edimax 7024WG. OS is XP SP2 with current updates and running SlimServer 6.3.1

I'm posting here as it was a while ago that I got my SB working the first time around, and I've forgotten what I did!

Pale Blue Ego
2006-09-02, 09:43
Try disabling the PC-cillan software firewall. There is probably also a hardware firewall in the router. I'm not familiar with WindowsXP and wifi networking, so I can't help you there, but it does seem like Windows should recognize the wifi network.

Hangtight
2006-09-02, 09:58
Yep, tried disabling the software firewall already but still no joy.
This is probably the most frustrating product I've ever owned. I'm fairly sure that the problem isn't the SB, but the PC end of things. It's almost a pity that when everything is fine, it works so well. Maybe then I wouldn't be so irritated when problems occur!

Mark Lanctot
2006-09-02, 12:33
After a reset, the SB finds the network SSID fine but then fails to connect. I've tried with WPA, WEP and with no encryption.

This indicates the problem lies in the Squeezebox or the router - the Squeezebox isn't even communicating with SlimServer at this point so your OS has nothing to do with it.

This could be caused by:

- proprietary speed enhancement in the router: "Super G", etc. Disable this.

- setting the router to "b" only. It must be in mixed or g-only mode.

- an error in the passphrase, although if you connect with no encryption this isn't an issue

- the SB not in the "approved" MAC address list

- the router set to restrict the number of wireless clients

- some esoteric router settings, like long preamble (possibly, I'm not sure if the Squeezebox likes or dislikes this setting, but you get the idea. There are some advanced settings it would be best not to alter.)

- general incompatibility with the router. This hasn't been much of an issue since firmware 28, and if it connected before it should connect now.

You haven't chosen a common SSID a neighbor might be using?

Try connecting wired to see if that still works.

Hangtight
2006-09-02, 12:54
Somehow I got the SB to talk to the router. I think it may have something to do with changing back to WEP encryption, but I think I need to investigate that further. Connecting to SlimServer was then simply a case of setting up an in/out TCP/UDP exception for Slim.exe. At the moment this is on all ports, but I take it it only needs to be on 3483 & 9000?
Just as well it's been raining all day! Now all I've got to do is get AlienBBC working so the wife can catch up on The Archers....