PDA

View Full Version : streaming wma codec not working



gingerneil
2006-08-31, 17:32
I use my SB2 to stream talksport at night (www.talksport.net). The URL of the stream is mms://194.46.192.142/talkSPORT
and it comes up in WMP9 as "Windows Media Audio 9
20 kbps, 22 kHz, mono 1-pass CBR".

I can only get this to play in the SB2 by turning off native hardware decoding of WMA streams. As a result, the server trancodes it on the fly and it plays without a problem.

I dont mind this, but it begs the question "why?". Anyone have any idea why the SB2 hardware cannot manage this stream ? I initially thought it must be a WMA Voice Codec, but I am running 6.5_v2006-08-30 which is meant to have support for this codec...

bpa
2006-08-31, 17:33
AFAIK - it is not the codec but http streaming.

gingerneil
2006-08-31, 17:39
can explain further ?

bpa
2006-08-31, 17:46
Not really - roughly they are different ways of delivering the compressed audio data packets
- one uses mms protocol
- the other uses "http streaming".

It will be up to somebody from SD to explain why "http streaming" has not been implemented in the SB3.

gingerneil
2006-08-31, 17:47
but the URL is mms:// etc ?!

andyg
2006-08-31, 17:50
This page has lots of info: http://www.microsoft.com/windows/windowsmedia/forpros/serve/firewall.aspx

Basically, WMA can be streamed using a non-HTTP protocol called MMS. Normally, radio stations want to be able to work over proxy servers, in corporate networks, etc, and so they enable the HTTP mode of streaming. We only support HTTP streaming because the vast majority of stations provide content in this way and it was much easier to implement.

You may be able to contact Talk Sport and tell them you'd like to listen at work, but you're behind an HTTP proxy server, and could they please enable HTTP streaming.

gingerneil
2006-08-31, 17:52
ok - thanks for the info. It doesn't really matter - as long as I can use the server to cope with it I'll be happy. Just curious...

Cheers.