PDA

View Full Version : New 6.5.1b Install - Want to Use Existing MySql Install



Michael Haan
2006-08-26, 11:38
So, that's pretty much it. Installed 6.5.1b on an FC5 box with an existing MySql install. When I try to run slimserver I get:

# ./slimserver.pl
2006-08-26 14:36:11.3383 ERROR: MySQLHelper: startServer() Couldn't find a executable for 'mysqld'! This is a fatal error. Exiting.

However:

# ps -ef | grep mysqld
root 2344 1 0 Aug24 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe --defaults-file=/etc/my.cnf --pid-file=/var/run/mysqld/mysqld.pid --log-error=/var/log/mysqld.log
mysql 2380 2344 0 Aug24 ? 00:00:00 /usr/libexec/mysqld --defaults-file=/etc/my.cnf --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock

So, the question is, how do I get slim to use my existing, running instance of MySql?

Robin Bowes
2006-08-26, 16:29
Michael Haan wrote:
> So, that's pretty much it. Installed 6.5.1b on an FC5 box with an existing MySql install. When I try to run slimserver I get:
>
> # ./slimserver.pl
> 2006-08-26 14:36:11.3383 ERROR: MySQLHelper: startServer() Couldn't find a executable for 'mysqld'! This is a fatal error. Exiting.
>
> However:
>
> # ps -ef | grep mysqld
> root 2344 1 0 Aug24 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe --defaults-file=/etc/my.cnf --pid-file=/var/run/mysqld/mysqld.pid --log-error=/var/log/mysqld.log
> mysql 2380 2344 0 Aug24 ? 00:00:00 /usr/libexec/mysqld --defaults-file=/etc/my.cnf --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-locking --socket=/var/lib/mysql/mysql.sock
>
> So, the question is, how do I get slim to use my existing, running instance of MySql?

Search the forums - this has been covered before.

R.