PDA

View Full Version : Second server doesn't register with mDNSResponder with the correct IP address



gerph
2006-08-23, 07:38
Hiya,

I'm not sure whether this is a Beta /issue/ or just came up because I'm testing the Beta stuff separately, so I'm reporting here in the hope it's right.

The problem I'm seeing is that two instances of slimserver on the same machine both register with mDNSResponder, obtaining two different link-local hostnames, but end up with the same address. This will be easier if I explain the steps and then what happens...

1. Normal linux server is running Slimserver 6.2.x (known stable and I don't want to break it) on 192.168.0.100, known as 'buttercup'. For reasons inexplicable, this appears as buttercup2.local in the bonjour list, with the address 192.168.0.100. The service is correctly listed on port buttercup2.local:9000 and this works fine.

2. On the same server, a separate address is configured (ifconfig eth0 192.168.0.25) in order that an instance of the SlimServer 6.5 can be run there.

3. SlimServer 6.5 is run with the options --playeraddr 192.168.0.25, and the http port 9001 (so that it's easier to distinguish).

4. The slimserver 6.5 instance has registered buttercup.local as 192.168.0.100, and the service it has registered is on port 9001. This is incorrect.

5. Thus, clicking on buttercup2.local bonjour service link in IE gives the address http://192.168.0.100:9000/ (correct).
Clicking on buttercup.local link gives http://192.168.0.100:9001/ (wrong, but works).

It's been a while since I worked ith mDNSResponder, but I don't remember it being possible to select the interface that it was announcing on (the facility is in the back-end, but I don't remember if it's exposed in the command line tool).

Don't know whether this is a bug, or 'just the way it is, live with it'. It doesn't seem too important, as running two servers simultaneously is quite specialised and in that case you're unlikely to want to use Bonjour / mDNSResponder / Rendezvous. I tried searching for the problem here and in the bugs list, but saw nothing.