PDA

View Full Version : Remote streaming problem



bugs
2006-08-23, 05:55
Hi all,
I have 2 Squeezeboxes at home & Slim Server 6.2.1 on XP. All works well as it has done for quite a few years.
I've just starting playing with remote streaming for the first time, and have run into a problem.
I can browse the server fine remotely, and also stream mp3 files. However, when I try to play an AAC file, Slim just simply won't play it (ie the display won't change from 'stopped' to 'playing').
Is this a limitation, or is there a fix? I'm using the http://hostname/stream.mp3 link (maybe there's a clue there ;-)
Cheers,

bpa
2006-08-23, 06:10
My guess:
1. Missing port 9000 in the URL
2. Lame not installed to transcode AAC to MP3


See here:
http://wiki.slimdevices.com/index.cgi?RemoteStreaming

bugs
2006-08-23, 08:21
My guess:
1. Missing port 9000 in the URL
2. Lame not installed to transcode AAC to MP3


See here:
http://wiki.slimdevices.com/index.cgi?RemoteStreaming

Thanks for that.
It's not a connectivity issue, as I can stream mp3s fine. In fact I'm using a static IP and forwarding port 80 -> 9000 on my router.

Sounds like the LAME thing might be the problem though. Is that a specific requirement for streaming, as I can obviously play the AAC files OK through the Squeezeboxes.

Cheers,

davep
2006-08-23, 08:29
I do this all the time but the key is to make sure that your remote player (I use Softsqueeze) is set to use bitrate limiting. I find that with an average quality internet connection I can get away with 160k but sometimes have had to go down to 128k. If you don't do this SS will try to stream the file at its original size and this usually chokes the network connection.

davep

bugs
2006-08-23, 08:47
I do this all the time but the key is to make sure that your remote player (I use Softsqueeze) is set to use bitrate limiting. I find that with an average quality internet connection I can get away with 160k but sometimes have had to go down to 128k. If you don't do this SS will try to stream the file at its original size and this usually chokes the network connection.

davep

Hiya,
Problem seems to be before any streaming starts. When I'm browsing the Slim interface remotely, I physically can't make it start playing an AAC file. MP3s just play as expected. It's almost as though there's a problem at the server end - which I guess from above is the LAME thing???

bpa
2006-08-23, 09:01
You can only stream MP3 to non-SoftSqueeze players such as Winamp. To create the MP3 stream from your AAC file you need to install Lame which is an MP3 encoder.

You also need to specify the maximum remote bitrate for the player - this will trigger the use of Lame to transcode the AAC stream into MP3.

bugs
2006-08-23, 09:23
I don't necessarily want/need to stream in mp3 format, I hust need a solution that will play my AAC files - as that's most of my library. Can I steam in AAC to a suitable player (iTunes?) at the remote end?
Thanks,

Mark Lanctot
2006-08-23, 10:18
No, a remote stream will always be in mp3 format.

SlimServer should tell you if LAME is properly installed or not in the section where you specify bitrate.

bugs
2006-08-25, 04:42
Guys,
just wanted to say thanks. LAME installed and everything works fine.
Other than obviously straight ftp/scp, is there anyway to 'get' a song remotely via the slim interface? ie not stream it but download the file.

Cheers,

Mark Lanctot
2006-08-25, 06:00
Guys,
just wanted to say thanks. LAME installed and everything works fine.
Other than obviously straight ftp/scp, is there anyway to 'get' a song remotely via the slim interface? ie not stream it but download the file.

Cheers,

If you can see the SlimServer GUI (and I presume you can so you can add/remove songs from playlists), go to the song either by browsing or searching.

Once SlimServer displays a single song you'll see a download link.

bpa
2006-08-25, 06:24
You could try to use "file://" with file path instead of "http://" in Radio Tune-in. I've only tried it on local playlist files - I'm not sure what happens if you reference a file on a networked drive.

eagle63
2006-10-26, 17:52
Sorry to dredge up an old thread, but I've got a related question:

Let's say my music collection is encoded in AAC (m4a) and I want the ability to:
1. Stream the music over the internet to my windows PC at work.
2. Stream the music to a hardware client in my house. (Roku Soundbridge)

So if I understand this correctly, in order to stream the tunes over the 'net I need to check the setting to make AAC files get encoded as MP3. Fine. However, does this mean that music going to the Roku will ALSO get encoded as MP3, or does the server have some smarts to keep the files in their native AAC format since the Roku can accept AAC??

Thanks for any info!!

mherger
2006-10-26, 23:03
> So if I understand this correctly, in order to stream the tunes over
> the 'net I need to check the setting to make AAC files get encoded as
> MP3. Fine. However, does this mean that music going to the Roku will
> ALSO get encoded as MP3, or does the server have some smarts to keep
> the files in their native AAC format since the Roku can accept AAC??

No, transcoding is a per client setting.

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

bpa
2006-10-27, 00:10
I may be wrong but I have a vague recollection that the Roku doesn't support AAC streams when it is emulating an SB1 to commuinicate with slimserver.

eagle63
2006-10-27, 14:09
No, transcoding is a per client setting.


Where do you set it per client?? I'm in the server settings: Home/Server Settings/File Types.

Looks like a global setting to me...

bpa
2006-10-27, 14:15
The web interface only supports one set of settings. If you edit the convert.conf file you can set rules on a specific client by MAC address or type (squeezebox for the roku). Use logging d_source to see which rules actually get applied.

mherger
2006-10-27, 14:20
> Where do you set it per client?? I'm in the server settings:
> Home/Server Settings/File Types.
>
> Looks like a global setting to me...

Go to Home/Player settings/Audio/Bitrate Limitation (or something): if you
set it, Slimserver will stream MP3, if you don't, slimserver will send
whatever the player knows the best. (FLAC -> WAV -> MP3)

--

Michael

-----------------------------------------------------------------
http://www.herger.net/SlimCD - your SlimServer on a CD
http://www.herger.net/slim - AlbumReview, Biography, MusicInfoSCR

eagle63
2006-10-27, 14:23
The web interface only supports one set of settings. If you edit the convert.conf file you can set rules on a specific client by MAC address or type (squeezebox for the roku). Use logging d_source to see which rules actually get applied.


Ahh, gotcha. Thanks. Although as you mentioned previously, if the Roku doesn't support AAC then I guess it's kind of a moot point. I'll just use MP3 for everything then.