View Full Version : SS 6.3.1 crashing at startup

2006-08-18, 11:22
Hi all.
I have been a happy Slimserver/SB3 user without any problems for a few months, using 6.3.1 since it came out, but last night slimserver started to act up.

What happens is that when slimserver is started, after maybe 10-20s, it starts using up large amounts of RAM untill all of my 1GB is used, it then starts to fill the swapfile until full, 1.5GB, then it just crashes and exits. It never gets to the stage where anything other than the slimtray icon appears.

In windows event log it says: Perl interpreter failed.

I have tried starting slim.exe from a command window, same thing happens but I get the following error message:

AppName: slim.exe AppVer: ModName: perl58.dll
ModVer: Offset: 00089931

I have tried: slim.exe --logfile c:\slimlog.txt, but the logfile is empty.
Also tried: --noupnp and --noscan, with no luck.

Last thing I did yesterday before the problem started was to set up remote streaming to my work PC. This all seemed to work fine and I listened to music at work for a few hours and then later also at home using both SB3 and local stream to winamp. Then late last night I updated my nVidia graphics drivers, and did a reboot. After that reboot slimserver has behaved as described above.

I have tried XP's system restore to get back to how the system was 2 days ago, this seemed to work ok restoring the old graphics driver and other settings, but slimserver still does not work.

I also tried to reinstall slimserver 6.3.1 on top of my existing install but no luck. I am tempted to try a clean install, but don't want to loose all my settings.

I understand there are some debugging possibilities in slimserver but I am not sure how to proceed.

Any suggestions would be most welcome.

2006-08-18, 13:48
Could not stand it anymore. So I uninstalled, deleted all traces of slimserver, and then installed the latest 6.5 nightly. Wanted to test that anyway.
After the rescan everything is working fine.
Hope it lasts...