PDA

View Full Version : Slim 6.3.0 suddenly started to fail repeatedly



jimwillsher
2006-08-18, 07:43
Ubuntu Dapper, SB3 player, 6.3.0 release.

My Slim software has been running happily for 19 days (ever since the server has been up). Yet today it has crashed 6 times! I've tried a restart of the whole machine, no joy.

I've enabled logging, and this is what I see:


2006-08-18 15:33:13.7626 DBI: Supressing periodic commit - no dirty items
2006-08-18 15:33:43.7708 DBI: Supressing periodic commit - no dirty items
2006-08-18 15:34:13.7790 DBI: Supressing periodic commit - no dirty items
2006-08-18 15:34:43.7872 DBI: Supressing periodic commit - no dirty items
Can't use string ("
") as an ARRAY ref while "strict refs" in use at /usr/local/SlimServer_v6.3.0/lib/UPnP/Common.pm line 282.
2006-08-18 15:35:08.2535 Got to the END.
2006-08-18 15:35:08.2537 Got sigint.
2006-08-18 15:35:08.2538 SlimServer cleaning up.
2006-08-18 15:35:08.2547 forceCommit: syncing to the database.


Help! Can anyone suggest any solutions? I'm at my wits' end now, as a seemingly solid installation has gone belly-up in the space of 2 hours.

Many thanks,


Jim

snarlydwarf
2006-08-18, 08:23
Do you have an Xbox360?

jimwillsher
2006-08-18, 08:27
Errm....no. Why do you ask?

I've just installed 6.3.1 (I hadn;t spotted the new release) and so far (24 minutes!) it's kept running, so I'll monitor it.


Jim

snarlydwarf
2006-08-18, 08:51
The 360 does something odd with UPnP, sending out a weird URL that confuses Slimserver. It has been fixed (I think in 6.3.1). Perhaps something else on your network is doing something similar.

jimwillsher
2006-08-18, 08:53
Hmmm....the only thing I've changed in the last 24 hours is that I've installed Vista Beta 2 onto a spare PC, and that's switched on and on the LAN. I wonder if it too is doing something Microsoft-ish.....


Jim

Gregory Hamilton
2006-08-18, 09:01
Jim

The default install of MS Vista Beta 2 turns on the media sharing
capibilities of Windows Media Player
I suspect it is doing the same type of thing the XBOX 360 is.

andyg
2006-08-18, 10:18
You can run with the --noupnp switch to ignore all UPnP stuff.

jimwillsher
2006-08-18, 10:29
6.3.1 has been running happily for a couple of hours now. Looks like the uPnP issues was the one. Many thanks for that!


Jim

mherger
2006-08-18, 22:37
> You can run with the --noupnp switch to ignore all UPnP stuff.

How do I add this parameter to the startup string if Slimserver is run as
a service on Windows?

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)