PDA

View Full Version : Universal Remote with MusicIP



opchiasm
2006-08-15, 13:15
Thanks in advance for any help.

I use a Home Theater Master MX800 with an SB2. I'm running MusicIP as a service with Slim. As far as I know, the way to create a mix on the SB2 is to press and hold the Play button on the remote. This works great with the SB2 remote.

When I press and hold the Play button on the MX800, it seems like the remote just sends individual "Play" commands. I created a new button on the 800 and learned the SB2 remote's Play button, with the button depressed. That doesn't work. It acts just like a regular "Play" does.

Is there any way to learn a command on the 800 that simulates a held "Play" button on the SB2 remote and therefore creates a mix?

Thanks again very much.

Simon Still
2006-08-15, 13:43
On 8/15/06, opchiasm <opchiasm.2clljb1155673201 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
> When I press and hold the Play button on the MX800, it seems like the
> remote just sends individual "Play" commands. I created a new button on
> the 800 and learned the SB2 remote's Play button, with the button
> depressed. That doesn't work. It acts just like a regular "Play" does.


Odd - works on my Harmony. Can you adjust the repeat delay?

opchiasm
2006-08-15, 15:26
As far as I can tell, I can't adjust the delay. I can create a macro to repetitively send a Play command, but the smallest time interval is 0.1 sec.

opchiasm
2006-08-15, 15:55
Please forget this thread. I've got it working. Thanks for the response.

Simon Still
2006-08-16, 11:01
So what did you change?

On 8/15/06, opchiasm <opchiasm.2clsxz1155682801 (AT) no-mx (DOT) forums.slimdevices.com>
wrote:
>
>
> Please forget this thread. I've got it working. Thanks for the response.
>
>
> --
> opchiasm
> ------------------------------------------------------------------------
> opchiasm's Profile: http://forums.slimdevices.com/member.php?userid=1087
> View this thread: http://forums.slimdevices.com/showthread.php?t=26407
>
>

opchiasm
2006-08-16, 17:40
When I originally set up the SB2 as a device on the MX800, I started from scratch and learned all the commands directly from the SB2 remote. When I learned the "Play" command, I pressed the "Play" button on the SB2 remote briefly, got a "GOOD" message from the 800, and everything worked fine.

When I started using MusicIP with the SB2, I couldn't get a mix created. Holding the "Play" button on the 800 did nothing but send a "Play" command. I had to use the SB2 remote to create a mix. My MX800 instantly became an almost-universal remote.

I created a new button on the 800, called it "Mix" and learned the "Play" button from the SB2 remote, but this time I held the SB2 "Play" button for a while. When I tried it and briefly held my new "Mix" button, it acted like a "Play" button. I thought it was hopeless. I got the bright idea to hold the new "Mix" button for a while and it worked!

So ... in order to get "Play" on the MX800 to act as a "Play" when pressed quickly and as "Mix" when held down, I had to learn the command while holding the "Play" button on the SB2 remote for a little while.

Further proof that it is better to be lucky than good.