View Full Version : Problem streaming asf stream

2006-08-15, 01:56
I have not had any luck streaming and get the following message in the logfile

scanRemoteURL: Can't connect to remote server to retrieve playlist: Error reading headers: Server closed connection without sending any data back at /usr/share/perl5/Net/HTTP/Methods.pm line 302.

The stream works in Windows media player and also with mplayer. I'm running 6.5b1 - 8964 - Debian.

Any thoughts would be appreciated.

2006-08-16, 15:24
I've been keeping up to date with the 6.5 nightlies, hoping this might help, but so far no joy. Is anyone else able to play this stream? The website says the stream "will ONLY work in Windows Media Player" (see http://www.2ser.com/streamhttp://www.2ser.com/stream), which I took as something of a challenge! While it doesn't defeat mplayer, it does seem to defeat the slimserver. Any other ideas?

2006-08-18, 04:16
hi smc - i seem to have the same problem as you. I'm running SlimServer Version: 6.3.1 and simply get no feed when trying to stream Note this link works when I use windows media player via "open URL".

seems odd.....

2006-08-19, 04:56
Seems like a challenge to me! I have also tried the stream in foobar2000, but it doesn't work (I've always managed to stream with foobar2000 before). Maybe there's some media player detection trickery going on. Any ideas?

2006-08-19, 05:36
Simply change the URL to mms:// This instructs SlimServer to send Windows Media Player headers, which the server requires.

2006-08-20, 02:46
Thanks Andy, that worked a treat. I'd never realised the significance of the "mms" prefix. Also, it's not the first time you've helped me out, and I'm sure it won't be the last!