View Full Version : MAC Address changed?

2006-08-06, 12:33

I use authentication on MAC address as part of my wireless security (SSID, Encryption, and MAC authentication). Yesterday the following happened: the display of the squeezebox was scrambled, and after a reset the SB would not connect to the wireless network anymore. After some testing, I found that the MAC authentication failed. Looking at the MAC address of the player, I found that it had changed.

I was under the impression that a MAC address was factory set for each network card. How can it be changed? Is this a sign of a dying SB Wireless?



2006-08-06, 12:41
matthijskoopmans wrote:
> I was under the impression that a MAC address was factory set for each
> network card. How can it be changed? Is this a sign of a dying SB
> Wireless?

It is set, but it is just firmware. You can change it.
Search the forum archives for instructions, I've never had to do it.

Like everything else related to computers, the probability of it
happening is directly proportional to how much pain changing it
will cause.


2006-08-06, 22:37
Thanks for that...

I would never go through the pain of changing the MAC address by choice... I guess some glitch somewhere caused it to be changed. It seems to be working (although I am under the impression that the wireless strength is about half... I need some more testing on that), and the fact that it is governed by firmware means that it doesn't have to be faulty hardware (I am not ruling it out, yet... :) )



2006-08-07, 00:07
There is - or possibly was, I don't know if or when it was corrected - a bug that would sometimes change the MAC address.

2006-08-07, 10:56
The bug is 2283, and it's been bothering me for some time, but we haven't been able to reproduce it here.


I'd love for you to add any information you can provide about the bug, especially:

What was your MAC before the change? What did it change to? Had you ever set it previously?

How complicated is your network? Do you have a lot of machines and services running over it?

Thanks for any info!

2006-09-16, 18:48
Mine just changed tonight on me too. Same symptoms. It had been playing fine for a few hours and then I got a garbled display that required me to turn the squeezebox3 off/on.

1. I had never changed the mac address on it before. The original address was 00:04:20:06:30:E4. It is now 00:00:00:ff:ff:ff

I performed a factory-reset because I wasn't connecting to the network and thought a reset was the way to get back to square one. I'm not sure if the mac address changed from the reset or during the garbled display incident.

2. I've got one desktop pc connected directly to a linksys router and 2 laptops that connect wirelessly, and finally the squeezebox via wireless. Desktop is running win2k and the laptops winxp and win2k. The desktop has the slimserver software. My wife had just turned her laptop on (win2k) from standby mode and at that moment the squeezebox went into garbled/lock-up mode.

2006-09-17, 14:19
Mine has changed as well and now can not access the wireless network. I have three Macintoshes and two XP boxes on my home wireless network. I finally had reliable connectivity after switching to channel 11. that lasted about a week and all of a sudden could not access the network. I ended up having to hardwire the SB3 to my mac mini. I'm still struggling with getting the rig to stay connected to the wireless network AND have internet access. I'd rather not broadcast the addresses. Please mail me privately if this info is required. Montre8

2006-09-17, 14:30
You can easily reset the MAC address to the correct one yourself. Its something along the lines of ... navigate to the bit in the settings where it is telling you what it thinks its MAC address is - then press right - and put the new address in.



2006-09-18, 20:04
My address changed for some reason. The address should match the MAC address printed on sticker under the SB3. Go to current settings>MAC Address. Scroll right to edit the address. My wireless network is again working after resetting to the proper MAC address.


2006-09-19, 01:52
Currently two of my SB's have lost their MAC's recently.
This has never happened before.

MAC(orig) --> 00:04:20:06:2A:F9
MAC(bad) --> FF:FF:FF:2F:FF:FF

MAC(orig) --> 00:04:20:05:CF:52
MAC(bad) --> 00:00:00:FF:FF:FF

In both cases they had working perfectly and then they began to get either a corrupt display (SB3) or would blank out and pop back on (SB2), start and stop its playing. The only way after this happened to get them to work was to connect them via wired connection.

Again, like others I do not know wether the MAC changed before the abberant behavor began or during my attempts to debug the problem. Both units are configured for static IPs with WPA Personal encryption. Both units detected the network signal strength during this period of debug at 80% or greater. Using WiSpy I was able to confirm that channel #6 I was using was getting some signal interference from one or more neighbor nets.
I've since switched to a less used channel.

The only recent changes was upgrading the slimserver to v6.3.1 (Running on a ReadyNAS) and going to FW version 55. These changes were made at least two weeks prior to the observed adverse behavior. SB3, Server and WAP are on the UPS while SB2 is on a surge protector.

Hopefully this will help you in searching for this bug.

2006-09-19, 09:27
I've also had my MAC address change on a newly installed wireless connected SB3. This happened while getting to know the SB (first time user) after I got it connected. I know I did not change it myself, but don't recall what I was doing when the connection failed. I know I was using the remote and not the server.

The above isn't really interesting as far as debugging the problem but what I can add is that only one or two bytes of the MAC changed and they weren't to 0xFF. I have not seen the problem since.

2006-09-19, 11:28
I know Richard and Dean have been working on this issue. I'll see if I can get Richard to post about his possible solution that's in the firmware that ships with 6.5.

2006-10-06, 18:34
So I've had the problem over the last month or two that my SB3 would just stop playing and act like it was on but unresponsive till I off'd it and turned it back on. Sometimes had to unplug it and repower it.

But two days ago it really trashed itself, screen went all garbled, and when I hit off, the screen cleared up and displayed I guess the last good screen data (not the off screensaver). Played some more after off, off, on, back to normal, and in the morning the display was dark. The unit was working but wouldn't connect to the network to save its life.

Hooked it up wired and that worked fine, but I did notice in my wireless router that the mac address of the new DHCP client started with an ff, which makes no sense. Was ready to write it off and RMA it when played with it more and saw that funny MAC address being shown in the "current settings", now that I was retry wireless.

So added that to my router. Still no good. Then realized you could change it at that same location and changed it back to the right MAC address. Now works wireless and all again.

So while it was saying one MAC, and that MAC was what the wired connection was working with, the false MAC was not working for the wireless connection. Thing is, that false MAC was not in my router MAC filtering, so it should not have been able to connect. So something really got trashed. The fake MAC seems to have to be reset back to the good MAC to really get the unit back to proper operation. I'm still dumbfounded how the router registered the fake MAC in DHCP and allowed network access even though the fake MAC was not authorized. Maybe something between wireless LAN and wired LAN handling in my router.

Anyway, good MAC was 00:04:20:06:3A:EE and the bad MAC was FF:BB:5F:00:00:83. And I have no idea why it happened. Was running firmware 45 or 48 (whatever goes with 6.2.2) till I upgraded a few weeks ago to 6.3.x and firmware 55.

Quite frustrating, but this product still rocks. Just happy it's working 100% again.