PDA

View Full Version : Changing the streaming rate on the fly



Martin Hay
2003-11-28, 10:58
Dammit - don't I feel like a right tool now? :)

Works perfectly, thank you.

Martin.


-----Original Message-----
From: dean blackketter [mailto:dean (AT) slimdevices (DOT) com]
Sent: Fri 28/11/2003 17:52
To: SlimDevices Discussion
Cc:
Subject: Re: [slim] Changing the streaming rate on the fly



Hi Martin,

When you first connect, you'll be streaming silence, and that silence
is encoded at 320kbps. When you actually start streaming songs, you
should see the new rate.

Does this work for you?

-dean

On Nov 28, 2003, at 8:44 AM, Martin Hay wrote:

> I've tried that, but it makes no difference for me. Is there any
> specific location I should be putting the Lame files? I've put
> lame.exe and lame_enc.dll into c:\winnt\system32 - not exactly
> elegant, but the lowest common denominator. I can run lame from a
> command prompt fine.
>
> I've uncommented the suggested line from convert.conf to enable
> conversion to 96Kb/s. After that I restarted the service (no change)
> and the whole machine (still no change). My MP3's are still trying to
> stream at 320Kb.
>
> Any ideas?
>
> Martin.
>
>
> -----Original Message-----
> From: Kevin Deane-Freeman [mailto:kevin (AT) deane-freeman (DOT) com]
> Sent: Fri 28/11/2003 01:16
> To: SlimDevices Discussion
> Cc:
> Subject: Re: [slim] Changing the streaming rate on the fly
>
>
>
> Quoting Steve Pawsey-Bowerman <steve.pawsey-bowerman (AT) virgin (DOT) net>:
>
> > I've been playing around with the remote streaming which is ace,
> since I can
> > listen to mp3 radio streams at work via my slimserver (have firewall
> > restrictions at work which means only port 80 stuff can go through).
> > When trying the same with MP3's I run into issues because all my
> MP3's are
> > ripped at 320Kbs and my ADSL upstream is 256K, hence I'm running
> into
> > buffering issues.
> >
> > Is there anyway I can stream at a lower rate (say 196Kbs) on the fly
> > (without actually converting the original MP3's)
> >
> > TIA
> >
> > Steve
> edit convert.conf so that the following appears uncommented:
> mp3 mp3 http *
> $lame$ --silent --mp3input -b 32 $FILE$ -
>
> You must have LAME installed, and restart the server. Change 32 to
> whatever
> bitrate you want for streaming. This way, any HTTP client, such as
> Winamp or
> Windows Media Player will use the above command to filter the
> playback through LAME.
>
> -kdf
>
>