PDA

View Full Version : SLimserver hangs Mac System prefs, shutdown process



SteveWong
2006-07-23, 03:19
I'm having a devil of a time with Slimserver, both 6.3.0 and 6.3.1

System:
MacMini Intel 1.66 GHz, 2GB RAM, OSX 10.4.7
Slimserver was installed for all users but this also seems to happen with one user install.
The squeezboxes and web interface work well despite all of this.

Problem:
Both are causing the system prefs to hang: clicking the slimserver pref panel causes the system preferences title bar to say "slimserver loading" and hang there. If I run activity monitor at the same time, it also hangs.

On shutting down (even if I don't attempt the above, ie right after a restart), the Mac hangs and won't shut down. I have to hold the power button down.

I've tried:
1. Safe Boot - then deleting the pref panel
2. Reinstalling: on normal boot, it says "Waiting for System Preferences application to quit" which it never does.
3. Reinstalling in safe mode, then immediately setting slimserver pref panel to NOT startup automatically. Rebooting normally causes all the above to happen.
4. Removing ALL entries under user/startup items
5. Note the prefs application works with all other preferences except slimserver
6. Sudo shutdown now hangs the system, no reports of the hanging application.
7. Safe mode DOES reboot OK.
8. I recall 6.3.0 seemed to be problem free. Upgrading to 6.3.1 may have caused these. Reverting back to 6.3.0 doesn't help and all the above happens.

It looks to me like the slimserver pref panel is causing a hang.


How to fix it? Searching all the posts for full uninstall on Mac suggests only deleting the preference panel.
- Steve

danco
2006-07-23, 08:45
Definitely NOT the preference pane itself, as 6.3.0 work fine with 10.4.7 on my system.

Is this your first install of SlimServer? If not, I would suspect some old stuff that had not been cleared out is causing trouble. Quite possibly the cache (database) in the Caches folder of one or more of the Libraries.

SteveWong
2006-07-25, 02:13
Thanks for above:
it turns out it was a conflict with a driver for a Keyspan networked USB print server: removing that seems to have fixed everything.

Thanks....
- STeve

lumpy
2007-10-22, 18:18
Hey Steve,

Can you go into more detail on how you found the device conflict? I've got similar issues going on a powerPC G4 running OSX 10.4.10. Issues seemed to start with the installation of a new driver on a PCI SATA controller card (for the mirrored drives).