View Full Version : Playlist Locks SlimServer on NV

2006-07-18, 13:04
I posted this on Infrant's Forums, as well. I thought some experts here might have more info on Playlist creation.

I'm using the latest beta on an NV and SlimServer 6.3.0. Whenever I try to save a playlist, SlimServer stops responding and I have to reboot the NV.

:?: 1. Any suggestions? Bug? User Error?

In trying to figure out what is going on I started playing with the Playlist Directory settings in SlimServer but I cannot seem to figure out what it is doing. Regardless of what I put in the playlist folder field, SlimServer is looking somewhere else and coming up with playlists.

:?: 2. Where does SlimServer look for playlist files? Recursive? Is there any way to set this?

:?: 3. What is the correct setting for the Playlist Directory in SlimServer?

:?: 4. (Bonus) Looking at the m3u files with a text editor, the ones saved from SlimServer have many more properties then your average .m3u file.
Is all this extra info required to get SlimServer to play .m3u files correctly? Can someone point me to a site which describes the .m3u standards and what the details mean?

Thanks in advance,


2006-07-21, 12:32
SlimServer 6.3 is locking up as it starts to create the m3u file.

This is painful because it takes Soooooo long to build a playlist using Slimserver that I hate to lose the hours of work. But since I cannot save it, I will lose the list if I want to (or accidently) play anything else!

Does anyone have solutions? bug fix? other ways to save my work?

Where does SlimServer look for playlists on the NV?


2006-07-21, 14:23
I have an NV here, and I was very concerned that maybe this was a bug that slipped though my testing.

However, I'm not able to reproduce these symptoms.

Slimserver saves its playlists to wherever it says on the Server Settings page. (often the same directory where your music is stored)

Is there a valid directory name listed there? Are you able to browse pre-existing playlists okay? Are any 'stubs' of playlists you tried to save there in that directory?

2006-07-21, 19:47
Hi Chris,
Thanks for the reply. I am now running 6.3.1. The attached file shows the info making it into the m3u. Just a couple of squiggles.

After this all my SB3s go dark and the web page returns with unable to display. I no longer have access to the shares except using RAIDar and I have to reboot the NV.

Please let me know what further info I can provide.

Thanks, David

2006-07-24, 09:15
Hmm I would guess Slimserver is crashing while attempting to write the .m3u file. In my experience, .m3u files should be more than 3 bytes long :).

I wonder if any other linux users have seen this problem?

Otherwise I need to find out from the Infrant guys some info about how to get information on the Slimserver process on their system.

I've sent them some email.

2006-07-24, 10:17
Thanks Chris. I have tried a variety of different things and have had no success yet. I will await further instructions from you.


2006-07-26, 13:58
Any word from Infrant?


2006-07-26, 14:40
Infrant tells me that if you've got the RAIDiator 3 beta installed, the log file is in the .zip file that's created when you do "Download All Logs" from the the Logs tab.

If you don't have RAIDiator 3, is there any relevant message on the Status -> Logs page about Slimserver crashing?

It's a problem that I'm not seeing, so I don't think it's a bug in Slimserver, but I'm not very sure how to diagnose it (or fix it!) correctly on your Infrant.

Since I can't actually see the error, I'd like to try deleting your slimserver.prefs file (Because Slimserver will build a fresh one that might not cause the error), or perhaps uninstall and re-install the server (in case it was just some quirk or cosmic ray during installation).

I'll ask our support team as well if they have any tips.

2006-07-26, 14:52
Ah it's under Shares -> Services. There's a "Remove" button next to Slimserver.

Then reinstall it the same way you installed it originally (probably System -> Update).

And let me know if you've tried this before.

2006-07-28, 19:35
Hi Chris...

I have reinstalled and am still encountering the same problem. This is the error message showing up in the SlimServer.log:

Can't locate PerlIO.pm in @INC (@INC contains: /usr/share/slimserver/Plugins/SlimScrobbleSupport /usr/share/slimserver/Plugins /usr/share/slimserver/CPAN/arch/5.8.8/sparc-linux /usr/share/slimserver/CPAN/arch/5.8.8/sparc-linux/auto /usr/share/slimserver/CPAN/arch/5.8/sparc-linux /usr/share/slimserver/CPAN/arch/5.8/sparc-linux/auto /usr/share/slimserver/CPAN/arch/sparc-linux /usr/share/slimserver/lib /usr/share/slimserver/CPAN /usr/share/slimserver /etc/perl /usr/local/lib/perl/5.8.8 /usr/local/share/perl/5.8.8 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at /usr/share/slimserver/Slim/Formats/Parse.pm line 1118.
BEGIN failed--compilation aborted.

I hope this gets us somewhere.


2006-07-31, 10:05
Ah that looks a lot like bug 3650 (which has been fixed).

Do you install that from our binaries or does YM have an installation somewhere that you download?

What version of the server does it say you are running at the bottom of the Server Settings page?

2006-08-02, 12:24
Do you install that from our binaries or does YM have an installation somewhere that you download?


I'm away from my machine until the weekend and will give you more specifics then. The image is downloaded from Infrant and SlimServer is inside of their package. I update the NV using update/local. I have not tried manually placing your SlimServer on the NV (Wouldn't know how to get it on there).

I'm fairly positive, however, that the version number on the server page was the same as being downloaded on the Slim Devices site. 6.3.1 I believe.


2006-08-02, 12:30
Sorry, YM = Yellow Machine, another NAS. Too many NASes in my brain at the moment.

2006-08-07, 14:26
The server settings page reports:

SlimServer Version: 6.3.1 - 8154 - Debian - EN - utf8

This is installed as part of a complete installation of the NV Software.

Looks like this is a different error or it is only partially fixed.

Please check into it again.

Thanks, David

2006-08-07, 15:18
I am having a hard time trying to reproduce this problem.

Do you have multiple Squeezeboxes? If so, does this problem still happen if you unplug one of them?

2006-08-07, 15:50

I have two Squeezeboxes, but I believe I have tried that already... I will try it again.

Additionally, I tried installing SlimServer on my PC (vs. the NV) and used the NV shares. With this setup I have no problem saving playlists to the NV share. It is the same version.

Using the SlimServer running on the NV, I get the error.

Any more ideas? More info I can provide?


2006-08-09, 13:02
I have the same problem. I can save an internet radio station as a playlist but when I hit save -- after giving the playlist a name -- the SB3/SlimServer crashes. The radio station keeps playing but the SB3/SlimServer cannot connect. I also tried resetting the network connection -- both wired and wireless -- but it still won't connect. I can see the ReadyNAS through RAIDar but the neither the SB3 nor the Slimserver will connect. I have to reboot the ReadyNAS to get the SB3/SlimServer back online. Any ideas?

2006-08-09, 13:44
I've created bug 3902 to track this issue. http://bugs.slimdevices.com/show_bug.cgi?id=3902