PDA

View Full Version : Chinese music still skipped



dailofan
2006-07-11, 20:38
I have a number of Chinese and Japanese CDs in my collection. Slim will always skip their directories claiming they are invalid and not include them in the library.
I've tried this on versions 6.2x, 6.3, and now 6.5x. Same problem.

The files were ripped using WMP and are certainly valid directory names but are in double-byte Chinese characters.

Sample error is below:
2006-07-11 23:27:05.1470 ERROR: _isValidPath: Couldn't find directory: [F:\My Music\MP3\隡] on disk: [No such file or directory]

Renaming all the directories to western characters would be a real pain. (It does work and will then display the song in Chinese characters on SB). Anyone find a better fix?

agentsmith
2006-07-11, 21:32
I have a number of Chinese and Japanese CDs in my collection. Slim will always skip their directories claiming they are invalid and not include them in the library.
I've tried this on versions 6.2x, 6.3, and now 6.5x. Same problem.

The files were ripped using WMP and are certainly valid directory names but are in double-byte Chinese characters.

Sample error is below:
2006-07-11 23:27:05.1470 ERROR: _isValidPath: Couldn't find directory: [F:\My Music\MP3\隡] on disk: [No such file or directory]

Renaming all the directories to western characters would be a real pain. (It does work and will then display the song in Chinese characters on SB). Anyone find a better fix?

My experience with Slim server is that it hates all double bytes and accented characters.

Someone kind soul from this forum was kind enough to write me a perl script to remove all the non english characters from a bunch of files automatically. I will try to look it up later and refer you to that thread.

snarlydwarf
2006-07-11, 21:50
What sort of filesystem is your drive F:?

Is it a local drive? Is it a mounted share? If a share, what sort of machine is it on? What OS are you running your server on?

I have plenty of both latin1 and utf8 directories and file names and they both work fine, but that's as ext3 on linux.

kdf
2006-07-11, 23:35
On 11-Jul-06, at 9:50 PM, snarlydwarf wrote:
>
> I have plenty of both latin1 and utf8 directories and file names and
> they both work fine, but that's as ext3 on linux.
>
utf16 could be problem, however.
-kdf

dailofan
2006-07-12, 06:50
The F:drive is a local drive (USB) on an XP Pro workstation. File system is NTFS, I believe(will verify). The system has OS support for both Chinese and Japanese. I have no problem in Windows Media Player reading, displaying or playing these files.

ChrisOwens
2006-07-12, 10:00
This looks like a real bug to me. I'd encourage you to file it at http://bugs.slimdevices.com so we can keep track of it more easily.

Thanks!

monkie
2006-07-15, 01:51
I have this probelm too.
It also extends to Japanese and Korean.

Windows XP, NFTS, UTF8 tags.

Very occasionally, it will recognise a song but it's very rare and I have no idea why it works when it does.

dailofan
2006-07-15, 09:27
I opened a bug: http://bugs.slimdevices.com/show_bug.cgi?id=3739

However, progress seems to have stalled.
I hope someone will contact me soon to continue troubleshooting this.

raylpc
2006-09-14, 12:47
I found a workaround. Go to control panel -> Regional and Language Options -> Advanced, and set the langauge to Chinese (PRC). Then you should be able to see your Chinese, Japanese or Korean songs in slimserver or slimbox.

rwong
2006-10-01, 12:04
change the regional setting - now my chinese music works! thanks!

but my japanese ones still don't... not sure why cuz some do and some don't... just sorta gets ignored even tho they were ripped from the same CD