PDA

View Full Version : Internet radio issues with 6.3



jfo
2006-07-10, 20:54
I switched to 6.3 and have been unable to connect with any of the internet radio options except for Alien BBC, which works fine. I get a "can't open file" message on the SB with all stations. When I click play on Slimserver, nothing happens at all. This is happening on both a wired SB1 and a wireless SB2. I didn't experience this with 6.2.2. Anyone else having similar problems??

Jim

jfo
2006-07-12, 18:59
I switched to 6.3 and have been unable to connect with any of the internet radio options except for Alien BBC, which works fine. I get a "can't open file" message on the SB with all stations. When I click play on Slimserver, nothing happens at all. This is happening on both a wired SB1 and a wireless SB2. I didn't experience this with 6.2.2. Anyone else having similar problems??

Jim

I'm still trying to diagnose the problem with no success. I can however, access all the usual internet radio channels through Squeeznetwork, which seems to point to Slimserver as the problem. I've tried reinstalling 6.3 and deleting/rebuilding the database. Of interest, when I reverted to 6.2.2, Shoutcast had disappeared from the menu list!
Any suggestions on how to troubleshoot this would be appreciated.

Jim

colglfr
2006-07-12, 19:54
I am also having problems with the Internet Radio with my 6.3 installation. If I use the Sqeezenetwork it works better. Hoping someone has a solution

andyg
2006-07-12, 20:43
All stations? Very strange. Can you post a debug log with --d_scan and --d_source?

Maurice2
2006-07-13, 09:24
I have 6.2.2 and SB1 wired. For months connection to radioio had worked flawlessly. Then recently I could not connect at all to radioio. Then the connection worked again. But the last two evenings while listening to it connection stopped and could not be restarted (other internet stations worked fine). This morning it's on and off with radioio. What's going on?

andyg
2006-07-13, 09:27
If it's working some of the time the problem is likely with RadioIO, not SlimServer.

jfo
2006-07-13, 10:40
All stations? Very strange. Can you post a debug log with --d_scan and --d_source?

Here's a sample of the log when I attempt to play several different stations.
Thanks!
Jim

2006-07-13 08:22:32.7743 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:22:32.7744 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:23:02.5891 Adding song index 0 to song queue
2006-07-13 08:23:02.5892 Clearing out song queue first
2006-07-13 08:23:02.5892 Song queue is now 0
2006-07-13 08:23:02.5895 00:04:20:05:ab:56: Switching to mode stop from stop
2006-07-13 08:23:02.5895 Already in playmode stop : ignoring mode change
2006-07-13 08:23:03.0156 00:04:20:05:ab:56: Switching to mode stop from stop
2006-07-13 08:23:03.0157 Already in playmode stop : ignoring mode change
2006-07-13 08:23:03.0158 Adding song index 0 to song queue
2006-07-13 08:23:03.0158 Clearing out song queue first
2006-07-13 08:23:03.0159 Song queue is now 0
2006-07-13 08:23:03.3102 Scan::checkConnect URL OK: http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls
2006-07-13 08:23:03.3103 Scan::addToList: http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls
2006-07-13 08:23:03.3182 Trying to open protocol stream for http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls
2006-07-13 08:23:03.3182 Found handler for http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls - using Slim::Player::Protocols::HTTP
2006-07-13 08:23:03.9065 Scan::checkContentType: Remote content type is pls [http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls]
2006-07-13 08:23:03.9068 Scan::readList gonna read http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls
2006-07-13 08:23:03.9091 Scan::readList loading http://www.shoutcast.com/sbin/tunein-station.pls?id=180587&filename=playlist.pls with base
2006-07-13 08:23:04.2343 Scan::readList loaded playlist with 1 items
2006-07-13 08:23:04.2348 00:04:20:05:ab:56: Switching to mode stop from stop
2006-07-13 08:23:04.2349 Already in playmode stop : ignoring mode change
2006-07-13 08:23:04.2349 Adding song index 0 to song queue
2006-07-13 08:23:04.2350 Clearing out song queue first
2006-07-13 08:23:04.2350 Song queue is now 0
2006-07-13 08:23:04.2353 00:04:20:05:ab:56: Switching to mode play from stop
2006-07-13 08:23:04.2375 openSong on: http://64.62.252.134:5100
2006-07-13 08:23:04.2377 URL is remote : http://64.62.252.134:5100
2006-07-13 08:23:04.2379 Trying to open protocol stream for http://64.62.252.134:5100
2006-07-13 08:23:04.2379 Found handler for http://64.62.252.134:5100 - using Slim::Player::Protocols::HTTP
2006-07-13 08:23:04.6746 openSong: remoteURL is a song : http://64.62.252.134:5100
2006-07-13 08:23:04.7026 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:23:04.7027 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:23:04.7028 undermax = 1, type = mp3, squeezebox2 = 00:04:20:05:ab:56, lame = C:\Program Files\SlimServer\server\Bin\lame.exe
2006-07-13 08:23:04.7029 checking formats for: mp3-wma-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7029 checking formats for: mp3-wma-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7030 checking formats for: mp3-wma-squeezebox2-*
2006-07-13 08:23:04.7030 checking formats for: mp3-wma-*-*
2006-07-13 08:23:04.7030 checking formats for: mp3-flc-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7031 checking formats for: mp3-flc-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7031 checking formats for: mp3-flc-squeezebox2-*
2006-07-13 08:23:04.7032 checking formats for: mp3-flc-*-*
2006-07-13 08:23:04.7032 checking formats for: mp3-aif-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7033 checking formats for: mp3-aif-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7033 checking formats for: mp3-aif-squeezebox2-*
2006-07-13 08:23:04.7033 checking formats for: mp3-aif-*-*
2006-07-13 08:23:04.7034 checking formats for: mp3-wav-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7034 checking formats for: mp3-wav-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7034 checking formats for: mp3-wav-squeezebox2-*
2006-07-13 08:23:04.7035 checking formats for: mp3-wav-*-*
2006-07-13 08:23:04.7035 checking formats for: mp3-mp3-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7036 checking formats for: mp3-mp3-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7036 checking formats for: mp3-mp3-squeezebox2-*
2006-07-13 08:23:04.7037 checking formats for: mp3-mp3-*-*
2006-07-13 08:23:04.7037 Checking to see if mp3-mp3-*-* is enabled
2006-07-13 08:23:04.7038 There are 23 disabled formats...
2006-07-13 08:23:04.7038 Testing wma-wma-squeezebox2-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7039 Testing wma-wav-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7039 Testing wma-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7040 Testing wma-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7040 Testing wav-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7040 Testing wav-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7041 Testing ogg-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7041 Testing ogg-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7042 Testing ogg-aif-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7042 Testing mpc-wav-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7043 Testing mpc-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7043 Testing mpc-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7043 Testing mpc-aif-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7044 Testing mp3-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7044 !! mp3-mp3-*-* Disabled!!
2006-07-13 08:23:04.7045 ******* Error: Didn't find any command matches for type: mp3 format: mp3 ******
2006-07-13 08:23:04.7045 openSong: Couldn't create command line for mp3 playback for [http://64.62.252.134:5100]
2006-07-13 08:23:04.7046 Error opening current track, so mark it as already played
2006-07-13 08:23:04.7072 ERROR: Couldn't open song.

2006-07-13 08:23:04.7073 Got a track starting event
2006-07-13 08:23:04.7074 Song 0 has now started playing
2006-07-13 08:23:04.7076 Song queue is now 0
2006-07-13 08:23:04.7076 opening next song open: 1 error: ...
2006-07-13 08:23:04.7079 the next song is number 0, was 0
2006-07-13 08:23:04.7095 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:23:04.7096 Setting maxBitRate for Downstairs to: 0
2006-07-13 08:23:04.7097 undermax = 1, type = mp3, squeezebox2 = 00:04:20:05:ab:56, lame = C:\Program Files\SlimServer\server\Bin\lame.exe
2006-07-13 08:23:04.7098 checking formats for: mp3-wma-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7098 checking formats for: mp3-wma-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7099 checking formats for: mp3-wma-squeezebox2-*
2006-07-13 08:23:04.7099 checking formats for: mp3-wma-*-*
2006-07-13 08:23:04.7100 checking formats for: mp3-flc-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7100 checking formats for: mp3-flc-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7100 checking formats for: mp3-flc-squeezebox2-*
2006-07-13 08:23:04.7101 checking formats for: mp3-flc-*-*
2006-07-13 08:23:04.7101 checking formats for: mp3-aif-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7102 checking formats for: mp3-aif-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7102 checking formats for: mp3-aif-squeezebox2-*
2006-07-13 08:23:04.7102 checking formats for: mp3-aif-*-*
2006-07-13 08:23:04.7103 checking formats for: mp3-wav-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7103 checking formats for: mp3-wav-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7104 checking formats for: mp3-wav-squeezebox2-*
2006-07-13 08:23:04.7104 checking formats for: mp3-wav-*-*
2006-07-13 08:23:04.7105 checking formats for: mp3-mp3-squeezebox2-00:04:20:05:ab:56
2006-07-13 08:23:04.7105 checking formats for: mp3-mp3-*-00:04:20:05:ab:56
2006-07-13 08:23:04.7105 checking formats for: mp3-mp3-squeezebox2-*
2006-07-13 08:23:04.7106 checking formats for: mp3-mp3-*-*
2006-07-13 08:23:04.7106 Checking to see if mp3-mp3-*-* is enabled
2006-07-13 08:23:04.7107 There are 23 disabled formats...
2006-07-13 08:23:04.7107 Testing wma-wma-squeezebox2-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7108 Testing wma-wav-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7108 Testing wma-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7109 Testing wma-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7109 Testing wav-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7110 Testing wav-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7110 Testing ogg-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7110 Testing ogg-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7111 Testing ogg-aif-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7111 Testing mpc-wav-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7112 Testing mpc-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7112 Testing mpc-flc-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7113 Testing mpc-aif-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7113 Testing mp3-mp3-*-* vs mp3-mp3-*-*
2006-07-13 08:23:04.7113 !! mp3-mp3-*-* Disabled!!
2006-07-13 08:23:04.7114 ******* Error: Didn't find any command matches for type: mp3 format: mp3 ******
2006-07-13 08:23:04.7115 opening next song (old format: , new: mp3) current playmode: stop
2006-07-13 08:23:04.7116 ERROR: Couldn't gotoNext, stopping

andyg
2006-07-13, 10:52
Can you check Server Settings -> File Types, and make sure MP3 MP3 (built-in) is checked?

jfo
2006-07-13, 18:34
Can you check Server Settings -> File Types, and make sure MP3 MP3 (built-in) is checked?

Thanks Andy...that fixed it. I don't listen to MP3 so may have unchecked this at some point.

Jim

jjwrecker
2006-07-28, 17:06
Well, I just got my new Squeezebox today and set up was a breeze. Everything is working except for the Internet Radio off of the SlimServer. I have checked all the file types listed above and have 6.3.0 Slimserver running.

When connecting to SqueezeNetwork, Internet Radio works perfectly.

Could this be another issue? I hate to keep switching to Squeeze network everytime I want Internet Radio.

Please remeber I am a noob to SB. I do understand networking and PC's though.

Also, happens with the Slimserver is down (PC not booted). It seems that the SB wants to connect to SlimServer before full boot. If SlimServer is not booted, can't I get to the SqueezeNetwork straight away?

Mark Lanctot
2006-07-28, 17:17
Also, happens with the Slimserver is down (PC not booted). It seems that the SB wants to connect to SlimServer before full boot. If SlimServer is not booted, can't I get to the SqueezeNetwork straight away?

After the logo splash page, press up or down to get options. Select "Connect to SqueezeNetwork".

If you don't touch anything, it tries to go to where it last connected, and if that's SlimServer when SS isn't up, it'll fail...but it will come right back up again when SS starts.

jjwrecker
2006-07-28, 18:29
Thanks for the tip. Anyone know why I can't access Internet Radio from SlimServer 6.3.0? It appears to be my only issue before I start with all the plug-ins that I want to put in!

Mark Lanctot
2006-07-28, 19:08
Does SlimServer have Internet access rights in your firewall?

jjwrecker
2006-07-28, 19:36
I just updated all ports on Firewall and upgraded to 3.6.1 and everything is working now. I am in love with this little white box.

Now,
1. Wake on Lan
2. Local FM stations in playlists that i can't get living too far out in the mountains
3. Plug in, Plug in and Plug - in's.
4. IR Blaster (once I buy)
5. Remote on PDA
6. etc!!!!

I am going to plug this thing up like a leaky dam!

colglfr
2006-07-29, 19:06
I seem to have a problem launching Internet Radio stations using playlists. It seems to freeze up and I have to shutdown the Squeezebox. I can launch the same radio stations either manually or by setting it up in the SqueezeNetwork and it works fine. I am using 6.3.1