View Full Version : TRACKNUMBER tag in MP3s not recognised

2006-07-07, 06:40
My music collection contains Ogg Vorbis files, FLACs and MP3s. For every file I use a TRACKNUMBER tag.

I've just noticed that the TRACKNUMBER tag is ignored in all my MP3s. The other files are fine. By "ignored", I mean that if I go to New Music and choose an MP3 album, the files are listed in title order; if I click on a single track, there's no "Track:" entry in the metadata list.

I've never noticed this before, but I don't have a lot of MP3s so perhaps the behaviour is not new. I've just upgraded to SlimServer 6.3 and done a full re-scan.

Should I be using a different tag name in MP3s for the track number?


2006-07-07, 08:15
Are your tags ID3v1.1 or ID3v2?

With another device I have, I found that it did not properly recognize the ID3v1.1 track number tags, but it did recognize them in the v2 tags. (I had to delete all the v1.1 tags and replace them with v2. Just adding v2 tags did not do the trick.)

I don't know if the same applies to SlimServer, but it would be fairly easy for you to try it out on an album or two of files.

2006-07-07, 08:52
Aha, an excellent point. Foobar2000 apparently has the ID3v2 plugin installed, but it doesn't tell me what sort of tags I have... okay another utility seems to thing I've got ID3v1 and APEv2 tags in place.

I'll try to work out how to get fb2k to really write ID3v2 tags, and report back. Thanks for the suggestion.

2006-07-07, 09:01
Or you can use an ID3 tag editor to convert the tags in batch. I use ID3-TagIT for all my tag management/validation. Pretty powerful and it's free.

Check it out here: http://www.id3-tagit.de/english/index.htm


2006-07-07, 10:17
I found the relevant settings in fb2k, and tested a few files: it is indeed the case that if ID3v1 is present at all, the tracknumber is ignored. I set all my MP3s to have purely ID3v2 tags (I don't think I need the backwards-compatibility) and re-scanned, and everything looks good.

Thanks for your help guys.