PDA

View Full Version : Error: Cant open remote URL - Shoutcast



abacus
2006-07-07, 04:02
Hi,
Im new to squeezebox 3. I keep getting Error: Cant open remote URL on Shoutcast in the squeezenetwork. It seems to work fine if I use slimserver. It looks like its having a problem with a playlist.pls file lookup? The interesting thing is I've been on with technical support and they cant figure it out....also after speaking to tech support last nite about an hour later it mysteriously worked and now this morning Im getting the same thing. Does anyone else have this problem and was able to figure out how to fix it? Im sure its something to do with Squeezenetwork. All the other internet radio's work 35 radioio ect...and pandora...just Shoutcast isnt working?

mherger
2006-07-07, 04:54
> support last nite about an hour later it mysteriously worked and now
> this morning Im getting the same thing.

Shoutcast sometimes experiences reliabilty issues. I guess SQN does cache
the information about streams longer than does your slimserver. The links
in there probably were outdated.

Just to say that I don't have a solution, but experienced the same last
night :-/

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

andyg
2006-07-07, 05:35
On Jul 7, 2006, at 7:54 AM, Michael Herger wrote:

>> support last nite about an hour later it mysteriously worked and now
>> this morning Im getting the same thing.
>
> Shoutcast sometimes experiences reliabilty issues. I guess SQN does
> cache the information about streams longer than does your
> slimserver. The links in there probably were outdated.

Actually we only cache the playlist links which shouldn't get outdated:

http://www.shoutcast.com/sbin/tunein-station.pls?
id=976120&filename=playlist.pls

The problem seems to be that their server that handles these links
sometimes gets overloaded and doesn't return a proper playlist. I'm
trying to find a good solution that doesn't cache the audio links and
mess up their internal listener counters. The interesting thing is
that the problem should affect both SN and SlimServer equally. since
they both use the same links.

Ruiner
2006-07-07, 06:26
Hi,
Does anyone else have this problem and was able to figure out how to fix it? Im sure its something to do with Squeezenetwork. All the other internet radio's work 35 radioio ect...and pandora...just Shoutcast isnt working?

I'm experiencing the same problem...this morning i have noted that signing off and reconnceting to SN just do the trick...but i don't know if it has been just random or a real fix...maybe tonight i will investigate better this issue...

Paolo

abacus
2006-07-07, 09:52
This afternoon now it seems to be working again...but later tonight might not..I hope you guys can get it to work. When I log onto the slimserver it seems to be doing a fetch. On the squeezenetwork it seems to be trying to point to that playlist.pls file. So the dynamics seem different to me. Either way I always connect to the slimserver, so squeezenetwork should be coded to do the same thing as slimserver does if thats possible?

LHawes
2006-07-08, 07:33
Just found the same thing after working perfectly for oh.. I'd say 20 minutes.

Oh wait, now it's working again. Ho Hum...

andyg
2006-07-09, 09:47
I've just updated SN to report some better errors when streams fail to play. In my testing, most Shoutcast stations that fail to play will play if you just retry them a few times. This is due to overloaded Shoutcast servers which send back empty playlists. The error you'll see when this happens is "No items found in playlist".

Sometimes also, www.shoutcast.com fails to respond at all, the error when this happens is "Can't connect to retrieve playlist". Usually, you can just retry and it'll connect.