PDA

View Full Version : Random Mix occasionally fails



Mark Lanctot
2006-07-03, 09:19
At first I thought I was seeing the return of bug 2510 (http://bugs.slimdevices.com/show_bug.cgi?id=2510), which was fixed. (This was when Now Playing was one track behind what was actually playing.)

But this is probably a different issue. About once an hour in Random Song Mix playback, I see what appears to be bug 2510 again, but at the end of the out-of-synch track, playback stops. If I press play, it goes back to the first track in the Random Mix playlist (I have Random Mix display 3 tracks). I have to skip the tracks, and when I get to the third one, i.e. the first one that was out-of-synch, another press of the skip button will bring up a new Random Mix track and everything goes back to normal.

So the problem is actually that Random Mix failed and bug 2510 is only the symptom.

Should I create a bug report? There doesn't seem to be an existing bug report for this issue.

Thanks.

Edit: whoops, this is with 6.3.0 official on Windows XP <blush>

Mark Lanctot
2006-07-04, 10:02
Guess not huh?

I'll submit a bug report shortly then.

What kind of logs should I include?

kdf
2006-07-04, 10:19
Quoting Mark Lanctot
<Mark.Lanctot.2afkib1152032701 (AT) no-mx (DOT) forums.slimdevices.com>:

> What kind of logs should I include?

d_plugins, d_source maybe
-k

Mark Lanctot
2006-07-04, 16:45
Bug 3696 (http://bugs.slimdevices.com/show_bug.cgi?id=3696) created.

Of course after enabling logging it hasn't happened since. ;-)