View Full Version : Slimserver 6.3 is not reading my second drive

Peter Evans
2006-06-29, 14:56

I was using windows XP, slimserver 6.2.2, SB1 and SB2, and everything was running perfectly, scanning my 32000 songs in less than 45 minutes.

I was having the famous 30-second freeze, which was not present with the previous 6.0 versions.

Now with 6.3, it's not reading the tags on the second drive. I can get through the windows shortcut with Browse Music Folder to that directory, but it still can't read the tags (Flac files). On the positive side the 30 second freeze has been eliminated.

I've also tried 6.5, same thing.

Is anybody having this problem?


Peter Evans
2006-06-30, 03:26
I've gone back to 6.2.2 and I don't have this problem anymore. Slimserver follows the windows shortcut to the second directory.

For some reason 6.3 and 6.5 are not getting to the second drive.

While browsing music folder, when I get to any of the files on the second drive I see that all of them have too many slashes on the file name: \\\\\\\\\amd\extension\etc

Peter Evans
2006-07-13, 06:55
What has changed as from 6.3 that SS can't get through windows shortcuts?

My 400 Gb drive has died on me today, so I have to go back to 6.22 (with the 30 second freeze), keep 6.3 and use on drive only and throw away 15000 tracks.

Has anyone have any suggestion on what can I do to fix this?

Thanks in advance,


2006-07-13, 07:17
What's the format of the shortcut? Looks like you're using a UNC name in there, you could try just a plain drive letter seeing as it's a local disk.

Peter Evans
2006-07-19, 11:35
SS 6.3 and onwards don't like my \\servername\ shortcuts.

If my shortcut is C\extension then it does work, except for 75 FLAC files which are not readable or playable.

I've tried setting up a new SS on another computer with 11 of these files (DVD video PCM rips @ 48000 hz) and I still have the same problem.

With some debug switches on I get the following:

2006-07-19 20:02:19.8572 extracted: C:\My Music\Enigma\MCMXC AD (DVD)\01 - Sadne
ss (video).flac from file:///C:/My%20Music/Enigma/MCMXC%20AD%20(DVD)/01%20-%20Sa
2006-07-19 20:02:19.8898 Invalid Catalog entry
2006-07-19 20:02:19.8914 [C:\My Music\Enigma\MCMXC AD (DVD)\01 - Sadness (video)
.flac] Problem parsing cuesheet metadata block! at C:\Archivos de programa\SlimS
erver2\server\CPAN/Audio/FLAC/Header.pm line 112.
2006-07-19 20:02:19.9321 ERROR: FLAC: Couldn't open file: [C:\My Music\Enigma\MC
MXC AD (DVD)\01 - Sadness (video).flac] for reading:

Debug switches used are: source & files

SS 6.2.2 works fine except for a 30 second freeze.

Anybody got any ideas what has changed to make this?

Any other debug switch I should try?



2006-07-19, 15:26
I think the newly release 6.3.1 may help you.

2006-07-19, 15:52
This sounded like a bug to me, so I tested it with today's 6.5 nightly and (almost to my surprise) it worked fine. Tracks located in \\6-5-XPS-6JUL06\shortcuttest\VariousArtistsTest2-flac\ were scanned and play okay.

I notice there's something about cuesheets in your log. Is your content full-album flacs with external cuesheets? Do individual flac files work any better?

Peter Evans
2006-07-20, 13:16
First of all, many thanks for your replies.

I've tested SS 6.3.1 - Same problem

I don't have a single cue file - either standalone or embedded.

All files are single track.

What puzzles me is that SS 6.2.2 works just fine, save for the 30 second freeze. So it seems I'll have to choose to stay with 6.2.2

These FLAC files play OK with dbamp, J River, Windows media player, and slimserver 6.2.2

Is there any other debug switch I could try?



Peter Evans
2006-07-20, 13:58
Today's nightly (6.5b) has the same problem.

Attached debug screen with d_parse on.

It can't read my metadata!

Any idea why is this happening?


Peter Evans
2006-07-20, 14:36
Metaflac 1.1 CLI editor can read these files

Metaflac 1.2 CLI can't

Tomorrow I'll recode and tag one of the problematic albums in both FLAC 1.1 & 1.2 and post results...


2006-07-20, 23:42
SS 6.3 and onwards don't like my \\servername\ shortcuts.
This is not my experience at all. I now use UNC shortcuts with 6.3 (.1?) and they are fine. There is some info from MeyerGru in this thread which may throw some light (or not):

Peter Evans
2006-07-21, 01:33
I've decoded my problematic FLACs back to wav, and encoded them with FLAC frontend again using flac 1.1.1

Now the SS 6.3.1 metaflac subroutine can parse and read the tags, as well as playing them.

So the answer to my question: what has changed as from 6.3?

The Metaflac subroutine...