PDA

View Full Version : Problems with Slimserver 6.3.0



Ledwidge
2006-06-27, 19:52
I have installed this and now I have lots of duplicate entries in my music database. Even after I uninstall it and go back to 6.2.2 or even 6.2.1 I cannot fix the problem. It duplicate both some CD titles and tracks.

Siduhe
2006-06-28, 01:47
The multiple album entries has been reported before, but the duplicate tracks thing came up for the first time yesterday:

http://forums.slimdevices.com/showthread.php?t=24955

No-one is quite sure if it's a tag issue or a bug - it doesn't appear to affect all albums, and seems to mainly affect albums with multiple artists ? My theory remains that it is something to do with the different way that Slimserver reads tags in 6.3.0. but I haven't been able to reproduce it on demand.

I managed to resolve "the multiple copies of albums with one song in each album" by opening each album in a tag program and resaving the album and compilation fields, then doing a full rescan. You might want to try that.

On the duplicate tracks - do you have any unicode characters in the file names (not tag names) ? Like or ? If so, replace them and rescan.

hansto
2006-06-28, 06:51
Siduhe schrieb:

> No-one is quite sure if it's a tag issue or a bug - it doesn't appear
> to affect all albums, and seems to mainly affect albums with multiple
> artists ? My theory remains that it is something to do with the
> different way that Slimserver reads tags in 6.3.0. but I haven't been
> able to reproduce it on demand.

My experience with the new code:

1. It depends on the order in which Slimserver reads the files. That
depends on how the files are named.

2. Problems occur when you have songs of multiple compilation albums in
one folder. But it might work if the filenames start with the album name.
(It should work if all songs of one album are read in sequence.)

3. Problem is solved when setting compilation tag on the affected files
and doing a full rescan.

4. It does not occur with only one album per folder. (every track number
occurs only once, album name is exactly the same for all files)
Compilation albums are then automatically detected.

5. A completely different problem with similar symptoms might occur of
you have the LazySearch plugin installed and do "Look for new and
changed music". Maybe a server upgrade also does this.

Hope that helps.

Hanno.

Siduhe
2006-06-28, 07:01
My experience with the new code:

3. Problem is solved when setting compilation tag on the affected files and doing a full rescan.


Hi Hanno, that's been my experience also.

However, some people are experiencing the same problem on files which do not using the compilation tag. In these cases, AFAIK, it's been resolved just by resetting the album tag and doing a full rescan.

hansto
2006-06-28, 10:12
Siduhe schrieb:

> However, some people are experiencing the same problem on files which
> do not using the compilation tag. In these cases, AFAIK, it's been
> resolved just by resetting the album tag and doing a full rescan.

I usually don't use the compilation tag, either. I only had to set it in
those special cases. (multiple various artists albums in one folder)

Greetings,

Hanno

Ledwidge
2006-06-28, 19:54
All my albums are in seperate directories. It seems to effect both compilation albums and some single albums with no specific reason. Even if uninstalled, it continus to effect earlier versions such as 6.2.1 or 6.2.2. Is there a way to remove absolutely all of 6.2.3, what files could I be missing when I uninstall.