PDA

View Full Version : Using Slimserver without Slimp3?



Dan Richardson
2003-11-24, 17:23
I checked the archives, and I can't seem to find out the answer to
this:

Can the Slimserver be used WITHOUT a Slimp3 (or squeezebox) on the
network?

I wanted to test it out before plunking down $300, since I've had a
Rio Receiver with Jreceiver, and now I've got an HP DE200c (works,
but want all MP3's on my main 24x7 server).

I installed the Slimserver on both a Mac OS X Panther machine, and a
Red Hat 9 Linux machine (RPM) - and the same result from my Mac - the
web server, under "Now Playing" "Your player was not found". I can't
add anything to play lists, and I went into iTunes, opened stream
"http://127.0.0.1/stream.mp3" - iTunes says "stream.mp3 elapsed time
0:00", and just stays there.

Am I missing something?

-Dan

__________________________________
Do you Yahoo!?
Free Pop-Up Blocker - Get it now
http://companion.yahoo.com/

Raymond Day
2003-11-24, 23:00
I upgraded to the 5 vershion. The time on my SliMP3 was way off. I could not
get it right. I use webmin to upgrade and do all this. I put in it's time
"tock.usno.navy.mil" that seemed to work good for about 3 weeks. Because I
could not get the time right on my SliMP3 I went to install the new vershion
5 slimp3 server. I used webmin to install it. I said upgrade too. But the
old one was still there. I used webmin to uninstall the old one. Now when I
start the new vershion it can't. It comes back with this:

Executing /etc/rc.d/init.d/slimserver start ..


Starting SlimServer: Can't locate loadable object for module Time::HiRes in
@INC (@INC contains: /sa2/lib/site_perl /usr/lib/perl5/5.6.1/i386-linux
/usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux
/usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl/i386-linux
/usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux
/usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .
/usr/local/slimserver /usr/local/slimserver/CPAN
/usr/local/slimserver/CPAN/arch/i386-linux) at
/usr/local/slimserver/slimserver.pl line 78
Compilation failed in require at /usr/local/slimserver/slimserver.pl line
78.
BEGIN failed--compilation aborted at /usr/local/slimserver/slimserver.pl
line 78.
[FAILED]

I don't know what's wrong. I don't think it's the new slimsever. It was
working real good with the 4 vershion. I just started to get the time off by
about 5 hours. Could not get it right on my SliMP3 player. My guess is
setting it up in webmin messed the time up some how after 3 or so weeks. I
turned Syne system time off in webmin but still get this error.

I hope some one can help. It's running on Redhat Linux 7.3 and that's on a
Toshiba Magnia SG20. So I can't upgrade Linux if any one says to do that. I
can telnet to it. Just need to know what commands to do to fix this.

-Raymond Day

Kevin Deane-Freeman
2003-11-24, 23:05
try the following on an command line:
perl -MCPAN -e "install Time:HiRes"

You are missing Time::HiRes, which is strangely not included in some releases of
Redhat. The command above should download and install it for you via the online
CPAN archives.

good luck,
kdf



Quoting Raymond Day <raymondday (AT) hotmail (DOT) com>:

> I upgraded to the 5 vershion. The time on my SliMP3 was way off. I could not
> get it right. I use webmin to upgrade and do all this. I put in it's time
> "tock.usno.navy.mil" that seemed to work good for about 3 weeks. Because I
> could not get the time right on my SliMP3 I went to install the new vershion
> 5 slimp3 server. I used webmin to install it. I said upgrade too. But the
> old one was still there. I used webmin to uninstall the old one. Now when I
> start the new vershion it can't. It comes back with this:
>
> Executing /etc/rc.d/init.d/slimserver start ..
>
>
> Starting SlimServer: Can't locate loadable object for module Time::HiRes in
> @INC (@INC contains: /sa2/lib/site_perl /usr/lib/perl5/5.6.1/i386-linux
> /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux
> /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux
> /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl/i386-linux
> /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux
> /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl .
> /usr/local/slimserver /usr/local/slimserver/CPAN
> /usr/local/slimserver/CPAN/arch/i386-linux) at
> /usr/local/slimserver/slimserver.pl line 78
> Compilation failed in require at /usr/local/slimserver/slimserver.pl line
> 78.
> BEGIN failed--compilation aborted at /usr/local/slimserver/slimserver.pl
> line 78.
> [FAILED]
>
> I don't know what's wrong. I don't think it's the new slimsever. It was
> working real good with the 4 vershion. I just started to get the time off by
> about 5 hours. Could not get it right on my SliMP3 player. My guess is
> setting it up in webmin messed the time up some how after 3 or so weeks. I
> turned Syne system time off in webmin but still get this error.
>
> I hope some one can help. It's running on Redhat Linux 7.3 and that's on a
> Toshiba Magnia SG20. So I can't upgrade Linux if any one says to do that. I
> can telnet to it. Just need to know what commands to do to fix this.
>
> -Raymond Day
>

Raymond Day
2003-11-24, 23:16
Wow thanks Kevin. That was fast. I tryed what you said. But I get this:

Red Hat Linux release 7.3 (Valhalla)
Kernel 2.4.18-3custom on an i686
login: telnetuser
Password:
Last login: Sat Nov 15 03:03:25 from 192.168.0.8
bash-2.05a$ su
Password:
[root@myserver telnetuser]# dir
[root@myserver telnetuser]# pwd
/sa2/home/telnetuser
[root@myserver telnetuser]# perl -MCPAN -e "install Time:HiRes"
syntax error at -e line 1, near "Time:"
Execution of -e aborted due to compilation errors.
[root@myserver telnetuser]#

Looks like my be on the right track. Can't you think of what else to do?
Thank you for helping!

-Raymond Day

Kevin Deane-Freeman
2003-11-24, 23:20
d'oh! I must have typed that wrong. the colon needs to be double
perl -MCPAN -e "install Time::HiRes"
-kdf

Quoting Raymond Day <raymondday (AT) hotmail (DOT) com>:

> Wow thanks Kevin. That was fast. I tryed what you said. But I get this:
>
> Red Hat Linux release 7.3 (Valhalla)
> Kernel 2.4.18-3custom on an i686
> login: telnetuser
> Password:
> Last login: Sat Nov 15 03:03:25 from 192.168.0.8
> bash-2.05a$ su
> Password:
> [root@myserver telnetuser]# dir
> [root@myserver telnetuser]# pwd
> /sa2/home/telnetuser
> [root@myserver telnetuser]# perl -MCPAN -e "install Time:HiRes"
> syntax error at -e line 1, near "Time:"
> Execution of -e aborted due to compilation errors.
> [root@myserver telnetuser]#
>
> Looks like my be on the right track. Can't you think of what else to do?
> Thank you for helping!
>
> -Raymond Day
>

Victor Brilon
2003-11-24, 23:22
Try this:
perl -MCPAN -e "install Time::HiRes

Note the double colon there, that'll make all the difference in the world ;)

Victor

Raymond Day wrote:
> Wow thanks Kevin. That was fast. I tryed what you said. But I get this:
>
> Red Hat Linux release 7.3 (Valhalla)
> Kernel 2.4.18-3custom on an i686
> login: telnetuser
> Password:
> Last login: Sat Nov 15 03:03:25 from 192.168.0.8
> bash-2.05a$ su
> Password:
> [root@myserver telnetuser]# dir
> [root@myserver telnetuser]# pwd
> /sa2/home/telnetuser
> [root@myserver telnetuser]# perl -MCPAN -e "install Time:HiRes"
> syntax error at -e line 1, near "Time:"
> Execution of -e aborted due to compilation errors.
> [root@myserver telnetuser]#
>
> Looks like my be on the right track. Can't you think of what else to do?
> Thank you for helping!
>
> -Raymond Day
>

Raymond Day
2003-11-24, 23:50
Thank you Kevin! It worked. After a lot of text. It asked me a lot of stuff.
I did not know what to say mostly I just pressed Enter. After all that I
started slimserver. It came back with:

Executing /etc/rc.d/init.d/slimserver start..
Starting SlimServer: [ ok ]

I went to my SliMP3 turned it on and it works. Right time now too.

I then went to http://192.168.0.62:9000 and it's working real good. Says
it's "SlimServer Version: 5.0.0" I think they upgraded it but I guess I wait
till it says there's a new version on version 4 did. That's how I got this 5
version just clicked the link in the slimserver.

Thank you again Kevin!

-Raymond Day

Kevin Deane-Freeman
2003-11-25, 00:05
Excellent!
sorry about the initial typo.
There is a pre-release version available at:
http://www.slimdevices.com/downloads/nightly/latest/

However, you should wait for the full release, unless you are having some
problems with the current one.

-kdf

Quoting Raymond Day <raymondday (AT) hotmail (DOT) com>:

> Thank you Kevin! It worked. After a lot of text. It asked me a lot of stuff.
> I did not know what to say mostly I just pressed Enter. After all that I
> started slimserver. It came back with:
>
> Executing /etc/rc.d/init.d/slimserver start..
> Starting SlimServer: [ ok ]
>
> I went to my SliMP3 turned it on and it works. Right time now too.
>
> I then went to http://192.168.0.62:9000 and it's working real good. Says
> it's "SlimServer Version: 5.0.0" I think they upgraded it but I guess I wait
> till it says there's a new version on version 4 did. That's how I got this 5
> version just clicked the link in the slimserver.
>
> Thank you again Kevin!
>
> -Raymond Day
>