PDA

View Full Version : Here'a a fix for Firefox memory leak



Lowrent
2006-06-25, 11:09
1. Type about:config in url.
2. Right-Click / New / Integer
3. Enter Preference Name : browser.cache.memory.capacity
4. And put 16384 or 32768 depending on your ram (512k or 1gig and above).

Now you can leave your SlimServer page openend and not worry about Firefox taking up to 250 megs of ram after an hour :).

snarlydwarf
2006-06-25, 11:11
oooh if that works, I'll be VEERRY happy.

restarting firefox now since it's already grumpy this morning so see if it helps :)

Mark Lanctot
2006-06-28, 11:29
Well, did it work?

I don't think I've had a problem with SlimServer causing the FF memory leak, but Gmail caused it just now for me - I killed the FF process when it exceeded 200 MB of memory!

So I applied the fix.

snarlydwarf
2006-06-28, 11:37
Dunno, it still leaks for me... :/ Maybe something else is causing it to leak, too... it seems to be leaking slower than before.. but it still leaks.

bgriffis
2006-06-28, 13:34
Didn't work for me either. I have that "leak" issue no matter what pages I'm viewing, i.e. it's not SS specific.

dbls
2006-06-29, 10:23
Didn't work for me either. I have that "leak" issue no matter what pages I'm viewing, i.e. it's not SS specific.

I've always assumed it was some extension I've installed. It would be nice if FireFox allowed you to disable extensions rather than deleting them (at least, I don't think you can merely disable them) for the purpose of debugging. Then I'd disable them all, and enable one at a time to see if I could find the culprit.

bklaas
2006-06-29, 10:27
view your extensions, then right click on one and say "disable". that extension will be disabled on the next firefox restart.

cheers,
#!/ben

ZappaLover
2006-06-29, 10:31
I've always assumed it was some extension I've installed. It would be nice if FireFox allowed you to disable extensions rather than deleting them (at least, I don't think you can merely disable them) for the purpose of debugging. Then I'd disable them all, and enable one at a time to see if I could find the culprit.

You can. click on tools-extensions. Right click on the individual extensions, choose disable, & Bob's yer uncle.

dbls
2006-06-30, 12:18
You can. click on tools-extensions. Right click on the individual extensions, choose disable, & Bob's yer uncle.

Thanks. Silly me - I expected a button, like "Uninstall" or "Options".

narlus
2006-08-01, 09:13
that leak 'fix' didn't work for me either...it's a pain, because my library is HUGE (almost 100K songs) and i use the downstairs laptop as another remote sometime to control the SB.

guess i'll have to stick w/ IE for localhost viewing/controlling...