PDA

View Full Version : Non Slimserver Playlists Not Showing



Dick Sternum
2006-06-19, 15:54
Appologies if this has already covered, but I couldn't find anything.

Essentially, if I create playlists either from the SB or through the web interface of SlimServer, I can browse them.

If I create playlists as M3U files through another application (Winamp say) and save them to my playlist folder I don't see them even after doing a rescan.

I have just moved from 6.2.1 to 6.2.2 on Windows Server 2003 to see if that improved things, but no. I have been constantly upgrading slim server, so perhaps it's time to uninstall and start again.

Siduhe
2006-06-19, 15:58
There was a problem, hopefully now resolved, with 6.3.0. but someone else was having a problem with 6.2.2 earlier this evening. May be worth posting there instead:

http://forums.slimdevices.com/showthread.php?t=24842&highlight=playlist

Some people have found that opening up the playlist in a text editor like notepad and resaving it (with no changes) then doing a playlist only rescan sorts the issue out.

Dick Sternum
2006-06-19, 16:02
I saw the posting regards the 6.3.0 6.2.2 - but I've been having this issue for ages (probably since before 6.2.0).

Just tried opening in notepad and saving then did a rescan of playlists only, but still the same.

I think I'm just gonna end up uninstalling and re installing the server.

Ross L
2006-06-19, 17:21
Uninstalling and re-installing may resolve this issue. It's possible something is wrong with the .pref file, in which case you may not need to uninstall/re-install. You could just stop the server, delete the .pref file, restart the server and then reconfigure slim server.

Are you specifying a location for your playlist folder within server settings?

Dick Sternum
2006-06-20, 01:26
SlimServer is configured with a folder that holds my playlists.

I just installed SlimServer onto a fresh machine as a test, created a folder for music with a couple of albums in it and a folder for paylists into which I copied all playlists from the server. This time it doesn't pick up anything at all.

Siduhe
2006-06-20, 02:55
Just a thought: but are the paths of your playlists created outside of Slimserver the same as the way Slimserver sees them ?

If Slimserver sees your music library as a network share (e.g. M:\My Music), and the software which created the playlists sees them as something different (C:\Share\My Music), that might explain why none of them show up. Or are you using relative paths ?

Dick Sternum
2006-06-20, 03:17
No - but I moved my music folders to seperate MP3 and FLAC files some time ago, and these playlists were pointing at the old location.

Doh!

Often you just need an extra set of eyes to sort the wood from the trees! Thanks.