PDA

View Full Version : 6.5b1 on Debian (Ununtu) - empty Library?



jimwillsher
2006-06-17, 10:13
Hi,

I've installed 6.5b1 on Ubuntu (Dapper) via apt-get.

Not for love nor money can I get the library to have anything in it!

Browsing the music folder works fine, and for each album I play manually (via browse), that albums gets added to the the library. But I don't really want to have to play 700+ albums just to add them to the library!


All was working fine on 6.2.2 on Ubuntu Breezy.

Can I force a rebuild of the library? The "Rescan everything" button does precisely nothing, and the log.txt file shows nothing of any use whatsoever.

Can anyone help? I'm getting desperate here!




Jim

jimwillsher
2006-06-17, 10:33
I should add. When I look at the processes via

ps -auxww | grep slim

I see

[slimserver-scan] <defunct>


Does that mean the scanning thread has died?

jimwillsher
2006-06-17, 11:03
Don't worry. 6.5 is a bag of nails. I've removed it, and built 6.3 from the tarball, and all is now working fine.

Jim

cocjh1
2006-06-18, 03:58
I've got exactly the same problem after installing 6.5b1 on Ubuntu 6.0.6.

Trouble is I don't know how hoe to use the 6.3 tarball.
Could you please explain in further detail...
EG, where to download from and how to install? :)

Thanks,
Chris

jimwillsher
2006-06-18, 04:13
No problem.

Okay, on your Ubuntu box, first uninstall slismerver:

apt-get remove slimserver

The Remove procedure doesn't seem to get rid of everything, so I did a quick check for any stuff that was left via:

cd /
find / -name slimserver*

and rmeoved the excess stuff.

Next, download the tarball. I'm using the 6.3. release, which seems stable enough. Bear in mind that 6.3 is built using the "nightly" cycle, so the filenames below will change daily. You might prefer to use the 6.2.2 release.

The 6.3 webpage is here:

http://www.slimdevices.com/downloads/nightly/latest/6.3.0/

so on your server enter:

wget http://www.slimdevices.com/downloads/nightly/latest/6.3.0/SlimServer_6_3_x_v2006-06-18.tar.gz

(I download it to my home directory).

Next, unpack the tarball:

tar -xzf SlimServer_6_3_x_v2006-06-18.tar.gz


Move the folder to /usr/local

mv SlimServer_6_3_x_v2006-06-18 /usr/local


Create a symlink called slimserver. This means you will "appear" to have a slimserver folder, but it will actually point to your SlimServer_6_3_x_v2006-06-18 folder. Useful for having multipel copies:

cd /usr/local
ln -s SlimServer_6_3_x_v2006-06-18 slimserver


Next, build the application:

/usr/local/slimserver/Bin/build-perl-modules.pl

You will be prompted for pathnames. I entered:
/usr/bin/perl
/usr/local/slimserver
/tmp

Ignore any "signedness" messages, they don't seem to matter.


Now start the server:
cd slimserver
./slimserver.pl --daemon


And that should be it!

When you compile it, you might get an error:

Couldn't find a valid dynamic library for XML-Parser-2.34.tar.gz - something is wrong. Exiting!

In this case just type:

apt-get install libexpat1-dev

and then re-run the

/usr/local/slimserver/Bin/build-perl-modules.pl

script, and you should be fine. My slim has been up for 14 hours now, without any issues.

Good luck!



Jim

cocjh1
2006-06-18, 13:26
Thanks Jim, great instructions.

I now have a fully working v6.2.2 slimserver, library indexed and available :)

However, I'm starting the slimserver with slimserver.pl --daemon.
How can I automate the starting of the process at boot-up?

I've read this thread...
15548
...but the process refuses to start. The following is appended to the /var/logs/slimserver.log file

DBI connect('hostname=127.0.0.1;port=9092;database=/var/cache/slimserver/.slimserversql.db','slimserver',...) failed: Can't connect to MySQL server on '127.0.0.1' (111) at /usr/local/SlimServer_v6.2.2/Slim/DataStores/DBI/DataModel.pm line 147

Any ideas?

Thanks
C:

jimwillsher
2006-06-18, 13:30
Nice one :=)



This is what I have on my system:

Create a startup file /etc/init.d/slimserver
#!/bin/sh
echo "Starting SlimServer"
cd /usr/local/slimserver; ./slimserver.pl --daemon


Set the file permissions
chmod 755 /etc/init.d/slimserver


Create the chklevel links to enable upoj startup
cd /etc/rc2.d
ln -s /etc/init.d/slimserver S99slimserver



I've not tested the startup thing yet - I only reboot when I need to, so that could be another 6 months - but the same file used to work on my Ubuntu Breezy system so it should be fine.


The message you are getting looks like a permissions problem. Does the user (from your slimserver.pref file) have correct permissions within MySql?



Jim

cocjh1
2006-06-18, 14:56
Thanks Jim for your startup script but ended up using the one from the other thread.

The problem in the end was solved by deleting the existing /etc/slimserver/slimserver.pref file and forcing a fresh one out.

Suppose I should have trusted you with the 'find / -name slimserver*' command and deleted it earlier. Just didn't think it would be a problem keeping that file!!!

Anywy, sorted now :)
Thanks again,

C:

chiphart
2006-06-20, 05:39
jimwillsher wrote:
> Okay, on your Ubuntu box, first uninstall slismerver:

[6.3 Ubuntu install instructions followed]

First, thanks for those. When I loaded Ubuntu at home back in
March or so, there were a few sets of instructions for 6.1? in
some of the forums, but they differed in spots [iirc] and I
could never get the package to work properly. Part of it was
that I was so used to the rpm package and where things lived.

The 6.5 deb package rolled out at the same time and it worked
immediately so I've stuck to it. I've had only two problems in
the ~10 nightly upgrades I've done since then - once, it needed
some perl modules I didn't have (easy enough) and then, about a
week ago, I started having the VERY SAME PROBLEM reported here
regarding the results from scanning (1000s of tracks, hundreds
of artists, dozens of albums, or some variation).

FWIW, the nightly from 2 nights ago fixed this problem. If
you're struggling with 6.5b right now, try it today.

--
Chip Hart - Pediatric Solutions * Physician's Computer Company
chip @ pcc.com * 1 Main St. #7, Winooski, VT 05404
800-722-7708 * http://www.pcc.com/~chip
f.802-846-8178 * Pediatric Software Just Got Smarter.
Your Practice Just Got Healthier.