PDA

View Full Version : OS X problem with fresh install



Victor
2006-06-10, 22:12
I wiped out my previous Slim install on my OS X machine and installed from scratch tonight using the release 6.2.2 software.

No matter what skin I use something is seriously wrong. Intermittently frames don't show up. I can't browse my library since nothing shows up there. Very weird stuff considering the previous release (sorry don't remember what version) was working fine.

Starting up the server in debug mode, I see this in the logs:
006-06-11 00:07:04.5434 Odd number of elements in anonymous hash at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/Setup.pm line 2308.
2006-06-11 00:07:04.5440 Use of uninitialized value in anonymous hash ({}) at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/Setup.pm line 2308.
2006-06-11 00:07:05.5555 Using a hash as a reference is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/MusicMagic/Plugin.pm line 1262.
2006-06-11 00:07:05.5563 Using a hash as a reference is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/MusicMagic/Plugin.pm line 1277.
2006-06-11 00:07:05.9187 defined(@array) is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/ShoutcastBrowser/Plugin.pm line 138.
2006-06-11 00:07:05.9190 (Maybe you should just omit the defined()?)
2006-06-11 00:07:05.9196 defined(%hash) is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/ShoutcastBrowser/Plugin.pm line 171.
2006-06-11 00:07:05.9198 (Maybe you should just omit the defined()?)
2006-06-11 00:07:09.7821 Use of uninitialized value in numeric eq (==) at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Player.pm line 618.
2006-06-11 00:07:26.0453 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
file error - html/ajax.js: not found
2006-06-11 00:07:27.4823 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:27.7083 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
file error - crumblist: not found
2006-06-11 00:07:29.3114 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3116 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3117 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3118 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.

Any suggestions as how to better diagnose this problem or why it happened in the first place?

azinck3
2006-06-10, 22:17
I wiped out my previous Slim install on my OS X machine and installed from scratch tonight using the release 6.2.2 software.

No matter what skin I use something is seriously wrong. Intermittently frames don't show up. I can't browse my library since nothing shows up there. Very weird stuff considering the previous release (sorry don't remember what version) was working fine.

Starting up the server in debug mode, I see this in the logs:
006-06-11 00:07:04.5434 Odd number of elements in anonymous hash at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/Setup.pm line 2308.
2006-06-11 00:07:04.5440 Use of uninitialized value in anonymous hash ({}) at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Web/Setup.pm line 2308.
2006-06-11 00:07:05.5555 Using a hash as a reference is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/MusicMagic/Plugin.pm line 1262.
2006-06-11 00:07:05.5563 Using a hash as a reference is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/MusicMagic/Plugin.pm line 1277.
2006-06-11 00:07:05.9187 defined(@array) is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/ShoutcastBrowser/Plugin.pm line 138.
2006-06-11 00:07:05.9190 (Maybe you should just omit the defined()?)
2006-06-11 00:07:05.9196 defined(%hash) is deprecated at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Plugins/ShoutcastBrowser/Plugin.pm line 171.
2006-06-11 00:07:05.9198 (Maybe you should just omit the defined()?)
2006-06-11 00:07:09.7821 Use of uninitialized value in numeric eq (==) at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Player/Player.pm line 618.
2006-06-11 00:07:26.0453 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
file error - html/ajax.js: not found
2006-06-11 00:07:27.4823 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:27.7083 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
file error - crumblist: not found
2006-06-11 00:07:29.3114 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3116 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3117 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.
2006-06-11 00:07:29.3118 Use of uninitialized value in hash element at /Users/victor/Library/PreferencePanes/SlimServer.prefPane/Contents/server/Slim/Networking/Select.pm line 109.

Any suggestions as how to better diagnose this problem or why it happened in the first place?

I'm no expert but it looks like you have some old plugins that aren't updated to work with 6.2.2. When you said you installed from scratch did you remove your preferences, extra skins, and plugins? As a start you might try removing your plugins from the plugins directory to see if you have any better luck. And track down updated versions of your various plugins.

On the other hand, I may be off the mark entirely...

Victor
2006-06-10, 22:21
Yep I removed the directores manually from my ~/Library.

You're right about the plugins though -- should have read the messages more carefully. I disabled all plugins (except Date/Time) and restarted the server. It seems like the Fishbone skin is the culprit here. The key messages in the log that I see are:

file error - html/ajax.js: not found
file error - crumblist: not found

But what's wacky is that doing a "grep -R ajax.js *" from the server directory returns nothing. I can't even find where that file is being asked for. I am really confused now.

So what causes that? And why is Fishbone broken on a fresh install?

kdf
2006-06-10, 22:31
On 10-Jun-06, at 10:21 PM, Victor wrote:

>
> Yep I removed the directores manually from my ~/Library.
>
> You're right about the plugins though -- should have read the messages
> more carefully. I disabled all plugins (except Date/Time) and restarted
> the server. It seems like the Fishbone skin is the culprit here. The
> key
> messages in the log that I see are:
>
> file error - html/ajax.js: not found
> file error - crumblist: not found
>
>
> So what causes that? And why is Fishbone broken on a fresh install?
>
the ajax.js reference is something from 6.5 builds ONLY. You've got
some garbage lying around from a previous install.
-k

snarlydwarf
2006-06-10, 22:33
file error - html/ajax.js: not found
file error - crumblist: not found


Odd those didn't exist in 6.2.2. ajax.js wasn't added until April.



But what's wacky is that doing a "grep -R ajax.js *" from the server directory returns nothing. I can't even find where that file is being asked for. I am really confused now.

So what causes that? And why is Fishbone broken on a fresh install?

Because it isn't a fresh install: you had a prior version of some sort... but that doesn't make sense either since ajax.js didn't exist in 6.1 either.

Did you install 6.3 or 6.5 at some point?

It looks like something from one of them was left in place.

Victor
2006-06-10, 22:37
kdf, I think you're 100% right -- there's gunk leftover from a previous install. I am clueless as to where it might be. I thought Slim stored all of its goodies in ~/Library/PreferencePanes/SlimServer.prefPane

Is there another place I should be looking for leftovers?

Clearly this is a problem I caused myself :) Just trying to figure out how this managed to happen in the first place.

kdf
2006-06-10, 22:51
On 10-Jun-06, at 10:37 PM, Victor wrote:
>
> Is there another place I should be looking for leftovers?
>

Files potentially get stored in /Library/... and ~/Library...

-k

Victor Brilon
2006-06-10, 22:54
On Jun 11, 2006, at 12:51 AM, kdf wrote:

>
> On 10-Jun-06, at 10:37 PM, Victor wrote:
>>
>> Is there another place I should be looking for leftovers?
>>
>
> Files potentially get stored in /Library/... and ~/Library...
>

Yep. Checked both of those. I just did a 'find' though on anything
Slim related and found some Cache directories that were hidden away.
I suspect these may be causing problems. Will test ASAP and report
back :)

Victor

Victor
2006-06-10, 23:00
The Cache directory (in ~/Library) was the culprit it seems. Nuked it, reinstalled, everything seems to be working as expected.

Well Fishbone has a ton of CSS errors that Firefox chokes on and Safari doesn't display properly, but that deserves a different thread.

Thanks for the quick help in getting this diagnosed.