PDA

View Full Version : Logs



tamanaco
2006-06-09, 06:04
Can someone explain or point me to the documentation that deals with generating Slimserver logs. I looked in the wiki, but I guess I didn't look hard enough. I could not find information on how to generate, find and read Slimserver logs. I think I found all the --switches to generate logs in the comments in slimserver.pl, but I couldn't find how to use them and how to identify the specific log file generated using Windows.

Thanks...

tgoldstone
2006-06-09, 06:56
If you run slimserver.pl from the command line then you would use the switches like so; slimserver.pl --d_plugins --d_info --logfile c:\temp\mylog.txt

You can also view the log using the slimserver webpage. Server Settings --> Debugging. Select what debugging you want to see and then click the "here" in "You can view the most recent log entries here."

tamanaco
2006-06-09, 07:01
If you run slimserver.pl from the command line then you would use the switches like so; slimserver.pl --d_plugins --d_info --logfile c:\temp\mylog.txt

You can also view the log using the slimserver webpage. Server Settings --> Debugging. Select what debugging you want to see and then click the "here" in "You can view the most recent log entries here."

I see.. I tried something similar, but I was not using the --logfile switch to redirect the output to a file. No wonder I could not find it.

Thanks...

tamanaco
2006-06-09, 07:51
I tried slimserver.pl --d_plugins --d_info --logfile c:\temp\mylog.txt from the C:\program files\slimserver\server and my notepad opens up with the content of slimserver.pl. The slimserver doesn't start and there is no log generated. When you say command prompt, you mean the Windows "DOS" command prompt you don't mean a different environment command prompt... correct?

I'm using the latest 6.5b1 daily and when I used the Web interface to generate a log using a specific switch, namely selecting the --d_plugins in the server setting for debugging and clicking change, I don't get any messages related to plugins in the log. When I click the "here" I get a log.txt that has a DBI connect error related to port 9092 in the first line and a few other lines. I have since opened up port 9092 in my firewall, but I still keep getting the same error in the log.txt. When I start the server from the desktop icon, the server starts, but is not loading the WeatherTime plugin.

Any suggestions as to why I'm not able to generate or find a log with the information generated with the debugging switches? I'm probably missing something very obvious.

kdf
2006-06-09, 08:15
Quoting tamanaco <tamanaco.2953tn1149864901 (AT) no-mx (DOT) forums.slimdevices.com>:

>
> I tried slimserver.pl --d_plugins --d_info --logfile c:\temp\mylog.txt
> from the C:\program files\slimserver\server and my notepad opens up
> with the content of slimserver.pl. The slimserver doesn't start and
> there is no log generated. When you say command prompt, you mean the
> Windows "DOS" command prompt you don't mean a different environment
> command prompt... correct?
>

under window, you must use:
c:\program files\slimserver\server\slim.exe --logfile ...

instead of slimserver.pl

The .pl file will only work if you install ActivePerl to interpret the
raw .pl. Slim.exe is a packaged version with a perl interpreter and
all core modules included.
-k

tgoldstone
2006-06-09, 08:25
oops. It's been a long time since I used the Windows binaries.