PDA

View Full Version : 2 bugs



rbl
2006-05-30, 01:05
Hi - I have 2 problems with slimserver:

1) I can not clear and rescan the library. The only way is to exit slimserver, terminate slim.exe in the task manager, delete slimserversql.db, and then a rescan works. A real pain!

2) I have my original music and artwork in lossless WMA format complete with artwork. I batch process this into a new directory in FLAC format since SS seems to prefer FLAC. I therefore point "Music Folder" at the FLAC folder and the "Artwork Folder" at the WMA folder. However SS doees not pick up any of the artwork. The directory structures are identical. If I point the music folder at the WMA folder then the art is picked up properly.

Any ideas? I have reinstalled Slimserver several times, deleting the original directory altogether and installing to a newly named directory. I have tried 6.2.2, 6.5b1, and now 6.3.0 - 7668 on XP. It makes no difference although it is about the time that I installed 6.5b1 that the problems started. There are no shortcuts to confuse it.

I am happy to run debugging routines, but need to know how to pick up the log file. The only file I could find was limited to 100KB which doesn't appear to be enough.

Many thanks for any help!!!

mherger
2006-05-30, 01:41
> 1) I can not clear and rescan the library. The only way is to exit
> slimserver, terminate slim.exe in the task manager, delete
> slimserversql.db, and then a rescan works. A real pain!

Do you get an error message? Why do you think it's not doing its job?
(sounds stupid, but there must be something telling you it's not working)

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
SlimString Translation Helper (http://www.herger.net/slim/)

rbl
2006-05-30, 01:50
What happens is it goes off and scans away for a long time. But it never clears the library in the first place, so I end up with everything duplicated. If I start the clear and rescan and then quickly look under Artists, then the entire library is still there. There are no error messages displayed on the web page.