PDA

View Full Version : 5.0 upgrade problem: can't access web server!



fcm4711
2003-11-20, 10:00
Hi there

What skins are you trying? I had it running with
the Standard skin on two browsers and two players
for over 3h with no problem.

As soon as I changed the skin to Fishbone the
Squeeze would stop playing and the browser gets
stuck.

The skin switch produced the following output:

2003-11-20 17:55:17 Couldn't open:
html/images/nav_7.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_8.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_9.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_10.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_11.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_repeat.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_one.gif
2003-11-20 17:55:17 Couldn't open:
html/images/nav_all_sel.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_off.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_shuffle.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_off_sel.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_songs.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_albums.gif
2003-11-20 17:55:18 Couldn't open:
html/images/nav_nowplaying.gif
2003-11-20 17:55:18 Couldn't open:
html/images/b_delete_white.gif

Also, for what it's worth, I get a lot of
this messages:

getpeername() on closed socket Symbol::GEN7692 at
/System/Library/Perl/darwin/IO/Socket.pm line 200.

Felix


--- Sean Adams <sadams (AT) slimdevices (DOT) com> wrote:
>
> Neither Dean nor I have been able to reproduce this
> problem yet... need
> some help here folks.
>
> I'm running the server at the office on Windows, and
> at home on Linux.
> Dean does all his development and testing on OSX
> 10.3.
> I'm also running the 5.0.0 server here on OSX 10.2.8
> (g4 tower).
>
> On none of these systems can I get the slow web
> interface bug to
> happen. Tried with no clients connected, with one
> slimp3, two slimp3s,
> a squeezebox, two slimp3s and a squeezebox... no
> dice.
>
> If someone can reproduce this reliably and would
> like to help out,
> please contact me or dean. If you're willing to let
> one of us log in
> remotely to troubleshoot on your machine, that would
> be immensely
> helpful.
>
>

Kevin Deane-Freeman
2003-11-20, 10:12
Quoting Felix Mueller <fcm4711 (AT) yahoo (DOT) com>:

> Hi there
>
> What skins are you trying? I had it running with
> the Standard skin on two browsers and two players
> for over 3h with no problem.
>
> As soon as I changed the skin to Fishbone the
> Squeeze would stop playing and the browser gets
> stuck.
>
> The skin switch produced the following output:
>
> 2003-11-20 17:55:17 Couldn't open:
> html/images/nav_7.gif
> 2003-11-20 17:55:17 Couldn't open:

jeez, I'm stumped. none of those images are used in the Fishbone skin. Custom
images are in html/ with only two standard images used from html/images. Those
would be the logo and spacer.gif. There is a bit more processing going in in the
Fishbone skin versus the default, but it shouldn't really be a noticeable
change. I had expected only maybe an extra percent on the CPU usage.

Felix, I assume you are fluent in html, so maybe try removing the progress bar
code from status_header.html and see if that changes anything as far as usage.
The image problem would seem to be a whole other issue that is beyond me.

cheers,
kdf