View Full Version : Service won't start with 6.2.0+

2006-05-15, 20:15
I've tried unsuccessfully to upgrade SlimServer to releases higher than 6.1.1. I've uninstalled, reinstalled, even manually cleaned out the registry. Nothing helps. The service starts for a second or two and then stops. The event logs show "Perl interpreter failed". I've just tried several nightlys right up to May 15ths and that failed like the rest of them.

PIII 700
Windows 2000 server SP4+

2006-05-15, 23:47

2006-05-16, 05:39
Those links contained nothing relevant to my problem that I could see. In those cases reverting to version 6.2.1 from 6.2.2 solved their problems. I cannot get 6.3.x or 6.2.2 or 6.2.1 or 6.2.0 to run at all. As far as plugins go, whatever is installed with SlimServer is what's installed. I haven't downloaded or installed anything other than SlimServer. On several attempts, after uninstalling SlimServer, I've deleted the SlimServer folder which would have solved any plugin or pref.conf file problems like those that were mentioned in the links. Also, my event log error message was not posted in any of those links.

2006-05-16, 07:37
Have you tried running slim.exe from the command prompt with a debuggig switch such as d_server enabled ? It may give more information about how far slimserver gets before it halts.

2006-05-16, 07:46
I've solved this problem after scouring the forums. The SlimServer service seems to crash after encountering a large amount of bad playlist files. Several others have reported this problem as well. To solve it I opened up types.conf in the SlimServer\server folder. I commented out lines for M3U and CUE, as I have both of these stored along with each ripped CD, and this allowed the server to scan my music folders without a problem. Ideally SS would just log these bad files, so they can be repaired later, and move on. Unfortunately, I think SS stores playlists using M3U files. Will commenting M3Us out of types.conf cause problems with SSs regular functions?