PDA

View Full Version : Shoutcast Plugin and SimpleAsyncHTTP



mlmurray
2006-05-13, 09:09
I'm having problem's with Shoutcast again for the last 3 nightlies I've tried.

When selecting Shoutcast from the web interface, I get an "unable to connect, try again" message. I enabled -d_http_async and -d_plugins and this is what the log file shows:


Can't call method "header" on unblessed reference at /usr/share/perl5/Slim/Networking/SimpleAsyncHTTP.pm line 188.
2006-05-13 11:37:46.3652 Formats::XML: async request: http://content.us.squeezenetwork.com:8080/shoutcast/index.opml
2006-05-13 11:37:46.3655 SimpleAsyncHTTP: GETing http://content.us.squeezenetwork.com:8080/shoutcast/index.opml
2006-05-13 11:37:46.3665 AsyncHTTP: Starting async DNS lookup for [content.us.squeezenetwork.com] [timeout 20]
2006-05-13 11:37:46.4220 AsyncHTTP: Resolved content.us.squeezenetwork.com to [64.71.155.211]
2006-05-13 11:37:46.4222 AsyncHTTP: Connecting to content.us.squeezenetwork.com:8080
2006-05-13 11:37:46.5042 AsyncHTTP: connected, ready to write request
Can't call method "header" on unblessed reference at /usr/share/perl5/Slim/Networking/SimpleAsyncHTTP.pm line 188.
2006-05-13 11:37:46.5045 SimpleAsyncHTTP(http://content.us.squeezenetwork.com:8080/shoutcast/index.opml) destroy called.
2006-05-13 11:37:46.7158 Shutting down plugins...
2006-05-13 11:37:46.7183 Scrobbler: Unsubscribing on 'play', 'pause', 'stop', 'power', 'mode'
2006-05-13 11:37:46.7185 Scrobbler: Unsubscribing on 'open'
2006-05-13 11:37:46.7186 Scrobbler: unHookScrobbler() engaged, SlimScrobbler V0.35 deactivated.


Could this be that the shoutcast plugin hasn't caught up with the recent changes to the SimpleAsyncHTTP code that was discussed previously (and that is way over my head)?

Any suggestions?

Thanks!

andyg
2006-05-13, 09:11
On May 13, 2006, at 12:09 PM, mlmurray wrote:

>
> I'm having problem's with Shoutcast again for the last 3 nightlies
> I've
> tried.
>
> When selecting Shoutcast from the web interface, I get an "unable to
> connect, try again" message. I enabled -d_http_async and -d_plugins
> and this is what the log file shows:

Wipe your FileCache directory.

mlmurray
2006-05-13, 09:25
I've said it before, but I'll say it again: You guys rock!

Thanks, Andy! That was all it needed. Everything is working great again!

Mark