PDA

View Full Version : Play AACplus



Ramage
2006-05-04, 00:28
I've had SB3 for a week or two and getting along fine - great kit. I have been trying to play internet radio AAC+ streams, with no success. The URLs are OK as I am getting the now playing info. Typically I am using AAC streams from SKY.FM. SB3 plays HE-AAC MP4 files from my PC OK. Anyone know the answer to this - grateful for any help

funkstar
2006-05-04, 02:48
Are you trying to play these streams when connected to the SqueezeNetwork or when connected to your own Slimserver?

SqueezeNotwork conneted players will only support streams in one of the native formats, MP3 and WMA (technically FLAC and WAV streams are possible, but not exactly practical)

Ramage
2006-05-04, 03:09
Thanks Funkstar. I am using slim server and using the tune radio function to enter the url.

K

bpa
2006-05-04, 03:15
What OS are you running ? AFAIK on Linux FAAD2 is used to transocde and on Windows/Mac Quicktime libraries are used to transcode AAC files which are probably identified by extension m4a.

AACplus streams would need to be identified and then transcoded. AFAIK Slimserver identifies a stream format type by a combination of things
- protocol (e.g. http, mms, rtsp)
- extension (e.g. pls, mp3, asx, wma)
- MIME content type identifier

The file types.conf has the standard values for identifying streams.

AACP plus streams typically have http protocol and pls extension but with a MIME content type of "audio/aacp" so are not identified and treated as default - MP3 I think.

Mplayer or FAAD2 could be confgured to play these streams. I think just a table entry change is not enough - perhaps a new "protocol" needs to be defined.

Ramage
2006-05-04, 03:26
What OS are you running ? AFAIK on Linux FAAD2 is used to transocde and on Windows/Mac Quicktime libraries are used to transcode AAC files which are probably identified by extension m4a.

AACplus streams would need to be identified and then transcoded. AFAIK Slimserver identifies a stream format type by a combination of things
- protocol (e.g. http, mms, rtsp)
- extension (e.g. pls, mp3, asx, wma)
- MIME content type identifier

The file types.conf has the standard values for identifying streams.

AACP plus streams typically have http protocol and pls extension but with a MIME content type of "audio/aacp" so are not identified and treated as default - MP3 I think.

Mplayer or FAAD2 could be confgured to play these streams. I think just a table entry change is not enough - perhaps a new "protocol" needs to be defined.

Thanks bpa, I'll investigate further. I have used the urls in a pls with no success, but I am able to play AAC+ (HE-AAC) mp4 files resident on the PC. I am running XP SP2 and have LAME and Mplayer installed together with AlienBBC. I normally play these streams on Winamp and copy the urls across to Slim Server. Although "now Playing" info shows up there is no sound played.

Tks

bpa
2006-05-04, 03:37
Try adding the following line to the custom-type.conf file (in the Alien directory if running 6.5)


aap ? audio/aacp audio

And then add something like the following to the slimserver-convert.conf file - you'll need to make a change for XP as below is for Linux. You'll see the pattern from the earlier lines in the file.



#
# AACPlus for mplayer pre7 or later
aap wav * *
[mplayer.sh] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$
aap mp3 * *
[mplayer.sh] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
aap flc * *
[mplayer.sh] -really-quiet -vc null -vo null -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -


Then try the real URL for the stream after all the playlist have been parsed.

Ramage
2006-05-04, 04:08
Thanks bpa, I'll give that a try tonight.

Regards

Ramage
2006-05-04, 11:10
For bpa. Tried the mods you suggested but with no success. The 3 lines in slimserver-convert.conf worked and 3 new file formats appeared in the server list - but no sound.

Any other suggestions gratefully received

Thanks

bpa
2006-05-04, 11:26
What URL did you use ?
I played around with this idea a while back, it didn't work but it was close - It's why I think a "protocol" handler is needed.

Ramage
2006-05-05, 00:14
For bpa - thanks for your interest and help, I also though something was missing.

I used a number of urls for SKY.FM streams all of which work on Winamp and on my PDA using TCPMP. My feeling was that Mplayer was not able to do the conversion from AAC+ to MP3 and that some other software was needed. I have NERO7 which has HE-AAC as its preferred conversion, Winamp also does the conversion - perhaps there is an avenue of exploration there.

As a newby I am not familiar enough with Slimserver to get very far.

Regards

bpa
2006-05-05, 00:53
Mplayer handles the AACPlus perfectly well - I have tested Sky URLs from the command line. The problem is that Slimserver gets its hands on the URL first and opens it and passes stdin to Mplayer which Mplayer doesn't like. A protocol handler is needed so that urls are identified easily and passed to mplayer unopened.

My present approach is as follows. Instead of http://128.177.3.80:4028 for the SKy Classical AACP plus service, I want to enter aacp://128.177.3.80:4028 and so pass the url straight to Mplayer but I need to change it back to http://128.177.3.80:4028 for Mplayer to handle it.

This requires some Perl in an area I haven't played before, my attempts aren't working and I don't have time at the moment to get it right.

Ramage
2006-05-05, 01:08
Good news about Mplayer ability. What about the Convert.conf (I think its called) file in slimserver, that seems to be about protocol identification. I don't know what it does, perhaps there is someone out there who can contribute to the debate.

bpa
2006-05-05, 01:39
Convert.conf is for the standard Slimserver conversions - the custom ones are provided in Alien and others. AFAIK The standard Slimserver support apps e.g. MOV123 can't handle AACPlus so you need to use a custom conversion.

To identify a stream - the stream must be opened and the ICY header read which gives the MIME content as AACplus - unfortunately Slimserver then passes the stream opened to Mplayer as stdin which Mplayer can't handle so the original URL must be passed to mplayer - FAAD2 might be able stdin but I don't want to start a new line of enquiry.

Ramage
2006-05-05, 02:23
Thanks for that bpa - useful info. I certainly don't have the knowledge to proceed on this so I am hoping someone from Slim Devices may wish to contribute.

I may transfer this thread to a different area on the BB.

In the meantime I will stream the AAC over Winamp server to SB3 unless someone can come up with a solution.

Best Regards
RMG

bpa
2006-05-11, 00:44
Good news & Bad news

Good news: The following are some setting for an AlienBBC installation which will play AACplus streams (e.g. http://www.somafm.com/groovesalad48.pls, http://www.sky.fm/aacplus/smoothjazz.pls) and you get the song titles on screen.
Bad news: It is not reliable and doesn't start up all the time especially after changing statin - I think it is a problem with Mplayer losing sync.

Any ideas on what could be the problem ?

1. As before add the "audio/aacp" with type "aap" to custom-types.conf

2. Fror Windows the mplayer line in the custom-convert.conf file for aap is as follows - key additions are the "-ac faad -demuxer aac", "-bandwidth" can be dropped.
mplayer -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 128 -ao pcm:nowaveheader:file=/dev/fd/3

For Linux I created a separate shell filed call aacplay.sh (mplayer.sh edited). The "aacplay.sh" replaces the "mplayer.sh" on the aap lines in slimserver-convert.conf file with above params. It is as follows for SuSe 9.3. The odd thing about this file is the line ") &" which was initially a typo but I find that playback is more reliable when it is in place. Again any ideas ?

Mplayer needs input from stdin otherwise it will close and seek omn the input and exit. So defining input to be /dev/fd/6 just doesn't work.


#!/bin/sh
scriptpid=$$
apppid=/tmp/.alienbbc-app.$$.pid
app=mplayer

if [ -x /usr/local/bin/$app ] ; then
app=/usr/local/bin/$app
fi
exec 6<&0

if [ -e "${10}" ] ; then
echo Local File: Launching $app $1 $2 $3 $4 $5 $6 $7 $8 $9 "${10}" ${11} "${12}" "${13}" >&2
$app $1 $2 $3 $4 $5 $6 $7 $8 $9 "${10}" ${11} "${12}" "${13}" 3>&1 1>&2
exit
fi

echo Streaming: Launching $app $* >&2
(
$app $* 3>&1 1>&2 &
echo $! > $apppid
wait
rm -f $apppid
kill $scriptpid 2> /dev/null
) < /dev/fd/6 &
) &
cat > /dev/null
if [ -s $apppid ] ; then
kill `cat $apppid` 2> /dev/null
fi

Ramage
2006-05-11, 04:37
Thanks bpa I'll try that mod and see where we go. I may be able to live with the bad news element.

As an aside I have been trying to make the Winamp Control plugin work - to no avail. Can't get it to register as a plug-in. It uses httpQ winamp CLI plugin. The code was written for SliMP3 and I suspect it will not run without modification on 6.2.2. I have another posting under plugins, plenty of readers, no answers.

Any thoughts?

bpa
2006-05-11, 05:11
I've tracked down the Windows problem - mplayer will not work with named pipes as input. Unfortunately this is what slimserver provides.

At least I now understand the problem - simplest solution is modify FAAD2 to accept stream input rather than a file. FFMPEG may work but standard builds don't include AACplus support so I'll see if I can mod FAAD2 first.

Ramage
2006-05-11, 06:07
I've tracked down the Windows problem - mplayer will not work with named pipes as input. Unfortunately this is what slimserver provides.

At least I now understand the problem - simplest solution is modify FAAD2 to accept stream input rather than a file. FFMPEG may work but standard builds don't include AACplus support so I'll see if I can mod FAAD2 first.

Interested to see how you get on with the mod - looks like you are making progress.

Ramage
2006-05-12, 00:42
Mixed success using faad2 changes as suggested by bpa. I was able to decode some AAC+ streams but not others. Most notable no streams from sky.fm. Success with AAC from Rooster.com and some from the aacplus music site www.tuner2.com

I was using the raw http ip address for the stations.

Could the problem be that some streams are aacplus v1 and others v2? I will do some more work to try and analyse the pattern of success and failure.

Triode
2006-05-12, 11:16
I've tracked down the Windows problem - mplayer will not work with named pipes as input. Unfortunately this is what slimserver provides.

Bryan - not kept track of the rest of this, but named pipes are only created by socketwrapper if the #PIPE# directive is given. Socketwrapper was orginally designed to use standard in / out.

bpa
2006-05-12, 12:33
It's not the #PIPE# (which is the output) that is the problem but $FILE$ which is the input to mplayer.

Mplayer will only recognize stdin if the input filename is "-" whereupon it uses fd 0.

Ramage
2006-05-13, 08:24
Mixed success using faad2 changes as suggested by bpa. I was able to decode some AAC+ streams but not others. Most notable no streams from sky.fm. Success with AAC from Rooster.com and some from the aacplus music site www.tuner2.com

I was using the raw http ip address for the stations.

Could the problem be that some streams are aacplus v1 and others v2? I will do some more work to try and analyse the pattern of success and failure.

Today none of the AACplus stations will play - I get loud squawks but no coherent audio. I downloaded the latest AlienBBC last night, which may have changed some other parameters. Any thoughts?

bpa
2006-05-13, 08:41
I tried a number of sky stations with mplayer and they played OK - mplayer uses faad2 library so when I make the mods to faad2, I am hopeful of success.

Mplayer and faad2 re-opens the stream supplied by slimserver so sometimes it will get back in sync but not always. T

Triode
2006-05-13, 09:03
Bryan - do you want some help with a protocol hander for this to avoid reopening the stream?

bpa
2006-05-13, 09:29
No thanks,
I hacked up a protocol handler based on the RTSP one where the user has to change the AACplus URL to accp instead of http. It worked but it means users cannot use .pls links as provided by sky and soma so it wouldn't be easy to use.

I think the solution is to mod faad2. The changes are not hard. All in all - I was treating this as a bit of a conundrum (i.e. make it work without code) and educational - I've got the linux side working with mplayer but not Windows.

Triode
2006-05-13, 09:56
Try using $URL$ rather than $FILE$ in the convert command.

If you use the standard http protocol handler, I think this will mean the server passes you the real url rather than '-' (as well as the stream on stdin). Does this mean mplayer can open the stream normally?

mplayer.sh monitors stdin by copying it to /dev/null so this probably means fetching the stream twice... I'm not sure this could be avoided with the current code.

bpa
2006-05-13, 10:31
I'll try the $URL$. I though if I used the URL I would lose the metadata which gives which song is playing.

Regarding mplayer.sh - I modified it for the aacplus case as a new shell script. At the start I redirect stdin to fd 6 and then changed the </dev/null to </dev/fd/6. $FILE$ is "-" in the mplayer command line and so mplayer reads stdin input via /dev/fd/6.

Ramage
2006-05-16, 01:51
Achieved the following results using the Mplayer CLI:

Some AAC+ streams play OK with Mplayer using very little PC processor time.

Sky FM streams would play for about a second then recycle and repeat continuously.

some AAC+ streams (not Sky.fm) start to play on SB3 but stop after about 30 secs - MPlayer running at 100% processor time. (1.6G P4). Sometimes the same streams would run perfectly with Mplayer taking a low value of processor time.

In these trials I am using the full url and not just the IP address.

The consistent inconsistencies are puzzling - any views?

bpa
2006-05-16, 02:38
Using latest CVS mplayer from Linux shell command line I can play 2 sky FM ordinary (not premium) stream OK (classical & guitar) and then play for a few minutes - I stopped the streams.

On Windows, with the AlienBBC version of Mplayer I got the same result as you did.

On Linux with a 10-Dec-05 version of Mplayer, I got the same problem as on Windows.

Basically, some bugs have been fixed ( I think handling some AAC+ features used by Sky fm) between Jan06 and now so a new version of Mplayer is needed for Windows.

bpa
2006-05-17, 14:59
Good news - a build of Mplayer after 24-Apr-06 fixes the problems. on Windows. So I think I now have a configuration setup which works for Linux(SuSe) and Windows based on AlienBBC (i.e. maplyer).

Tomorrow, I'll post a set of instruction on how to add AACplus support onto an AlienBBC installation. I'll also upload a newer version of mplayer for Windows.

By using streaming input, the metadata (i.e. whats playing) is processed and is displayed on the SB display.

bklaas
2006-05-17, 15:02
Would you consider doing your write up on the wiki (http://wiki.slimdevices.com/)? Wiki pages are *way* easier to find/point to than a forum thread posting...

Also, very cool, bpa. I've been lurking on this thread for quite a while, and I'm happy you're getting some success with aac+. I've been wanting to listen to this station's aac+ for quite some time.
http://minnesota.publicradio.org/radio/services/the_current/

cheers,
#!/ben

bpa
2006-05-17, 15:18
The wait was too long - according to this text, I think they have dropped their AACplus stream.

http://minnesota.publicradio.org/about/site/help/aacplus.php#aacplus

bklaas
2006-05-17, 15:22
aww, rats. In the one place I was able to get the aac+ to work on my linux system (VLC), the stream sounded fantastic (until I upgraded VLC, but that's another story).

At least I know that I can listen to a decent quality stream of The Current on my squeezeboxen now that they have adopted a 128K MP3 stream. Probably what they should have done from the beginning...

still think it's cool that you got the aac+ streaming...

#!/ben

Ramage
2006-05-18, 05:38
Good news - a build of Mplayer after 24-Apr-06 fixes the problems. on Windows. So I think I now have a configuration setup which works for Linux(SuSe) and Windows based on AlienBBC (i.e. maplyer).

Tomorrow, I'll post a set of instruction on how to add AACplus support onto an AlienBBC installation. I'll also upload a newer version of mplayer for Windows.

By using streaming input, the metadata (i.e. whats playing) is processed and is displayed on the SB display.

Been away for a few days and see that you've cracked the AAC+ problem. I look forward to seeing your mod of AlienBBC.

Great work

Regards

Ramage

Ramage
2006-05-26, 02:39
I have searched for a later version of Mplayer for windows mentioned by bpa with no success, anyone point me at the source?

bpa
2006-05-26, 06:25
I should have given a status update but I thought I would solve the latest bug quickly.

usually suitable unofficial builds of mplayer for windows can be found here http://oss.netfarm.it/mplayer-win32.php . However the fix for AACplus is later than these builds so I tried build a Windows mplayer myself.

I had some initial difficulties but now I have an mplayer build which plays aacplus stations fine when used standalone but when used with Slimserver it has bug. This bug seems to be specific to Win32(MinGW32) and only when used in the slimserver context (i.e. streaming input & output) . I have had problems in a Linux/Slimserver config so I think the issues is related Win32 build differences.

I'll post when I have an answer.

Ramage
2006-05-26, 07:33
Thanks bps for the info. I will have a look at that site and have a play.

Good luck with the bugs

Ramage
2006-05-26, 08:04
Bug #1839 covers this development, vote for this feature at http://bugs.slimdevices.com/

norderney
2006-05-30, 15:43
So in summary there is currently no way of playing aacplus through Squeeze Box with SlimServer running on a Windows XP platform?

I am trying to play the audio from www.palmfm.co.uk.

I am currently running SlimServer 6.2.2.

bpa
2006-05-30, 16:13
At present I can play AACplus streams reliably on a Linux platform through Mplayer.

However on Windows there is a bug which corrupts the datastream in some way - this bug uncovered some other bugs in Mplayer and I have been working my way through them.

I have a Windows build of mplayer which will play an AACplus stream continuously but will give clicks when the datastream is corrupted - the latest CVS version of mplayer gets stuck in a loop.

I am still looking for the Windows bug which corrupts the datastream and so have a proper AACplus solution but I can't say when for sure.

bpa
2006-06-07, 13:57
I finally sorted the problems - however it requires Slimserver 6.3 or 6.5 and the latest mplayer. I'll add these instructions to the Wiki.

The following gives instructions on how to enable playing Shoutcast/Winamp AACPlus streams within slimserver. It does not handle the Windows Media Play/AACPlus streams.

Pre-requisites:
(i) Latest build of Mplayer. For Windows users I have a prebuilt Mplayer which includes an
additional patch not yet accepted into official repository. Linux users should be able to use latest Mplayer but ideally should upgrade once patch is accepted [edit 10-June - the patch was accepted and is in mplayer repository].
(ii) Slimserver 6.3 or 6.5 as there is a bug in 6.2.x. Slimserver 6.2.x users on Linux can do the 2 line patch to the slimserver file if desired without upgrading.

1. Install Mplayer or replace your current version of Mplayer by the latest version of Mplayer (if you are replacing a version of Mplayer - save the current file in case you need to revert)..
For Linux - a version of Mplayer using latest CVS is needed. Install location is system dependent.
For windows - Install a new version of Mplayer in the BIN/MSWin32-x86-multi-thread directory which has .exe files like socketwrapper.exe. A prebuilt version of mplayer is available here (download & unzip). http://homepage.eircom.net/~altondsl/slim/mplayer07June06.zip . Download and unzip.
2. Test Mplayer by running one of the following command for example. Let it run for a few minutes - if the version of mplayer is not up to date problems will show.
mplayer -playlist http://www.somafm.com/groovesalad48.pls.
mplayer -playlist http://www.sky.fm/aacplus/classical.pls
3. There are additions needed to the types.conf and convert.conf files.
The changes depend on whether you are running Windows or Linux.
3a. For Linux - modify the following files that are in the slimserver directory
Add the following lines to convert.conf file


aap wav * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null
aap mp3 * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
aap flc * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -

Add the following line to the types.conf file


aap - audio/aacp,audio/aac audio


3b. For Windows - using a suitable editor (e.g Wordpad) modify the following files that are in the slimserver server directory
Add the following lines to convert.conf file


aap wav * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$
aap mp3 * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b $BITRATE$ - -
aap flc * *
[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=#PIPE# $FILE$ | [flac] -cs --totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -

Add the following line to the types.conf file


aap - audio/aacp,audio/aac audio

4. The step is not essential but without you will get an error message and blank fields in the Server / Filetypes as a new file type AAP has been added.
Edit the file strings.txt in the slimserver directory (server directory for Windows) and add the following 2 "AAP" lines to the file probably somewhere near other extensions such APE - keep the tabs on the "EN" line. The


AAP
EN AACplus

5. Stop and restart Slimserver. Look at the server / Filetypes and check if there are 3 lines of AACPlus entries or 3 lines with blank as the format if you did not edit strings.txt file.

6. Test some AACplus streams using Tune in - such as
Soma Groovesalad http://www.somafm.com/groovesalad48.pls
Sky FM Classical Guitar http://www.sky.fm/aacplus/guitar.pls
Virgin http://aacplus-vr-32.smgradio.com:80
StreamingSoundtracks http://www.streamingsoundtracks.com/aacPlus-hi.pls

mherger
2006-06-08, 09:54
> Edit the file strings.txt in the slimserver directory (server directory
> for Windows) and add the following 2 "AAP" lines to the file probably
> somewhere near other extensions such APE - keep the tabs on the "EN"
> line. The
> Code:
> --------------------
> AAP
> EN AACplus
> --------------------

Better save these few lines in a new file called custom-strings.txt - or
your changes will be lost with the next update.


--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

bpa
2006-06-08, 10:02
I didn't know about custom-strings.txt.

For Debian users of 6.5, the various conf files may not be in the directories I suggested for Linux users.

norderney
2006-06-09, 13:56
Is SlimServer version 6.5 stable and ok to use yet?

Ramage
2006-06-10, 13:08
Followed bpa's instructions worked first time on windows version, will try the linux later. This has added real value to SS and maybe should be included in future builds.

Great work

bpa
2006-06-10, 13:41
I need to check but for 6.5 I think there may be support for custom types, custom convert and custom strings files so that support could be as simple as copying 3 files & install mplayer as long as the user does not already have custom files.

My Mplayer patch has been accepted which is good news as Mplayer are preparing a pre8 code release. Pre-compiled builds for various platforms are only built using a code release so once pre8 is released, mplayer compiled binaries suitable for Aacplus will become available and this will simplify Mplayer install for non technical users.

norderney
2006-06-17, 01:43
How do I install version 6.3? I have checked out http://www.slimdevices.com/downloads/nightly/latest/6.3.0/

Is the link for "SlimServer_6_3_x_v2006-06-17.tar.gz" the windows version? Do I just download this file and unzip it into program files? I assume I would have to uninstall my existing 6.2.2 version first?

Thanks.

Andrew Smith

bpa
2006-06-17, 02:00
The windows version is a sort of compiled Perl and has Windows installer. It is the only .exe file found here
http://www.slimdevices.com/downloads/nightly/latest/6.3.0

Last night's Windows 6.3 is
http://www.slimdevices.com/downloads/nightly/latest/6.3.0/SlimServer_6_3_x_v2006-06-17.exe

AFAIK You are not required to uninstall 6.2.2 to upgrade.

An official built Windows mplayer pre8 release can be found at the mplayer site - one mirror is
http://www4.mplayerhq.hu/MPlayer/releases/win32/MPlayer-mingw32-1.0pre8.zip

norderney
2006-06-17, 02:43
I am having problems upgrading to version 6.3 with mplayer to handle aacplus audio.

I have upgraded to verssion 6.3 and installed mplayer to bin/mswin32-x86-multi-thread....

As I am running with windows xp, I then edited convert.conf and added the required lines by copying and pasting. I added then after mov flc * *
[mov123] $FILE$ |

Then I went into types.conf and added the line you suggested in that file. I could not find the strings.txt file in the slimserver directory, but found strings.txt slimserver server directory.

PROBLEMS:

1. When I go into Server Settings and select any option it says The page cannot be displayed

2. Also after installing version 6.3 it rescanned my music files and now says :
303 albums | 771 songs | 279 artists
Yesterday I had about 18500 songs on version 6.2.2 !!!!

What's gone wrong!!!!!

Thanks
Andrew Smith

norderney
2006-06-17, 02:57
Further to my previous post, it appears to have only scanned in compilation albums which I have in a folder called Various Artists. Although I have found a few albums which arre single artist albums which were in a folder named as the artist.

Also, if I try and play a track/album that is listed I just get the message:
The page cannot be displayed. The link at this point is- http://localhost:9000/status.html?command=playlist&subcommand=loadtracks&album=204&player=00%3A04%3A20%3A05%3A5a%3A0e

Any ideas?

Andrew Smith

bpa
2006-06-17, 03:28
From experience, I found it better after an upgrade to test the new system to ensure it is working properly before making changes.
I doubt that any of the AACplus changes would have the effect that you describe so I would look at 6.3 first. There has been a few threads about 6.3 problmes and compilation albums.

I suggest do an uninstall and a clean install of 6.3 and then do a full rescan. If 6.3 still gives you problem then start a new thread as users won't read an AACplus thread to solve 6.3 problems.

You should save the files you changed: types.conf, convert.conf and strings.txt files and copy them back once you are sure 6.3 is working to save editing and also to prove whether they caused the problem or not.

The strings.txt file is in the server directory on Windows - I'll correct the instructions.

Ramage
2006-06-27, 11:42
I have done a new clean install with ClarkConnect on an old P2 box using SlimServer Version: 6.3.0 - 8147 - Linux - EN - utf8, Alien BBC, latest MPlayer and Lame. All work OK but, when I configured for AACPlus, there is no audio output. Title strings show OK.

I,m pretty sure I have done all the mods to the files OK. I tested Mplayer, but I dont have audio suystem on the P2 box. The output from Mplayer was as follows for an AAC stream. Can any one tell me whether it is OK?

MPlayer dev-SVN-r18838-3.4.4 (C) 2000-2006 MPlayer Team
CPU: Intel Pentium II Klamath/Pentium II OverDrive (Family: 6, Model: 3, Stepping: 4)
CPUflags: MMX: 1 MMX2: 0 3DNow: 0 3DNow2: 0 SSE: 0 SSE2: 0
Compiled for x86 CPU with extensions: MMX

STREAM_HTTP(1), URL: http://www.sky.fm/aacplus/guitar.pls
Resolving www.sky.fm for AF_INET6...
Couldn't resolve name for AF_INET6: www.sky.fm
Resolving www.sky.fm for AF_INET...
Connecting to server www.sky.fm[160.79.128.8]: 80...
Cache size set to 128 KBytes
Unknown entry type Version=2

Playing http://160.79.128.40:7062.
STREAM_HTTP(1), URL: http://160.79.128.40:7062
Resolving 160.79.128.40 for AF_INET6...
Couldn't resolve name for AF_INET6: 160.79.128.40
Connecting to server 160.79.128.40[160.79.128.40]: 7062...
Name : S K Y . F M - Classical & Flamenco Guitar - a mix of classical, spanish, and flamenco guitar
Genre : Flamenco Classical Guitar
Website: http://www.sky.fm
Public : yes
Bitrate: 24kbit/s
Cache size set to 128 KBytes
Cache fill: 0.00% (0 bytes)
ICY Info: StreamTitle='Jesse Cook - Fragile';StreamUrl='';

AAC file format detected.
================================================== ========================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 44100 Hz, 2 ch, s16le, 128.0 kbit/9.07% (ratio: 16000->176400)
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
================================================== ========================
[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such device
AO: [null] 44100Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 56.7 (56.7) of 0.0 (unknown) 24.0% 42%
Exiting... (Quit)

bpa
2006-06-27, 11:53
There nay be two problem but first needs to test Mplayer.

What command line did you use to run Mplayer ?

Try the following - it will give more diagnostic output.


mplayer -v -v -vo null -ao pcm:nowaveheader:file=testoutput.wav -playlist http://www.sky.fm/aacplus/guitar.pls

Ramage
2006-06-28, 00:28
I'll give that a go this evening bpa, thanks.

bpa
2006-06-28, 00:58
I don't think there is a need to test Mplayer - I noticed the following line



[AO OSS] audio_setup: Can't open audio device /dev/dsp: No such device

This means there was no audio out device which is what you said. My Mplayer test will save audio out to a file in WAV format. This test Mplayer running. It will also generate lots of messages per packet of audio (the 2nd "-v" does this). You can run the test but I think Mplayer is ok.

To see why no audio from slimserver - do a log with d_source when selecting a BBC station. Preferably from a command line so that mplayer.sh output is also logged.

Ramage
2006-06-28, 05:03
For bpa

BBC stations play OK, it is only AAC+ that I have a problem with. I'll run the MPlayer test into the wav file and replay on my WinXP box to make sure.

I'll do the d_source check for mplayer.sh output and perhaps compare for BBC stations and AAC+.

One other minor issue is that the "AACplus" text does not appear in Filetypes but the check boxes do. I have added the appropriate text to strings.txt and custom-strings.txt and restarted SS.

As an aside, I find the MyPicks plugin excellent and just what I needed to organise my radio sations previously stored in playlists.

bpa
2006-06-28, 05:16
1. Regarding the blank filetypes - The formatting is critical. Ensure that "AAP" on first line starts in col 1. Ensure that the 2nd line has a tab (ascii 9) before and after the "EN" - some editors replace tabs with spaces !.

2. Check that AAP is in the types.conf file.

3. Restart SS

If still doesn't work - do the d_source log with the AACplus station.

Ramage
2006-06-28, 06:04
I'm using 'nano' to edit the files, and I am not sure whether it does something when wrapping the text - I would hope not. Is there any case sensitivity as types.conf and the other files are lower aac and strings.txt upper AAC?

I know this is not a problem on Windows as it works fine.

I will have another look at the text in all the modified files and maybe edit on WinXP to make sure I know what is happening.

bpa
2006-06-28, 06:32
Case shouldn't matter - I did my testing on a Linux 6.3/6.5 systems.

Don't know about nano but try moving the cursor across the line - if it jumps then there are tabs. Inconclusive if it doesn't. Usually the "replace tabs with spaces" feature is a user configurable setting.

There are some differences between the Windows and Linux "convert" files so they can't be interchanged.

Ramage
2006-06-28, 10:00
For bpa

I have checked the file changes and seems OK. The Filetypes problem was finger trouble now corrected.

The problem is worse than I thought, I can't play wma albums either. The album is selected into a player list which then runs through every track in a few seconds with no output into SB3.

I think I had this problem when I went with SS 6.3.0 earlier in the month, and I decided to revert.

Is there a bug?, I noticed someone else reported the wma prob in another thread this morn.

I may download the 6.3.x release and try again but I'm not hopeful.

The benefit of your considerable knowledge is greatly appreciated

bpa
2006-06-28, 10:08
WMA on Linux is usually implemented using AlienBBC for SB1 and SoftSqueeze.

I'm wondering whether you installed the Windows zip for AlienBBC and not the Linux version ?

If a playlist is set up (i.e. select an album) and SlimServer cannot play a track, it will move onto the next one. If WMA is not working and all the tracks are WMA, then SS will move through them v. quickly.

A d_source log will provide info on SS decision process regarding handling a file/stream type.

Ramage
2006-06-28, 11:26
Restarted SS with d_source on and found parsing error on custom-strings.txt. Deleted the file and restarted - wma now works OK. However AAC will still not run.

This is the output of the d_source log:

2006-06-28 19:22:28.5089 undermax = 1, type = aap, squeezebox2 = 00:04:20:06:63:22, lame = /usr/bin/lame
2006-06-28 19:22:28.5114 checking formats for: aap-wma-squeezebox2-00:04:20:06:63:22
2006-06-28 19:22:28.5134 checking formats for: aap-wma-*-00:04:20:06:63:22
2006-06-28 19:22:28.5154 checking formats for: aap-wma-squeezebox2-*
2006-06-28 19:22:28.5175 checking formats for: aap-wma-*-*
2006-06-28 19:22:28.5195 checking formats for: aap-flc-squeezebox2-00:04:20:06:63:22
2006-06-28 19:22:28.5215 checking formats for: aap-flc-*-00:04:20:06:63:22
2006-06-28 19:22:28.5235 checking formats for: aap-flc-squeezebox2-*
2006-06-28 19:22:28.5255 checking formats for: aap-flc-*-*
2006-06-28 19:22:28.5274 Checking to see if aap-flc-*-* is enabled
2006-06-28 19:22:28.5295 enabled
2006-06-28 19:22:28.5313 Found command: [mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao
2006-06-28 19:22:28.5345 Setting maxBitRate for SB3 to: 0
2006-06-28 19:22:28.5371 Setting maxBitRate for SB3 to: 0
2006-06-28 19:22:28.5392 Matched Format: flc Type: aap Command: [mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao
2006-06-28 19:22:28.5414 opening next song (old format: flc, new: flc) current playmode: play
2006-06-28 19:22:35.2068 Setting maxBitRate for SB3 to: 0
2006-06-28 19:22:35.2102 Setting maxBitRate for SB3 to: 0
2006-06-28 19:23:05.4427 Setting maxBitRate for SB3 to: 0
2006-06-28 19:23:05.4462 Setting maxBitRate for SB3 to: 0

Can you get anything from this?
Is there some text missing from the command text strings? Looks like the command is chopped where the text has been wrapped by the editor. Will have another go at getting that right.

bpa
2006-06-28, 11:44
Definitely command string should at least look like (other lines have lame and flac afterwards)


[mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null

Ramage
2006-06-28, 12:11
Sorted the command strings which had been wrapped by Putty my terminal. Things now look a lot better but no sound with AAC+

extract of d-source shows this:

2006-06-28 20:02:10.0208 opening next song open: 1 error: ...
2006-06-28 20:02:10.0260 the next song is number 0, was 0
2006-06-28 20:02:10.0378 Setting maxBitRate for SB3 to: 0
2006-06-28 20:02:10.0407 Setting maxBitRate for SB3 to: 0
2006-06-28 20:02:10.0428 undermax = 1, type = aap, squeezebox2 = 00:04:20:06:63:22, lame = /usr/bin/lame
2006-06-28 20:02:10.0453 checking formats for: aap-wma-squeezebox2-00:04:20:06:63:22
2006-06-28 20:02:10.0473 checking formats for: aap-wma-*-00:04:20:06:63:22
2006-06-28 20:02:10.0493 checking formats for: aap-wma-squeezebox2-*
2006-06-28 20:02:10.0513 checking formats for: aap-wma-*-*
2006-06-28 20:02:10.0534 checking formats for: aap-flc-squeezebox2-00:04:20:06:63:22
2006-06-28 20:02:10.0554 checking formats for: aap-flc-*-00:04:20:06:63:22
2006-06-28 20:02:10.0573 checking formats for: aap-flc-squeezebox2-*
2006-06-28 20:02:10.0593 checking formats for: aap-flc-*-*
2006-06-28 20:02:10.0613 Checking to see if aap-flc-*-* is enabled
2006-06-28 20:02:10.0638 There are 0 disabled formats...
2006-06-28 20:02:10.0659 Testing wma-wma-squeezebox2-* vs aap-flc-*-*
2006-06-28 20:02:10.0682 enabled
2006-06-28 20:02:10.0699 Found command: [mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null | [flac] -cs -totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
2006-06-28 20:02:10.0735 Setting maxBitRate for SB3 to: 0
2006-06-28 20:02:10.0765 Setting maxBitRate for SB3 to: 0
2006-06-28 20:02:10.0786 Matched Format: flc Type: aap Command: [mplayer] -ac faad -demuxer aac -really-quiet -vc null -vo null -cache 64 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/4 $FILE$ 4>&1 1>/dev/null | [flac] -cs -totally-silent --endian=little --channels=2 --sign=signed --bps=16 --sample-rate=44100 --compression-level-0 -
2006-06-28 20:02:10.0809 playing out before starting next song. (old format: flc, new: flc)
2006-06-28 20:02:10.0829 00:04:20:06:63:22: Switching to mode playout-play from play
2006-06-28 20:02:10.0861 00:04:20:06:63:22 New play mode: playout-play
2006-06-28 20:02:10.0930 00:04:20:06:63:22: Current playmode: playout-play
2006-06-28 20:02:10.0956 No pending chunks - we're dropping the streaming connection
2006-06-28 20:02:10.1010 00:04:20:06:63:22: Can't opennext, returning no chunk.
2006-06-28 20:02:10.1888 00:04:20:06:63:22: Decoder underrun while this mode: playout-play
2006-06-28 20:02:10.1921 **skipahead: opening next song

bpa
2006-06-28, 14:19
It's not clear whether mplayer starts or not.

Can you delete the "-really-quiet" from the command line and run slimserver from a command line with --d_source.

The screen output from the command line should be a mixture of slimserver and mplayer output and may help show what's not working when an AAC+ station is selected.

Ramage
2006-06-29, 09:21
deleted -really-quiet, and started slimserver from command line using "/etc/init.d/slimserver start, but I am not getting any output to the command line.

Tried another way of starting with the following result:

[root@server ~]# /usr/local/slimserver/slimserver.pl --d_source
Can't locate Slim/Utils/Misc.pm in @INC (@INC contains: /usr/local/slimserver/CPAN/arch/5.8.5/i386-linux-thread-multi /usr/local/slimserver/CPAN/arch/5.8.
BEGIN failed--compilation aborted at /usr/local/slimserver/slimserver.pl line 265.

I think this has been mentioned in another thread relating to v6.3.0. Slim server appears to start OK from the script in init.d.

I am puzzled.

bpa
2006-06-29, 09:28
Starting slimserver from /etc/init.d/slimserver will just spawn a subprocess and doesn't give the output you need.

Find the slimserver.pl file. Where did you install slimserver - usually it is something like /usr/local/slimserver.

cd to the directory with slimserver.pl and then give the command
./slimserver.pl --d_source

dSw
2006-06-29, 13:02
deleted -really-quiet, and started slimserver from command line using "/etc/init.d/slimserver start, but I am not getting any output to the command line.

Tried another way of starting with the following result:

[root@server ~]# /usr/local/slimserver/slimserver.pl --d_source
Can't locate Slim/Utils/Misc.pm in @INC (@INC contains: /usr/local/slimserver/CPAN/arch/5.8.5/i386-linux-thread-multi /usr/local/slimserver/CPAN/arch/5.8.
BEGIN failed--compilation aborted at /usr/local/slimserver/slimserver.pl line 265.

I think this has been mentioned in another thread relating to v6.3.0. Slim server appears to start OK from the script in init.d.

I am puzzled.

The solution to your 'Can't locate Slim/Utils/Misc.pm' problem is in post #15 of this thread - http://forums.slimdevices.com/showthread.php?t=24089&page=2

Ramage
2006-06-29, 13:38
OK Things are getting a bit complicated.

Starting slimserver with /etc/init.d/slimserver start, I now have AAC+ working and wma not!! Reverting to normal script start also keeps the same state even after re-boot of server PC

See attachment for logged outputs for mp3, AAC+ and wma.

Stopping from AAC+ crashes mplayer - not in itself a disaster.

Does this make any sense? Bottom line, things have changed, since I removed -really-quiet, AAC+ OK WMA not whilst before it was WMA OK AAC+ not. I will put it back and try again.

Restart after inserting -really-quiet and I have AAC+ OK but wma tracks don't play.

Extra info, AAC+ works only when Bit Rate Limiting is on, but wma is now kaput.

Comments gratefully received.

bpa
2006-06-29, 14:32
Reverting to normal script start also keeps the same state even after re-boot of server PC

I don't understand the above - can you be more explicit but only if it provides additional info than what is below.



Stopping from AAC+ crashes mplayer - not in itself a disaster.

That is the normal way mplayer stops - it's just now you are seeing the message. Signal 13 is broken pipe - it means slimserver stopped reading from mplayer so mplayer takes it as a reason to stop.


Does this make any sense? Bottom line, things have changed, since I removed -really-quiet, AAC+ OK WMA not whilst before it was WMA OK AAC+ not. I will put it back and try again.

It doesn't make sense - WMA is different to AAC and they do not share anything. If the problems persist post your convert.conf, types.conf and slimserver-convert.conf files.



Restart after inserting -really-quiet and I have AAC+ OK but wma tracks don't play.

This vindicates my point - AAC and WMA are separate - you have two problems or a common problem later in the transcoding process where thinsg are common and not related to AAC or Flac e.g. flac !.



Extra info, AAC+ works only when Bit Rate Limiting is on, but wma is now kaput.

Are you sure your version of flac is working ?
When you enable bit limiting - use of flac is replaced by lame.

Ramage
2006-06-29, 22:15
Thanks bpa for the clear response.

I can't be sure whether flac is running correctly, is there an 'easy' way to test it? Presumably flac comes with mplayer.

Am I right in thinking that wma is decoded by AlienBBC in Linux?

The strange thing is that wma has run OK using the current set-up, and seemingly unrelated changes to convert.conf have stopped wma working.

I'll have another go this evening and if no success i'll post the conf files.

Cheers

bpa
2006-06-30, 00:49
You need to understand how slimsever uses the "conf" files to try and find this problem, so here is an explanation. Sorry it is a bit long. The answer to your last post is at the end of this post but you need this background.

There are two files which tell slimserver how to categorise a stream/file and then how to play it - types.conf and convert.conf. These files are distributed with Slimserver. In 6.2/6.3 Slimserver allows two other files to provide additional information - slimserver-convert.conf and custom-types.conf. These files are NOT changed after installation of Slimserver as they are files maintained by the user.

The types.conf and custom-types.conf files are used by Slimserver to categorise a stream/file typically by using a mime type or file extension (suffix). When a file is identified it is give a short code (e.g. wma, aap) and a type (audio or playlist).

The convert.conf file provide rules in order to play a particular file/stream once it has been given a code (e.g. wma, mp3, wav, app). The file is self documenting I'd advice reading it.

Slimserver-convert.conf is identical in format to convert.conf and similarly for custom-types.conf and types.conf. At startup the Slimserver files are read convert.conf & types.conf and then the Slimserver-convert.conf and custom-type.conf files - entries in these file will override similar entries in the distrbuted conf file.

Once a file/stream has been given a code (e.g. aap, wma) - Slimserver goes through the rules to find best way to play it for the device type. I'm not sure exactly but if a file/stream type cannot be played (e.g. RealAudio, AAC, AAP) then Slimserver will try to send the stream in FLAC unless some filetype have been disable or Bitrate limited.

In the case of WMA. For an SB3 in Linux, WMA will normally be passed through as SB3 can natively decode it. Since SoftSqueeze cannot decode WMA since there is no Slimserver distributed application (i.e. wmadec). AlienBBC adds WMA entries in Slimserver-convert.conf and uses its mplayer.sh to start mplayer to handle WMA stream for devices such as SoftSqueeze. No code of AlienBBC deals with WMA - it is just the entry in the file and mplayer.sh. If in filetypes "Windows Media (built-in)" is disabled than Mplayer.sh will be used for SB2/3 devices as well.

In the case of AAP, a new entry has been made in convert.conf and types.conf. The types.conf ensure the stream is given a code AAP which then is used to lookup the convert.conf file.



I can't be sure whether flac is running correctly, is there an 'easy' way to test it? Presumably flac comes with mplayer.

No Flac does NOT come with mplayer; it has nothing to do with MPlayer as it a utility used by Slimserver to provide Flac stream. On supported Linux distributions it is provided as part of Slimserver which means depending on how you installed Slimserver it may or may not be on your system. To check if you have flac - type "flac" on a command line and see if a program runs and produces a header that is readsonable something like


flac - Command-line FLAC encoder/decoder version 1.1.1
Copyright (C) 2000,2001,2002,2003,2004 Josh Coalson



Am I right in thinking that wma is decoded by AlienBBC in Linux?

Yes and No. WMA is decoded by SB2/3 natively on the SB unless "Windows Media (built-in)" is disabled - so most users do not need AlienBBC to listen to WMA on their SB2/3. On Linux, Softsqueeze needs an application to decode WMA. AlienBBC installation adds WMA lines in Slimserver-convert.conf to allow Mplayer to decode WMA. No Perl code of AlienBBC is used in processing WMA. For some URLs AlienBBC code is used to parse ASX playlist files - this results in a URL of a WMA stream which is then handled in the normal way.


The strange thing is that wma has run OK using the current set-up, and seemingly unrelated changes to convert.conf have stopped wma working.

Do a diff on the two version of convert.conf (or your version and the version on the slimserver distribution) and isolate which change causes the problem. An accidental line deletion and a character inserted (e.g. space) can change a rule.

Ramage
2006-06-30, 02:13
Thanks for the comprehensive explanation - it will help my understanding of the workings.

I have been using my SB3 for all the tests, not Softsqueeze; therefore I should expect wma to be decoded by SB3 - I have tested with the native wma enabled and disabled - no discernible difference except for an entry in d_source log when disabled.

Flac is in the correct directory for use by SS with the appropriate permissions - I will check running tonight.

Could this be a SB3 firmware issue coupled with a problem in Slimserver-convert.conf, or alternatively SS not recognising the wma track format in the first instance?

bpa
2006-06-30, 04:10
Could this be a SB3 firmware issue coupled with a problem in Slimserver-convert.conf, or alternatively SS not recognising the wma track format in the first instance?

Generally if it was a firmware problem then there would be a few other people complaining about it especially if it Linux & WMA.

Stick to simple diagnosis - something in changes to the slimserver files have messed things up.

Whenever this sort of problem crops up - the best solution is to re-install completely - get rid of the pref file, plugins and database as well. Then make the changes one step at a time and retest to make sure

1. Stop Slimsever, delete pref file, plugins, database and Mplayer. Re-install Slimserver. At no point in the following steps should changes to Server Settings (e.g. filetypes, debugging) be needed.
2. Stop & start Slimserver. Test WMA & MP3 files and streams. Use WMA Stream that do NOT use the voice codec as these will have no audio on SB3 and seem like a problem. WMA decode on SB3 should work out of the box with no plugins. Make reference d_source logs to compare in case problem arise later.
3. Install Mplayer and check it works standalone. Check step 2 again and make sure all works and that you restart slimserver before testing. If something stops working - undo the last change and prove that the change caused the problem - sometimes internet streams stop working or are oversubscribed so if a problem arises with a stream check that it is working before assuming the change caused the problem.
4. Change Strings.txt, types.conf and convert.conf for AACplus support - one file at a time and between each file do step 2.
5. Now test AACPlus streams. If they work then checl WMA and MP3 as well.
6. Install AlienBBC and do Step 2 and also check for AACplus.

This is tedious but it will identify the problem area if there is one as it could have been finger trouble.

Ramage
2006-06-30, 04:31
You are right, finger trouble is usually the cause.

WMA worked OK before I made the AAC+ changes

I'm going to roll back a few steps before trying a full re-install, as I am now cheesed off with getting things wrong in the first place, and determined to find the prob.

I will have my WinXP to stream the music whilst I play with the Linux.

Thanks bpa for letting me pick your brain.

Ramage
2006-06-30, 11:38
bpa

System is now fully functional. Installed 6.3.0 (official release) fixed the problem.

Modified the .conf files very carefully - putty does tend to wrap the line of text when inputting and CRs have to be removed to make it work properly.

It remains a mystery what the final problem was - although finger trouble contributed to the earlier problems.

Grateful for your time - I have learnt a lot.

bpa
2006-06-30, 11:42
Glad to know it all worked out in the end.

I have done a wiki entry for AACplus but I think I'll attach files with the relevant text to make life a bit easier.

Ramage
2006-06-30, 22:15
Great idea, it's easy to corrupt the strings, as I know to my cost.

Be nice to have the AAC+ mod included in the SS build. Bug#1839 covers it.