PDA

View Full Version : Making Sure FLAC is streamed in full res



agentsmith
2006-04-21, 21:59
Hi I know this is basic, how do I make sure that my FLAC files are not transcoded to a lower format?

Is it simply a matter of:
1. Go to Server Setting
2. Go to File Types

---
Tick Check Box
File Format = FLAC
Stream Format = FLAC
Decoder = built in
---
UnTick Check Box
File Format = FLAC
Stream Format = MP3
Decoder = FLACflac/lame
---
Is that all?

---
What about ?

File Format = FLAC
Stream Format = WAV
Decoder = flac

Should that be checked as well?

What's the difference?

What if you check both flac-flac and flac-wav?

rudholm
2006-04-21, 22:08
All you need to do is set bitrate limiting to "no limit". It's a player setting. I believe it's the default.

kdf
2006-04-21, 22:17
On 21-Apr-06, at 9:59 PM, agentsmith wrote:

>
> Hi I know this is basic, how do I make sure that my FLAC files are not
> transcoded to a lower format?
>
If you have a squeezebox2/3 then by default Flac plays untouched. The
player decides the format. If you think you may have accidentally set
the bitrate limiting, then you can verify in player settings->audio.
Make sure it is set to "no limit". This is the default, and will let
the player use the "built in" decoding. Flac converts to WAV for
Squeezebox 1 (mp3 if wireless). Most times, you shouldn't have to
worry about any of the file types settings unless you wish to force a
particular conversion at some point.

-kdf

Skunk
2006-04-22, 06:12
What about ?

File Format = FLAC
Stream Format = WAV
Decoder = flac

Should that be checked as well?

What's the difference?


If you check that box, the server transcodes the FLAC and streams .wav over your network. If the box is left unchecked the server streams FLACs, which the SB can decode on the fly.

You'll lose the ability to FF/RW if/when streaming .wavs, but some say the quality is better when the transcoding load is taken off the SB itself.

I use FLAC this way, mostly because I have an ethernet connection and don't care for fast forwarding. If you want to test for a difference in SQ, you just check/uncheck this box- and turn off the SB through the web interface. Refresh the browser then press play. Test for the change by attempting to FF. I'm not sure if 'file types' is accessible through the remote, so testing for a difference can be difficult.

Anyway, it may be worth a try. If you hear a difference it'll be the cheapest upgrade you ever made ;-)

EDIT: to answer your last question, you want to have flac>flac unchecked if trying to stream .wav, or it will default to streaming flac- iirc.

agentsmith
2006-04-22, 23:30
Thanks for the replies.

I checked the player setting and yes it was defaulted to no limit.