PDA

View Full Version : Wake-on-LAN: something new...?



Magwitch
2006-04-21, 05:03
Does anyone know of a Squeezebox setting to control how long the SB waits for a server to come up after sending WOL packets? I haven't been able to find one myself.

My little 2.5Ghz Celeron box running XP Professional can wake up from hibernation in a little under 30 seconds; but that's not quick enough for my SB2, which fails to connect every time.

Retrying the connection via a remote makes the SB2 try again, then it powers itself off. If I then power it up again, it connects immediately.

This is a bit of a nuisance as I use a Harmony universal remote, and have to go through a lot of button pushing via its interactive help to coax the SB2 to power up again after failing to connect. The original SB2 remote is safely tucked away in a drawer, otherwise I'd be drowning in high impact plastic and soft rubber buttons :)

I can program a button on the remote to toggle the power for me; but I'd really like a simple timeout I can tweak to step around the problem altogether.

Optimising the server PC to come to life quicker doesn't seem a likely option, as I'm using hibernation mode so the state of the machine is saved out to disk. I've tried standby mode to see if that's quicker, but it still isn't fast enough.

Any help or sympathy much appreciated!

Nick.

michel
2006-06-17, 09:38
I am bringing this topic up because my PC needs longer too to come back from standby. This is An Athlon 2400+ machine so I think this must be a common concern.

bigjules
2006-06-20, 15:33
I thought the SB polled for the server continuously anyway.. so it should find the server as soon as the server machine is up and running.

Jules

MrStan
2006-06-21, 01:47
I thought the SB polled for the server continuously anyway.. so it should find the server as soon as the server machine is up and running.

Jules

It will find the server as soon as it comes up, but if the server does not come up quickly enough the SB will return to the OFF state. When the server eventually arrives the SB will then display whatever you have configured for the OFF condition.

Niss
2006-10-25, 11:24
Can I also pile into this thread. I have the same problem/question as Magwitch and Michel, namely that by the time server has resumed from hibernate, the SB has given up waiting and powered off again. It then needs to be turned on again at the remote -- not disastrous, but a bit untidy.

Is there a way to change the SB settings so that it will wait longer for a reply from slimserver before it powers itself off?

Tarn
2006-10-25, 14:05
One more vote more a settable timeout param, or at least a longer default wait time.

Mark Lanctot
2006-10-25, 15:25
Create an enhancement request at http://bugs.slimdevices.com. The developers can't track every thread on the forums.

You'll have to register first.

Once it's created, you can vote for it to increase its profile.

Niss
2006-10-26, 05:13
I have posted report # 4424. Others with the problem -- Magwitch, Michel, Tarn? Others? -- please vote for it.

florca
2006-10-26, 14:32
I think this behaviour may be a bit more subtle than simply a timeout value. On my system it's dictated by the exact state of the SB when the server system drops into standby (S3 suspend in my case).

1) If the SB is "off" (which on my device I have set to "blank" screensaver) when the Slimserver drops into standby, then turning the SB on again via the Power button on the remote will behave as per this thread. It cycles through "Waking Slimserver...", "Connecting to Slimserver..." and then reverts to a blank screen, after which you need to retry the Power button to activate.

2) If the SB is "on" (which I have set to a clock screensaver) and I then force the SS system into standby, the SB will drop back to "blank" - re-waking the SB after any period will then go back through Waking / Connecting but now it will re-connnect and return to a "clock" state. So I think that the SB may be simply reverting to its logical state when the system entered standby, rather than failing to connect.

This may not be true in all cases, but it would certainly be welcome if re-awakening forced the SB into a logical "on" state rather than requiring the Power button to do this - although I can see that this may be quite tough to achieve.

Brgds
Phil

mswlogo
2007-01-09, 19:37
I have the exact same issue. My ThinkPad server will come out of sleep in about 5-10 seconds but SQ3 gives up and shuts off. It should keep trying longer.

Gildahl
2007-01-10, 09:48
I had this issue when I first got my Squeezeboxes over a year ago. I eventually gave up on using WOL for precisely this reason and run my server 24/7 instead.

dkxdn
2007-04-08, 00:58
To run the server 24/7 is not a solution its a "given up sign "!
No where must be a way to setup a timeout value so the SB can wait for the server to wake up - typical 1-2 min.

mswlogo
2007-04-08, 06:13
This is an old bug, you shoudl search for the OLD bug and vote on that one rather than fragment it.

Drives me insane too.

Oddly enough I switched from Wired to Wireless and the it connects faster.

I think it does wait long enough, it's just that it loses connection as the server starts to respond. I think it needs a retry loop, not a longer timeout.