PDA

View Full Version : Italian radio station: how to?



TheSaint
2006-04-17, 21:20
HI guys....


just a little question for you all:
I would like to listen to an italian radio and I think this is the correct address...
mms://digi04.digitalidentity.it:80/wmtencoder/15232234.wmv

Now, when I paste that under "tune in" in the slimserver, I can' t hear anything....

I need a little help!

:) Thank you.

Mark Lanctot
2006-04-17, 21:30
That's probably not the correct URL - that would be a Windows Media Video (WMV) file.

You should be looking for a Windows Media Audio (WMA) file. Be on the lookout for MP3 or MP3 playlist (PLS) files as well.

Finding the right URL is quite hard, especially since some radio stations purposefully hide it. There are programs out there for trying to get the URL:

http://www.donationcoder.com/Software/Mouser/urlsnooper/

http://www.proxomitron.info/

slimpy
2006-04-18, 02:13
The URL is correct and plays fine in Windows Media Player. WMP report it as:
Windows Media Audio 9
48 kbps, 44 kHz, stereo 1-pass CBR
But why they would use the video file extension for an audio stream is beyond my imagination. I assume that since slimserver cannot play video files it simply refuses to play anything with a .wmv extension (which makes perfect sense IMO).
Write an email to the radio station and ask them if they could use the proper extension (.wma) for their stream.

-s.

bpa
2006-04-18, 02:47
I've got SB3, 6.5b1 and AlienBBC 1.01 installed and it played OK when I pasted in the URL into Radio Tune-in.

AlienBBC wasn't used to transcode but AlienBBC may have affected the parsing of the URL

TheSaint
2006-04-18, 11:43
Thank you so much guys....

I'll try AlienBBC and see if it changes anything...will report back :)

bpa
2006-04-18, 12:24
I went back over some old post I wrote about silence when playing mms streams on SoftSqueeze. I quote it below.

Before installing AlienBBC - try playing around with the filetypes especially disabling WAV->FLAC.


Since some were complaining that SoftSqueeze didn't work, I did some tests on filetype setting with SoftSqueeze with this URL mms://ms2.capitalinteractive.co.uk/xfm_high
and found a combination that worked.
I have the following filetypes enabled (i.e. all other disabled)
All 3 AIFF, All 3 FLAC, MP3, All 4 Musepack, All 3 OGG Vobis, of RTSP only RTSP->MP3, WAV-> MP3 & WAV->WAV, Windows Media -> MP3 & Windows Media -> WAV.

I found that if I enabled WAV->FLAC I got no output from Softsqueeze - errors and stream closes down or is closed down.


If you still have no joy - try posting a log with d_source debug flag set.

TheSaint
2006-04-18, 17:13
AHHHHHHHHHHHH WOOWOOOOOOOOOOOOOOO!!!

It works now!! Can't beleive it! Thank you so very much!! :)

bpa
2006-04-18, 23:55
To help others,

what did you do to make it work ?

What player are you using - SB2/3, SB1 or Softsqueeze ?