View Full Version : SlimServer on a Synology Diskstation 101j How To

2006-04-17, 14:44
Philippe Kehl has announced a How-To for running SlimServer on a Synology
Diskstation 101j in the German forum:


The documentation is in English - might be interesting to users of that
NAS solution.



Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

2006-05-17, 15:13

I finally managed to (mis-)use the firmware upgrade feature on the Synology DiskStation 101j to easily install slimserver on that NAS (the 101g+ and 106e versions won't work).

Go to http://oinkzwurgl.org/software/ssods/ to get the patch and further details. And be sure to check the trailer (animated GIF)!


Yes, you do not need telnet access.

Yes, this package will allow you to enable telnet access.

Yes, you can import your preferences and database from the previous ssods version.

Happy Hacking!



2006-05-17, 16:30
Great article. I can imagine quite a few people will want to 'mod' devices like this to run SlimServer rather than having to run a full blown PC 24/7/52.

When I looked around for an alternative to my PC based Mandriva SlimServer I did look at the Synology 101J NAS as a possible option, but as I couldn't find any info. on anyone porting SS to it (and therefore didn't know whether it would even be possible to do it) I moved onto other devices.

In the end I purchased (three weeks ago) a KuroBoxHG, installed my own HD, and proceeded to install Gentoo and SlimServer on it. It's now been running 10 days, AlienBBC & LastFM installed without issue, and it's been servicing 2 Squeezeboxen and 1 Softsqueeze player without fail, even when playing flac music whilst downloading same onto it from the original Mandriva box. I'm well impressed with it... If anyone is interested I'll do a wiki entry for those wanting to use the KuroBoxHG as a SS.

Maybe a wiki entry for Philippe's work would be good also?


2006-05-19, 05:49
For those in the UK Scan computers have the 101j on Today only this weekend for 115 inc vat.....

300Gb Maxstor is 65.


Seems like a good deal.


2006-05-30, 05:50
B*gger. Missed it. :(

2006-06-05, 09:03
Well, it came back on at Scan over the weekend so I bought one. It arrived this morning. Installed 250GB Samsung SP2514 and screwed the case back up.

Followed the instruction in this thread and have Slimserver up and running on my DS-101j beautifully easily and it took less than 30 minutes from opening the DS-101j box. Didn't touch the sides. :)

Brilliant, thanks. Saved a lot of cash by not having to buy one of those pre-installed QNAP/Slimserver combos.

2006-06-05, 09:16

Nice to hear that.

What firmware do you have? I suggest that you do not upgrade it, since that will make SSODS unusable (and not installable a second time). Wait for the new version (coming very soon) which will include instructions on how to upgrade the fw when SSODS is already installed.


2006-06-05, 14:32
I'm using what came on the box: 2.0.1 - 3.0281 I wasn't tempted to update it.

Thanks very much for the warning though. :)

2006-06-05, 14:35
Okay then. That's already the most recent fw release for the j. Mine had release 240 on the CD and I had to download the 281 patch.

2006-06-05, 14:43
I think scan.co.uk turn their stock very quickly, which is why their prices are so good. I got an extra fiver off mine becuase they said the box was a bit bashed. A bit bashed? It looked like it had been run over by a tank. The DS worked fine, though.

I'm unraring some archives to it at work tomorrow and then I'll bring it home.

2006-06-06, 09:00

SSODS now runs on all (hopefully..) Diskstations.

The firmware patch and detailed instructions are available at http://oinkzwurgl.org/software/ssods/.

Some Screenshots are available at http://oinkzwurgl.org/software/ssods/install.


2006-06-06, 17:23
When you say any Diskstation, do you mean it'll now run on the 101g?

2006-06-06, 17:35
Indeed, I do.

I did not test it, but I am rather confident that it will work. The 101g+'s hardware must be much the same as that of the 106e and the software is common for all Diskstations (apart from added features in newer releases).

2006-06-06, 17:49
Mmm. I have a new 101g at work with a 500Gb 7000.9 Seagate Barracuda in it. I was going to bring it home and run it alongside the 101j but with my video files on (the audio files are all on the 101j).

If I could run SS on the 101g I could just use that on it's own at home (plus it's black and matches our decor better than the white of the 101j). I coud take the 101j back to work and nobody would be any the wiser ;). So, I would only need the one DS.

If I tried to install ssods and SS on a 101g what's the worst that could happen if it didn't work?

2006-06-06, 17:56
Virtually nothing. Not working would mean, that you cannot start the slimserver process because of binary incompatibility. But that shall not happen. There is an included "deinstallation-patch" which will completely remove all of SSODS even if the installation has partly failed. And in the very worst case you can still format the whole harddisk and setup the DS from scratch.

I cannot think of any way why the installation of the patch would interfere with the DS functionality.

2006-06-06, 18:06
OK, in that case I'll have a go at installing ssods and SS on the 101g tomorrow.

It's late and I have "work" tomorrow, so I'm going to bed now. :)

2006-06-07, 03:00
OK, well I tried flashing the ssods patched firmware:


This is my ds-101g data:

Model Name: DS-101g+
Current Firmware Version: 2.0.1 - 3.0284
Firmware Date: 2006/02/14

I got the error 42 message as expected and went to the ssods tab of the Network Admin menu (logged on as admin)

Then when I tried to do this:

2. Then, in the admin interface, under Networking, go to the SSODS panel.

3. Follow the instructions given there carefully.

and got the 403 result:

You don't have permission to access /tools/ssods.cgi on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

So, and to prove I have the Readme.txt, I have tried logging in again, about ten times. This isn't having any effect. I still can't get in.

More ideas?

EDIT: The admin password is admin and the string being passed to the webserver is:


which doesn't look like it should be giving html problems.

I'm stumped. I have run ssods-deinst.pat

2006-06-07, 03:46
Well, at least the DS is still running. ;->

What firmware revision do you have?

What DS do you have exactly. You say "101g". Does that exists? Do n't you mean 101g+?

I have one confirmation from a g+ user by mail. Although from an earlier (not published) version. And he had his machine already patched before (Optware). Maybe there is some library incompatibility.. Although I do not understand why.

Did you patch the machine before (NSLU2/OpenSlug/Optware or the like)?

We can do two things.

1. Check if SS would still run. That can be done by telnet (command: /volume1/SlimServer/bin/rc.slimserver start). If it runs, we're fine, then it's only the admin interface which does not work.

2. See why the admin interface produces an error. I'll look at that. The URL you posted is okay. The id will be checked against the file "current.users" which contains a list of currently logged in users. If that fails, you get a clear message indication so and not a webserver error.

2006-06-07, 03:58
What DS do you have exactly. You say "101g". Does that exists? Do n't you mean 101g+?
I posted the version and model data in the post above. :)

Model Name: DS-101g+
Current Firmware Version: 2.0.1 - 3.0284
Firmware Date: 2006/02/14

Did you patch the machine before (NSLU2/OpenSlug/Optware or the like)?
Er, well I haven't but I bought it on eBay.... :???:

Is there any way to check? It came with no HDD and I installed a new unformatted one yesterday. I loaded the firmware downloaded from DS web site and all seemed to go well.

We can do two things.
Let's try number 2 (above) first, can we?

Thanks, flipflip, BTW. :)

2006-06-07, 04:02
Oh, sorry, my concentration has gone down a bit.. I need some "fuel" (i.e. lunch) soon :-)

If you install with a new harddisk then you have an unpatched system. There's not much to patch in the flash memory. And if there was something wrong the DS would probably have other problems.

I'll have a llok at the firmware. I cannot see it running, but i have the files. Maybe there is a slight difference to mine (since it is a bit older; revision 284, i have 281 on the j).

When SSODS is installed (as far as it gets, i.e. after the error 42 and your error 403), can you still use the rest of the DS menu? Just the SSODS panel does not work, right?

As far as I can see, the fw 284 is much the same as the 281.

Do you think you can enable telnet (with patch "enable-telnet.pat" in the "syno-telnet-r1.zip" file), log in as root (password=synopass) to the DS, issue a few commands and post the output? You'll find the necessary supplementary "syno password" here (http://oinkzwurgl.org/software/ssods/synopass.php).

If yes, please do so and issue the commands:

ls -l /usr/syno/synoman/tools/ssods.cgi

ls -l /volume1/SlimServer/bin/ssods.cgi

cmd=si_set /volume1/SlimServer/bin/ssods.cgi

2006-06-07, 04:08
Oh yes, the DS is still running OK. I can see the files in the public folder and I can access them:


Thanks, flipflip. Talk later. :)

2006-06-07, 06:16
rhubarbe, i am sorry to tell you this:

A collegue has just tested it on a new (i.e. installed from scratch, with an empty hdd) DS-101g+, firmware 284. And it worked as expected and described!

I suggest, that you start from scratch as well. Empty the HDD: delete all partitions. you probalby need to connect the HDD to another computer (internal or in an external usb-enclosure) and delete the partitions. This can be done in windows using the "Disk Tool" (I don't know the exact English name) under "Administrative Tools" (or so).

Then reinstall the DS with the firmware 284 and try again.

I hope it will work.


2006-06-07, 06:20
Oh dear. No SATA on our PCs and I don't have an external SATA enclosure.

EDIT: I deleted the files from my /public dir and tried the patch again:

The SlimServer web interface is at _http://
SlimServer auto start is disabled.
The database file is missing.
SlimServer is not running.
The following buttons will either start or stop the SlimServer process, or display the log.

Looks like we have success, Houston.

I'll build a database and report back later. :thumbsup:

2006-06-07, 06:36
Yeah, that looks rather good!

2006-06-07, 06:53
The SlimServer web interface is at _http://
SlimServer auto start is disabled.
Database file size is 0.1 MB.
SlimServer is running, PID is 2831.
Process state is S (sleeping).
Memory usage is 48436 kb total with 36784 kb resident set size.
Running since: 14:44, CPU time: 2:04, CPU load: 30.6% (average).

That looks even better! :grin:

Web Interface working too.

All working now and thanks very much flipflip. :)

2006-06-08, 08:32
I created a poll on SSODS. Could you please vote? Many thanks.

here (http://forums.slimdevices.com/showthread.php?t=24564)

2006-06-08, 14:46
OK, I voted for ds-101g+ but I installed ssods on ds-101j also. I am currently running the ds-101g+ and it's running just fine.

2006-07-06, 05:57
Have a slight problem with my DS-101j and even though I am sure it isn't connected to SSODS I thought I'd ask it anyway.

Thgere is a facility on the DS-101j to backup to a mounted USB HDD attached to the DS-101j.

You can choose for the DS-101j to automatically do backups based upon a schedule. I have set an hourly backup schedule but the danged thing just doesn't do it. It does an immediate backup if I click on that but reports a transfer of 0MB in 0sec. I have to ftp to the USB HDD to be abe to confirm whether it has done anything and I do not want to have to do this every time.

Anybody else get this? Is it SSODS or is it the capacity of the USB HDD tat I am using (40GB) DS-101j HDD 250GB.


2006-07-06, 06:38
I do not think that SSODS has something to to with it.

I do backups on demand (manually initiated). I had (have) an issue with Firefox where the backup status page would not update (i.e. show progess 0 mb and 0 time left to finish). With IE the problem does not appear.

Do you have the latest firmware (368)?


2006-07-06, 08:52
I'm using: 2.0.1 - 3.0281. I have the problem in IE 6.02.2900 and in FF What version of IE are you using?