PDA

View Full Version : Synchronized Players Out of Sync



tharrison
2006-04-11, 20:18
When I synchronize the SqueezeBox and SoftSqueeze, there's a significant lag, perhaps 1/2 second or so between one and the other. When sitting in a room hearing both players, the lag is clearly noticable.

SlimServer is running on a Win XP PC. One client is a SqueezeBox running over a wireless connection. The other client is a separate Win XP PC on a wired connection.

Is this a known issue? Is there anything I can do to resolve it?

Thanks --

Tom

Michaelwagner
2006-04-11, 21:23
Yes, and Yes.

Recent coding changes have improved the situation. Search forum threads for softsqueeze.

But the problem is a difficult one to solve in the general case, since they are so different.

ctaggart
2006-04-11, 22:53
When I synchronize the SqueezeBox and SoftSqueeze, there's a significant lag, perhaps 1/2 second or so between one and the other. When sitting in a room hearing both players, the lag is clearly noticable.


Which one is ahead and which one is behind? My Squeezebox plays about a half second ahead of my Softsqueeze.

tharrison
2006-04-11, 23:20
Yes, and Yes.

Recent coding changes have improved the situation. Search forum threads for softsqueeze.

But the problem is a difficult one to solve in the general case, since they are so different.
I'll chck out later versions of SoftSqueeze, although mine's about a week old now, so hardly venerable :-)

Thanks --

Tom

tharrison
2006-04-11, 23:27
Which one is ahead and which one is behind? My Squeezebox plays about a half second ahead of my Softsqueeze.
I am pretty sure I have the same situation.

Not the end of the world, but does kind of mitigate the value of the whole-house solution I was hoping to achieve. It would be nice if there were a specifiable lag one could define for a specific client when multiples were synched.

Thanks --

Tom

danco
2006-04-11, 23:42
I am pretty sure I have the same situation.

Not the end of the world, but does kind of mitigate the value of the whole-house solution I was hoping to achieve. It would be nice if there were a specifiable lag one could define for a specific client when multiples were synched.

Thanks --

Tom

I believe the problem is specific to trying to synchronise Softsqueeze with a Squeezebox. If you are having problems with synchronising two Squeezeboxes, that should have a different cause. Post more information and people will help.

mattybain
2006-04-12, 04:00
Have you tried Squeezeslave https://sourceforge.net/project/showfiles.php?group_id=105169 .

It works much better for me. However with 3 SB's and 2 squeezeslaves there is still sometimes a very slight annoying lag.

Michaelwagner
2006-04-12, 05:34
mine's about a week old now, so hardly venerable :-)
No, I would look elsewhere if yours is only a week old.

One of the authors of softsqueeze contributes here regularly, or you could check old threads by looking for softsqueeze.

I seem to recall there were some Java things to check, but since I use neither Java nor softsqueeze, they don't stick in my mind.

abdomen
2006-04-12, 06:09
One of the authors of softsqueeze contributes here regularly, or you could check old threads by looking for softsqueeze.
You are probably referring to Richard Titmuss, who I understand is the author of SoftSqueeze and SqueezeSlave. He was recently hired by Slim Devices, but not strictly to work on those things (in fact, based on his post excerpted below, his coming aboard has taken him away from those things for the moment).


...my plan is to migrate Softsqueeze to use slimprotolib. Things have come to a bit of a halt on this front at the moment due to my change in jobs. I hope to pick this up again in a few weeks.

The problem is the Java audio layer has too much latency, and appears to work inconstantly. This seems to cause lots of people trouble with sync, which was actually one of my main objectives when I started coding Softsqueeze. Also the CPU usage is _much_ higher with the Java decoders, when integrated with slimprotolib the cpu usage approached zero during playback...

(From http://forums.slimdevices.com/showpost.php?p=100880&postcount=3)

tharrison
2006-04-12, 19:08
Good posts all around. I guess I'll just buy another SqueezeBox in order to test the theory :-)

Tom

tharrison
2006-04-30, 10:16
The SlimServer 6.2.2 and SoftSqueeze 2.3 updates resolved my sync issues. Thanks all!!