PDA

View Full Version : 6.5b1 Plays only one track on SB3 (Linux)



davep
2006-04-08, 19:51
I have been running 6.2.1 successfully on my ubuntu box and wanted to try 6.5 to get the sort art by artist feature. I have installed from the tarball, upgraded the firmware to 37, and got it to run fine. However on my SB3 the play stops at the end of the first track. Using the down arrow to manually move to the next track and pressing Play makes the progress bar for the new track jump immediately to full (or occasionally about 2/3 full) and stay there. Same thing happens for each successive track chosen, with nothing actually playing. Rebooting the SB3 (holding down power button) restes things and it will then play a new track, but the same effect repeats and it stops at the end of this new track.

Interestingly my SB2 (also with firmware 37) does not show this behaviour but plays tracks consecutively without intervention or interruption - it is only the SB3 that stops. Given that I believed that the SB2 and SB3 were essentially identical other than the display and physical packaging, this seems odd to me.

I have tried doing a factory reset on the SB3 but this does not fix the problem.

Any ideas before I open a bugzilla?

davep

davep
2006-04-16, 23:49
BUMP
Did not get any response to this problem which has persisted through several nightlies and two firmware upgrades so have opened Bug 3283.
davep

melston
2006-04-17, 22:20
I experienced the same issue on one of my SB3's as well. Strangely enough one SB3 seems to work fine but one will only play one song and only a power cycle will allow it to play another (one) song. I have tried a couple times to reload firmware to 41. Also used a direct ethernet connection to eliminate any of the wifi potential issues. i am used an XP slimserver 6.2 just downloaded today April 17. i'm perplexed.

Anyone? Anyone? Bueller?

davep
2006-04-18, 05:53
I have just cracked this one. I had been starting 6.5b1 using the init script which came with the deb package. When it consistently failed to play more than one track I switched back to running 6.2.2 and, in order to stop 6.5 attempting to restart automatically, I had moved the init script out of the /etc/init.d folder. On the last go around I accidentally deleted it so, when I wanted to test 6.5b1 again using some debugging, I resorted to starting it directly by using /usr/sbin# ./slimserver.

Lo and behold the music played from track to track with no hesitation. I then went back to using a copy of the init script from the deb package to start it and it reverted to the 'one track then stop' behaviour. I have got this behaviour repeatably on a couple of tests so I am suspecting it is something in the init script.

I have updated Bug 3283 and attached a copy of the script in case that helps anybody track down the cause.

davep

slimpy
2006-04-18, 07:10
Did you use any parameters when starting from the command line? Did you run slimserver as root or any other user?
I suspect this to be a permission problem on one of the directories/files in the init script.

-s.

davep
2006-04-18, 07:25
Did you use any parameters when starting from the command line? Did you run slimserver as root or any other user?
I suspect this to be a permission problem on one of the directories/files in the init script.

-s.
No parameters on the command line, just '/usr/sbin# ./slimserver' but run as root so you could be right about it being a permissions thing. However, when I was using the init script this was also started from root using '/etc/init.d/slimserver start'

davep

slimpy
2006-04-18, 08:04
There are some differences between starting the script as root and running slimserver as root. First, the script starts slimserver as user slimserver (the --chuid $SLIMUSER parameter, $SLIMUSER resolves to "slimserver"), the script sets custom locations for CACHEDIR (/var/cache/slimserver vs the default ~/cache), LOGFILE and PREFSFILE (don't recall where the latter two will be placed by default).
Try the following:
Copy the code below into a new file and make it executable (chmod +x <filename>)
First, run this batchfile as user slimserver (as root type su slimserver, verify your identity by typing id). You should experience your one-track-only-problem. Now stop slimserver and type exit, you should now be root again, verify by typing id. Now run the script as root. If your problem is gone then have a look at the permissions of the following files and directories:
/etc/slimserver/slimserver.pref
/var/log/slimserver/slimserver.log
/var/cache/slimserver
The user slimserver needs write access to these files and directories.



#!/bin/sh
set -e
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
NAME=slimserver
PREFSFILE=/etc/$NAME/$NAME.pref
LOGFILE=/var/log/$NAME/$NAME.log
CACHEDIR=/var/cache/$NAME

/usr/sbin/slimserver --prefsfile $PREFSFILE \
--logfile $LOGFILE \
--cachedir $CACHEDIR

If you are unsure what the permissions on the files/directories should be post the current permissions here. Please also post the output of id slimserver

-s.

kdf
2006-04-18, 09:04
On 18-Apr-06, at 5:53 AM, davep wrote:

>
> Lo and behold the music played from track to track with no hesitation.
>
debian has a safe that restarts the server in the case of a crash. I
suspect that your "stopped" mode is actually the restarted server
sitting idle.
have you looked at the log file for anything when the playback stops?
-k

davep
2006-04-18, 16:02
If you are unsure what the permissions on the files/directories should be post the current permissions here. Please also post the output of id slimserver

-s.
Interestingly the id reported when I do su slimserver is root (0). the permissions on
/etc/slimserver/slimserver.pref
/var/log/slimserver/slimserver.log
/var/cache/slimserver
are all user: slimserver-SlimServer; group: nogroup

davep