PDA

View Full Version : SlimServer findet nicht alle Songs der iTunes Bibliothek...



AndreasG
2006-04-08, 02:20
Hallo zusammen,

Welche Gründe kann es dafür geben, dass SlimServer nicht alle Songs findet, die sich in meiner iTunes-Bibliothek befinden?

Mein System: Ich benutze SlimServer 6.2.2 unter Windows und 6.2.1 auf dem Mac. Die Bibliothek liegt auf 3 externen 250GB Platten (Formate Apple Lossless und MP3), die Platten sind FAT32 formatiert, so dass ich sie am Mac und am PC gleichermaßen benutzen kann.

Nachdem ich einige Ungereimtheiten mit den unterschiedlichen Dateinamen-Konventionen beider Betriebsysteme beseitigt habe, findet iTunes auf dem PC und auf dem Mac nun die gleiche Anzahl von Songs: 20 385.

Wenn ich einen kompletten SlimServer Re-Scan auf dem Mac ausführe, werden fast alle Songs gefunden, aber nicht alle (keine Ahnung, wie ich rausfinden soll, welche Songs fehlen...). Auf dem PC werden deutlich weniger Songs gefunden, gut 19 000. Interessanterweise ist die Zahl auch nicht immer gleich. Woran kann das liegen?

Ich bin extrem zwanghaft mit dem Taggen meiner Songs, ein offensichtliches Problem mit den Tags besteht nicht. Gibt es irgendwelche Beschränkungen was die Länge von Tags und von Dateinamen oder die Tiefe der Verzeichnisstruktur angeht?

Ich wäre echt dankbar für eine Lösung dieses Problems...

Andreas

AndreasG
2006-04-08, 07:20
...nach stundenlangem Suchen hat sich das Problem zumindest teilweise gelöst:

SlimServer übersieht alle Ordner, die mit einem Punkt enden!

Andreas

mherger
2006-04-08, 07:33
> SLIMSERVER üBERSIEHT ALLE ORDNER, DIE MIT EINEM PUNKT ENDEN!

Bitte eröffne einen Bug (http://bugs.slimdevices.com) oder ergänze deine
Informationen, falls es schon was ähnliches gibt. Danke!

--

Michael

-----------------------------------------------------------
Help translate SlimServer by using the
StringEditor Plugin (http://www.herger.net/slim/)

AndreasG
2006-04-08, 09:07
...bin mir nicht sicher, ob das ein SlimServer- oder ein Windows-Bug ist... Versuch mal in Windows einen Ordner mit einem Punkt am Ende zu erstellen: Das führt zu einer Reihe komischer Effekte...

Witzigerweise ist es am Mac ja genau umgekehrt: In einem Unix-OS werden natürlich alle Ordner nicht gefunden, die mit einem Punkt anfangen...

Ein tatsächlicher SlimServer-Bug ist allerdings das Problem, dass alle Alben, die mit einem Sonderzeichen beginnen nicht in der "Browse Albums" Ansicht gelistet werden!!! Ich hatte im englischen Forum schon gefragt, ob das Problem mittlerweile behoben ist, jetzt wo ich alles einigermaßen am Laufen habe, habe ich keine Lust, wieder die Version 6.5b1 zu installieren... (und diese Version ist auf Grund des bekannten "Umlaut-Fehlers" ohnehin derzeit unbrauchbar...).

Ich werde es aber trotzdem mal als Bug submittieren.

Andreas