PDA

View Full Version : Slightly different wireless network problem!



neilcoburn
2006-04-04, 05:47
I realise there are loads of threads re network problems, though these all seem to refer to problems of Squeezeboxes connecting wirelessly to routers/access points.

I have a slightly different issue. Since moving house, the PC running Slimserver is a long way from my incoming internet connection so I've added a wireless card to the PC so it can connect to the router wirelessly. The signal strength is 'excellent, 54 Mbps', but it still loses the connection a few times a day. It usually reconnects by itself, but about once a day needs me to right-click and select 'repair'. My question is, is this the best I can hope for from a wireless connection, or is it reasonable to expect this set-up to stay connected for many hours and days? If these drop-outs are inevitable, I'll invest in a Homeplug set up. Any thoughts welcome!

abdomen
2006-04-04, 06:25
I realise there are loads of threads re network problems, though these all seem to refer to problems of Squeezeboxes connecting wirelessly to routers/access points.

I have a slightly different issue. Since moving house, the PC running Slimserver is a long way from my incoming internet connection so I've added a wireless card to the PC so it can connect to the router wirelessly. The signal strength is 'excellent, 54 Mbps', but it still loses the connection a few times a day. It usually reconnects by itself, but about once a day needs me to right-click and select 'repair'. My question is, is this the best I can hope for from a wireless connection, or is it reasonable to expect this set-up to stay connected for many hours and days? If these drop-outs are inevitable, I'll invest in a Homeplug set up. Any thoughts welcome!

"Repair" is friendly-talk for "perform a DHCP release followed by a DHCP renew". Perhaps you have more than one device acting as a DHCP server. At any rate, one way to ensure you don't need to keep hitting repair is to assign your computer a static IP address, thus bypassing DHCP. Here's how:

- Open a command prompt (Start-->Run-->type CMD, click OK).
- Type "ipconfig /all" and hit Enter. Leave this window open.
- Open Network Connections (it's in Control Panel).
- Right-click on your wireless connection and click Properties.
- Select "Internet Protocol (TCP/IP)" from the list and click the Properties button.
- Select "Use following IP address" and "Use the following DNS server addresses".
- In each of the fields on the General tab, enter the corresponding IP address from the ipconfig listing in the command window.
- Click OK, and OK again, and close the control panel and command prompt windows.

If you do this, you will need to prevent IP address conflicts (more than one computer/Squeezebox/etc. trying to use the same IP address). One simple way is to assign the computer a static IP that is higher than the ones the DHCP server is assigning. In other words, if ipconfig showed that your computer had been assigned the address 192.168.1.2, assign it 192.168.1.100. The other way is to assign static IP addresses to your Squeezebox and any other computers on your home network, and keep a list so that you do not accidentally use the same address twice.

Good luck!

neilcoburn
2006-04-04, 06:34
Thanks, Abdomen, but I have already done this, suspecting the dynamic addressing wasn't helping. I assigned it 192.168.2.99 to make sure there's no conflicts. I've also tried the dreaded Belkin support line, who told me to change the broadcast channel. I used Netstumbler and I'm using a clear channel as far as I can tell. Any other thoughts?

abdomen
2006-04-04, 07:12
Thanks, Abdomen, but I have already done this, suspecting the dynamic addressing wasn't helping. I assigned it 192.168.2.99 to make sure there's no conflicts. I've also tried the dreaded Belkin support line, who told me to change the broadcast channel. I used Netstumbler and I'm using a clear channel as far as I can tell. Any other thoughts?
Interesting. That prompted me to find out just what Repair might do other than renew DHCP. It does indeed do more! A link with the complete list is below, but it seems clear that the key is this:


The following action has been added to Windows XP Service Pack 1: IEEE 802.1X Authentication Restart

(The following is pasted from an earlier post of mine.)
You may want to try upgrading to the latest nightly of 6.2.2. A number of firmware revisions have been made to correct problems with various wireless configurations. There is a list of wireless configurations that have been tested.

6.2.2 nightly (the .exe file is the installer):
http://www.slimdevices.com/downloads.../latest/6.2.2/

Wireless Access Point / Router Compatability:
http://wiki.slimdevices.com/index.cgi?RouterStatus

MS KnowledgeBase: A Description of the Repair Option on a Local Area Network or High-Speed Internet Connection
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q289256

MrC
2006-04-04, 07:44
The signal strength is 'excellent, 54 Mbps', but it still loses the connection a few times a day. It usually reconnects by itself, but about once a day needs me to right-click and select 'repair'. My question is, is this the best I can hope for from a wireless connection, or is it reasonable to expect this set-up to stay connected for many hours and days?

Be sure to disable allowing connections to other networks. WIndows Zero Config. can attach to a (momentarily stronger) network when your network connection drops. You want to ensure that *only* your network is tried. By default, any access point is a candidate.

To boost your hope, since its debut, I've never lost connection with my Belkin Pre-N, and it runs 24x7. Knock on wood, the thing has been rock solid.

bernt
2006-04-04, 07:44
Are you using Windows wireless configuration?

If you are, try to use the tools that came with your wireless nic instead.

abdomen
2006-04-04, 08:12
When I suggested upgrading SS above, I forgot we were talking about a PC-to-router connection problem. Still the insight that an authentication restart seems to be what reconnects you makes me think you should experiment with enabling a different wireless security method on the access point. If a less-secure method proves reliable, perhaps you could compensate with MAC address filtering.

geoffb
2006-04-04, 08:24
On 4/4/06, neilcoburn wrote:
>
> I realise there are loads of threads re network problems, though these
> all seem to refer to problems of Squeezeboxes connecting wirelessly to
> routers/access points.
>
> I have a slightly different issue. Since moving house, the PC running
> Slimserver is a long way from my incoming internet connection so I've
> added a wireless card to the PC so it can connect to the router
> wirelessly. The signal strength is 'excellent, 54 Mbps', but it still
> loses the connection a few times a day. It usually reconnects by
> itself, but about once a day needs me to right-click and select
> 'repair'. My question is, is this the best I can hope for from a
> wireless connection, or is it reasonable to expect this set-up to stay
> connected for many hours and days? If these drop-outs are inevitable,
> I'll invest in a Homeplug set up. Any thoughts welcome!

Are you sure you don't have anything generating interference in the house?
Once or twice a week, my girlfriend initiates a viscous DOS attack on
our wireless network by heating up something in the microwave. The
wireless phone used to cause problems as well, but I replaced that
with a 5.8Ghz model and that fixed it.

Cheers
Geoff

cjhabs
2006-04-04, 17:10
Once or twice a week, my girlfriend initiates a viscous DOS attack on
our wireless network by heating up something in the microwave. The
wireless phone used to cause problems as well, but I replaced that
with a 5.8Ghz model and that fixed it.

Cheers
Geoff

I have a microwave between my wireless Slim server and router and its guaranteed to knock the connection out every time. The only time I have a problen recovering is when one of the neighbour's wireless networks is generating a strong signal.

Maybe a judiciously placed wireless AP will help.

Habs

bdelp
2006-04-04, 20:18
Check your phone closely. Some 5.8Ghz Phones also use 2.4 Ghz for 1/2 the duplex connection. Found *that* out the hard way.
Bob