PDA

View Full Version : Frustrating new problem



ObjetDart
2006-03-28, 20:45
I've had my SB2 for about a year. Recently, a new problem has developed... the only change recently that I can recall is that I upgraded to version 6.2.1 of the server, but I'm not sure if the problem started immediately after the upgrade.

Basically, whenever I drop a new folder of mp3 files (an album's worth) into my mp3 directory, the server can only access the first file in the directory. I have to completely "Clear library and rescan everything" (which takes forever) to get rid of the problem. After I add another album, I have to do it all over again.

From the SB2, if I navigate to the directory via "Browse Music Folder ->", I can see all the files. I select the first one, and it plays. But when it gets to second track, the SB stops and just says "PROBLEM: CAN'T OPEN FILE FOR:" with no other information. Any attempt to play any file other than the first (alphabetically) from the folder gives the same result.

I tried enabling the d_files and d_info debug flags. The server writes a bunch of stuff to the log but nothing indicating what the problem was other than "ERROR: Couldn't open song."

There is absolutely nothing wrong with these files. I can copy them, move them, even play them in WinAmp on the PC itself. But if I try to add them to the playlist from the SlimServer web interface, nothing happens.

At this point I basically can no longer simply drop a new album of mp3s on to the computer and play them. This is enormously frustrating because this is how I use my SB 90% of the time.

kdf
2006-03-28, 21:21
adding via Browse music Folder should be fixed in 6.2.2 builds. Look on
the download page at the bottom, for the link to pre-release and beta
versions.
-k

ObjetDart
2006-03-28, 21:57
Great, thanks for the tip. Normally I'm a bit wary of running the latest beta builds but this problem is so bad I'm willing to do just about anything at this point. :)

So far, so good...problem seems to be fixed.

kdf
2006-03-28, 22:12
6.2.2 is fairly stable at this point. the risk lies in nearly entirely
with the firmware, since that is also the critical requirement for
making 6.2.2 an official release. the firmware updates are targetted
for fixing a number of wireless connection issues. If you run wired,
the risk should be minimal. if you do run wireless or wired, and run
into any trouble then you should be able to easily backtrack. just
install 6.2.1 again :)

-kdf

treble
2006-03-28, 23:21
Also, you don't have to upgrade the firmware for running 6.2.2. I am happily using 6.2.2 with firmware 28. Anything above doesn't work with my wireless (Linksys WAP54G, WEP64). THere are some posts on this forum with how you can suppress the 'automatic' firmware updates.

mbonsack
2006-03-29, 09:59
6.2.2 is fairly stable at this point. the risk lies in nearly entirely
with the firmware, since that is also the critical requirement for
making 6.2.2 an official release.

Why is the firmware so critical for this release? As you say, slimserver's been stable (for quite some time, I might add) and includes several bugfixes and enhancements that truly affect sound quality (like the volume fix). Why not just release 6.2.2 with FW 28, so that reviewers and others such as the OP leery of beta code will get the best sound, and call the release with the fixed wireless FW 6.2.3? This firmware holdup of 6.2.2 has gone on for *months*!