PDA

View Full Version : Failed to connect to update.slimdevices



tf8252
2006-03-24, 21:57
Anyone know why I'm getting this error?

Tried to run Slimserver...

bash-2.05a# ./slimserver.pl
2006-03-24 22:51:56.2263 There was an error while checking for updates to SlimServer:
Failed to connect to update.slimdevices.com:80. Perl's error is 'Invalid argument'.

tf8252
2006-03-24, 22:05
bash-2.05a# ps -A
PID TTY TIME CMD
1 ? 00:00:02 init
2 ? 00:00:00 keventd
3 ? 00:00:00 ksoftirqd_CPU0
4 ? 00:00:00 kswapd
5 ? 00:00:00 bdflush
6 ? 00:00:00 kupdated
9 ? 00:00:00 mtdblockd
10 ? 00:00:00 khubd
15 ? 00:00:00 kjournald
63 ? 00:00:00 kjournald
184 ? 00:00:00 utelnetd
196 ? 00:00:00 syslogd
202 ? 00:00:00 ekpd
209 ? 00:00:00 ls_servd
215 ? 00:00:00 inetd
219 ? 00:00:00 thttpd
224 ? 00:00:00 lpd
230 ? 00:00:00 cron
243 ? 00:00:00 atalkd
244 ? 00:00:00 smbd
246 ? 00:00:00 nmbd
254 ? 00:00:00 pcastd
260 ? 00:00:00 pcastd
262 ? 00:00:00 mc_ctld
271 ? 00:00:00 papd
273 ? 00:00:00 afpd
406 ? 00:02:01 slimserver.pl
436 pts/1 00:00:00 bash
438 pts/1 00:00:00 ps
bash-2.05a#



Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Tim>ping 192.168.1.5:9000
Ping request could not find host 192.168.1.5:9000. Please check the name and try
again.

C:\Documents and Settings\Tim>ping 192.168.1.5

Pinging 192.168.1.5 with 32 bytes of data:

Reply from 192.168.1.5: bytes=32 time=1ms TTL=64
Reply from 192.168.1.5: bytes=32 time=1ms TTL=64
Reply from 192.168.1.5: bytes=32 time=1ms TTL=64
Reply from 192.168.1.5: bytes=32 time=1ms TTL=64

Ping statistics for 192.168.1.5:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 1ms, Maximum = 1ms, Average = 1ms

C:\Documents and Settings\Tim>

snarlydwarf
2006-03-24, 22:16
Anyone know why I'm getting this error?

Tried to run Slimserver...

bash-2.05a# ./slimserver.pl
2006-03-24 22:51:56.2263 There was an error while checking for updates to SlimServer:
Failed to connect to update.slimdevices.com:80. Perl's error is 'Invalid argument'.

Try: "host update.slimdevices.com" from that Linux box. It should lookup the name and spit out the IP. If it fails, the problem is that the Linux box doesn't have DNS working for some reason.

Is it setup via dhcp? Or is it manual?