PDA

View Full Version : Prefs Explained?



Healy
2003-11-13, 12:03
Hey All,

I've been lurking on the list for a bit now. I'm heading to a shop to see
a slimp3 demo in person this afternoon. I've been running the server
software for a couple of days on both linux & winxp. It's really slick
& I'm 95% sure I'm going to be coming home with a new piece of hardware
under my arm :)

My question is about the prefs. Is there a doc page with a breakdown that
has examples of the prefs by chance? I've been able to hunt through the
directories and figure most of it out.

I am having trouble with authorization however. If I change authorize = 1
enter a username & password in the prefs and then restart the server, it
never lets me in. I know I must be missing something obvious but I can't
figure it out. Allowed hosts contains localhost & the host I'm trying to
connect from. However, filterhosts = 0

Also is there anyway to give a remote user access to be able to pick their
own songs to stream while locking them out of the server settings section
of the web server? I saw a bit of discussion on this in the archives but
it was a somewhat vague.

If this is in a faq someplace, feel free to hit me w/ a clue-bat.

Thanks,

-Healy

Got Trouble? http://trouble.nwgeeks.com/
========================================
The CAT5 to the omega 13 device
is making a weird noise because of Brian Bird...
Verizon is trying to raise 10 million more.

Kevin Deane-Freeman
2003-11-13, 12:47
Quoting Healy <slimp3 (AT) nwgeeks (DOT) com>:

> My question is about the prefs. Is there a doc page with a breakdown that
> has examples of the prefs by chance? I've been able to hunt through the
> directories and figure most of it out.
>
> I am having trouble with authorization however. If I change authorize = 1
> enter a username & password in the prefs and then restart the server, it
> never lets me in. I know I must be missing something obvious but I can't
> figure it out. Allowed hosts contains localhost & the host I'm trying to
> connect from. However, filterhosts = 0

First, you should not be editing the prefs file directly unless you are out to
prove something. ;) All the prefs are accessible from the server settings or
player settings within the interface. Authorisation is explained ON the
settings pages regarding authorisation. You can choose password control, and
blocking by IP address. The web server should take care of the prefs file on its
own

>
> Also is there anyway to give a remote user access to be able to pick their
> own songs to stream while locking them out of the server settings section
> of the web server? I saw a bit of discussion on this in the archives but
> it was a somewhat vague.

For now, its all or nothing. You can start the server with --nosetup to block
users from changing any settings permanently, but there are no "per-user" or
"per-page" access controls.

-kdf

michael
2003-11-13, 14:19
Kevin Deane-Freeman <kevin (AT) deane-freeman (DOT) com> writes:
> First, you should not be editing the prefs file directly unless you are out to
> prove something. ;) All the prefs are accessible from the server settings or
> player settings within the interface.

well, except that the interface refuses to believe that I really do
want the web server to answer on port 80, and so I usually have to
tweak the prefs directly to "convince" it of that point. :)

-michael

Kevin Deane-Freeman
2003-11-13, 14:38
Quoting michael <michael (AT) fallenangel (DOT) com>:

> Kevin Deane-Freeman <kevin (AT) deane-freeman (DOT) com> writes:
> > First, you should not be editing the prefs file directly unless you are out
> to
> > prove something. ;) All the prefs are accessible from the server settings
> or
> > player settings within the interface.
>
> well, except that the interface refuses to believe that I really do
> want the web server to answer on port 80, and so I usually have to
> tweak the prefs directly to "convince" it of that point. :)
>
> -michael

That setting should still be accessible from within the server settings
(advanced). If the setting is not sticking, that could be a bug which is
blocking the setting from being stored.

-kdf

michael
2003-11-13, 14:41
The setting is accessible, on the page. I can set it to port 9000 with
no problem. It just doesn't think that 80 is a valid value.

"New value for Web Server Port Number rejected:
Invalid value specified: 80"

Thus I muck with prefs by hand (only for this one setting) and it
happily works.

-michael

Kevin Deane-Freeman <kevin (AT) deane-freeman (DOT) com> writes:
> Quoting michael <michael (AT) fallenangel (DOT) com>:
>> well, except that the interface refuses to believe that I really do
>> want the web server to answer on port 80, and so I usually have to
>> tweak the prefs directly to "convince" it of that point. :)
>>
>> -michael
>
> That setting should still be accessible from within the server settings
> (advanced). If the setting is not sticking, that could be a bug which is
> blocking the setting from being stored.
>
> -kdf